Repository List of apps that do not work


#1

I could not get apps “Bristol” nor “Gnomoradio Music Player” to launch.

It would help newbies if there was a note in the App Cafe about which apps are unstable
or still in development or no longer being maintained by developers upstream, etc. etc.

Also, on a different note,

I was playing with all the sticky note type apps and I have not
yet found one that I like ( upon first glance )

Also,

There is an app somewhere on the web called “Great Little Radio Player.” I like that, but do
not have any idea what alternatives there are or how easy it is to install.


#2

look at clementine. it works on my systems


#3

Clementine is definitely a popular product. I was not aware it had an Internet Radio feature. I had already installed it, and also had played with it once before months ago. I just now found
2 free music channels Magnatune and SomaFM. Each of those had a dozen or more sub-categories of either artist or genres. So lots of free music there. But after 10 minutes, I did not find anything I wanted to listen to. I will keep researching this, as I have ZERO experience with online music or freeware relate to music streaming.

I just found another free channel on Clementine called Icecast. That had some free music that I liked.


#4

AppCafe

That’s a great idea.Thanks.

Would you like to make the enhancement request?

https://github.com/trueos/trueos-core/issues/ can cover AppCafe.

https://www.trueos.org/handbook/helpsupport.html#report-a-bug for guidance that is problem-oriented. Some of the principles that apply to bug reports (BRs) can apply to enhancement requests (ERs).

Hint and observations

It seems that security vulnerabilities are indicated only after installing what’s vulnerable. For example:

AppCafe invitations to clean may be tempting, but I recommend caution. Before experimenting:

  1. create a boot environment
  2. activate the environment
  3. restart TrueOS to experiment with the environment.

Pre-installation

For many of the non-installed items that can be browsed with AppCafe, there is a definitive page at FreshPorts. http://www.freshports.org/audio/gnomoradio/ for example.

If you use Firefox, you might like the FreshPorts.org add-on:


#5

That’s a great idea in theory; sadly, not so in reality. There are simply to many things in the package repo for us to update that kind of information on a package by package basis. I think there’s roughly 1500 packages in the repo, is someone going to volunteer to search for that information for every package?

We are dependent on FreeBSD for information about package updates, security issues, etc, and to my knowledge FreeBSD does not bundle that information. What information is there, is usually provided by the individual port maintainers. What information they choose to add/provide will vary greatly between the different maintainers. On top of that, there are some ports which dont have current maintainers. In other cases there are ports that have been abandoned by the original developer, but still exist in the ports tree by a very dedicated Port maintainer trying to keep the software running on FreeBSD.

Edit: This is a perfect example of something that people in the community can do when they have free time and are willing to try to help other users. Anyone can create a wiki for this information on the TrueOS subreddit: https://www.reddit.com/r/TrueOS/wiki/index (You will need to register and you may need to make a post in the subreddit first before being able to make pages, I forgot how I set it up initially).
If anyone wants, start making a list of what works and doesn’t work, when they last tested it, any other information they can find… and every 3 months or so go back and verify what’s on the list.


#6

Indications such as the no entry icon :no_entry_sign: in the first screenshot.

@beanpole135 please, from where does AppCafe get the post-installation information about installed vulnerabilities? Is it the result of a run of pkg with the audit option?

With a local copy of source code as a rough guide, I wondered whether there’s any hint here. At a glance, I see none:

$ grep -r -i vuln /usr/ports/www/chromium
$ grep -r -i secur /usr/ports/www/chromium
/usr/ports/www/chromium/pkg-plist:%%DATADIR%%/resources/inspector/Images/securityIcons.png
/usr/ports/www/chromium/pkg-plist:%%DATADIR%%/resources/inspector/Images/securityIcons_2x.png
/usr/ports/www/chromium/pkg-plist:%%DATADIR%%/resources/inspector/security/security_module.js
/usr/ports/www/chromium/Makefile:               libgnome-keyring.so:security/libgnome-keyring \
/usr/ports/www/chromium/Makefile:               libgcrypt.so:security/libgcrypt \
/usr/ports/www/chromium/Makefile:               libnss3.so:security/nss \
/usr/ports/www/chromium/files/patch-base_security__unittest.cc:--- base/security_unittest.cc.orig       2016-05-11 19:02:11 UTC
/usr/ports/www/chromium/files/patch-base_security__unittest.cc:+++ base/security_unittest.cc
/usr/ports/www/chromium/files/patch-components_url__formatter_url__formatter.cc:   // http://www.unicode.org/Public/security/latest/xidmodifications.txt) are
$ 

– whilst /usr/ports/www/chromium/files/patch-components_url__formatter_url__formatter.cc does include the phrase ‘security’ within a URL, as far as I can tell (from the file in its entirety) it’s unrelated to the vulnerability that AppCafe shows for the installed version of Chromium.

$ time pkg audit | grep is\ vulnerable ; uname -v
gstreamer-ffmpeg-0.10.13_4 is vulnerable:
gstreamer-ffmpeg-0.10.13_4 is vulnerable:
gstreamer-ffmpeg-0.10.13_4 is vulnerable:
libav-11.7_5 is vulnerable:
libav-11.7_5 is vulnerable:
libav-11.7_5 is vulnerable:
mysql56-server-5.6.34 is vulnerable:
gnutls-3.4.17 is vulnerable:
linux-c6-curl-7.19.7_8 is vulnerable:
irssi-0.8.20 is vulnerable:
w3m-0.5.3_6 is vulnerable:
libressl-2.4.4 is vulnerable:
chromium-54.0.2840.100_1 is vulnerable:
php56-5.6.29 is vulnerable:
linux-flashplayer-24.0.0.186 is vulnerable:
lynx-2.8.8.2_4,1 is vulnerable:
py27-pillow-3.1.1_1 is vulnerable:
libvncserver-0.9.10_1 is vulnerable:
icoutils-0.31.0_1 is vulnerable:
thunderbird-45.5.1_6 is vulnerable:
        0.29 real         0.29 user         0.00 sys
FreeBSD 12.0-CURRENT #14 f92c24b(drm-next-4.7): Fri Jan  6 19:28:21 UTC 2017     root@gauntlet:/usr/obj/usr/src/sys/GENERIC 
$ 

#7

There’s also an upstream FreeBSD security database, check your daily and weekly periodic jobs for that output (assuming you have appropriate config set). /etc/periodic/daily/450.status-security (part of port audit as shown above)

As for broken ports, the “MOVED” file in the ports tree often has ports that won’t build (grep -i broken MOVED at the top of the ports tree)


#8

@grahamperrin : Yes, pkg audit is used to provide the information on which installed packages have security vulnerabilities. That is why it only shows up on the “installed” tab, since pkg audit cannot be run against an entire remote repository (as far as I know).


Defensive computing with TrueOS Desktop
#9

… cvs-all … FreshPorts takes these mail messages, parses them, …


#10

I was chatting with one of the experienced contributors today to FreeBSD and he said his
favorite game was “Moria.” So I tried to install that. But the installation failed. I emailed
him about it. He was quick to respond back to me on my first email, which is really great
from a novices point of view.


#11

The game “Blood Frontier,” begins to launch, but then vanishes into thin air. I have no idea
if it is still running in the background. However, I do not have a video card. I turned off all the
options for extra graphics. The title says it is version 0.85 ( Beta 2). The game development was
in 2009, but was discontinued by 2013.

The rumor is that “Red Eclipse” evolved out of the discontinuance of Blood Frontier, meaning
it was forked. Seems like Blood Frontier should be removed, if nobody can figure out how to make
it play. I just tried Red Eclipse in TrueOS having only briefly tinkered with it in a Linux distro. I had
to turn off all the extra graphics to get it to work, but that is likely related to my integrated graphics,
I would be guessing. Also, Sauerbraten played okay, after I turned off all the extra graphics.

I just did the same test with the game “Tesseract,” and it too played okay, after I turned off all the
special effects under Options menu, under Display and Graphics.


#12

run from shell will give an better idea as to whats happening


#13

If I recall, Blood Frontier requires openGL acceleration (even with all the graphics turned down) - so most likely it is crashing when trying to load/use that library.

Just go get yourself a cheap $25 nvidia graphics card (Newegg Link) and that should give you the capability to play all/most of the games in the package repo. :slight_smile: