RC3 - update (taken from telegram) - discussion thread


#42

very weird. I have RC3 installed on this laptop, running RC3

I have 32G of hard drive space, using UEFI boot.

Do you have 64bit enabled?


#43

Yes, it’s enabled. Version is “FreeBSD 64-bit”


#44

@rowo

how much memory did you allot to the to the VM? How much memory is on your computer?

are you hitting CTRL-C by chance?


#45

PC has 6GB, VM has 1 GB, virtual partition has 16 GB. No, didn’t hit any key.


#46

can you go from 1G to 2G, and double the disk size?


#47
If you still have your RC1 media, install that and then upgrade to RC3 
per Rod's post:
<URL:https://discourse.trueos.org/t/rc3-update-taken-from-telegram-discussion-thread/3431/17?u=jgroenveld>

John
groenveld@acm.org

#48

Just trying with 2 GB


#49

Unfortunately I don’t have RC1 any more. Is it still available on a website?


#50

no RC1 iso, but this one http://pkg.project-trident.org/iso/archive/RC2/


#51

I still have RC2, but there the boot loader didn’t work as well.


#52

And this solved the issue: 2 GB of RAM is needed.


#53

So RC3 works in a VM.


#54

I think the download page recommends 2G memory (says minimum is 1G). From experience ZFS doesn’t do well at all with limited RAM, I would have put the requirements at minimum 2GB, recommended of 4GB.

@rowo glad you got it installed and running.


#55

Update works as promised (starting from RC1 BE).
Thanks, @RodMyers, for the hint!

Although I’d consider the RCs more like Betas, tbh.
E.g.:

  • Wine not working anymore (compared to RC1)
  • “about” not present in any of “my” /bin folders (RC1 & RC3). I guess my RC1 (into new BE) installation wasn’t “perfect” because others don’t seem to miss “about”. So RC3 update didn’t fix that for me.

Though: No waiting at/after login. Maybe because I use xfce or because I disabled automount a long time ago and it’s still disabled (haven’t checked - forgot about that, tbh).

As stated before: Not compaining, just reporting.

I’m not in a hurry and waiting patiently for the release version - whenever it’s ready.


#56

It was not installed by default on my system either. To get the about command I installed the package trueos-utils-201710251127.


#57
<URL:https://github.com/project-trident/trident-core/issues/22>
John
groenveld@acm.org

#58

Thanks, @jgroenveld, for the hint.
Now I’m back in the “about” business, as well. :slight_smile:


#59

Finally I succeeded to install RC3 on a SSD :wink:

It was a bit tricky: I had to install FreeBSD-13-CURRENT on my 2nd HDD first. During the installation the FreeBSD boot loader found RC2 on the SSD and generated a valid entry for it. So I can boot it by using F12 during the BIOS startup and then choose the 2nd HDD which start the FreeBSD boot loader and let me choose the entry for Trident. Simple, isn’t it? :wink:

I then fetched the config script
fetch http://pkg.project-trident.org/repo-config/install-trident-repo.sh
and executed it.
After that I did
trueos-update upgrade
It took about 50 minutes to upgrade and another 5 minutes after reboot to finish it.

I can’t change to german locale and keyboard layout, you can see the error message in the screenshot.


#60

The keyboard layout problem could be solved by installing setxkbmap and adding
setxkbmap de
to ~/.xprofile


#61

Tried to install RC3 into a BE on my laptop which is running 18.03 and received the error message “cannot open ‘/boot/lua/loader.lua’ , no such file or directory”. This is followed by the statement that the boot failed. I had downloaded RC3 with this laptop and then transferred the iso to a fresh USB3 stick via the dd command. dd reported no errors. Examining the USB stick, I find the file /boot/lua/loader.lua exists. Reading through the file, it is not obviously corrupted. The laptop is a Zareason Alto 4335 built in 2014: AMD64, 4 GB ram, 500 GB HD. It works well with 18.03. Any suggestions? Thanks.