RC3 - update (taken from telegram) - discussion thread


#22

Was it on a upgraded RC3 or new install RC3?

I’m getting ready to nuke the upgraded RC3 to test a bare metal install RC3


#23

was on an upgrade from RC1 to RC3


#24

Ok, hopefully I get back to a lightning quick login time on the “new install RC3” :slight_smile:
PS.
And the icon-stuff is also fixed in next RC - perfect!


#25

Ok, then 3 times. I only did it 2 times and it still didn’t work although it shows that the service was started.

service moused start
service moused status
status: started


#26

i have had to keep moving the mouse during each switch back to the installer.

Is this a new install? or BE upgrade?


#27

if you can be at a console what is the output of “ps aux | grep -i mouse” does it actually show a process running?


#28

I tried a fresh install. Now I actually repeated start/stop the process 20 times but it still doesn’t work. I also went to the first console, stopped the installer, checked the mouse service, restarted it several times but still no success. I’ll try the “move the mouse all the time” trick right now. The process table didn’t show any “mouse” process.


#29

If the output of ps aux does not show anything for moused then the process is not running. The process not running means the mouse does not work.


#30

On Telegram a user had the problem, that a HW kernel module wasn’t loaded and had to do:

> kldload i915kms

Maybe try to load your required HW kernel modules…


#31

That is only needed for Intel hardware but I have an AMD system with a NVIDIA 520 GT, which works well except for the USB mouse.


#32

So it still doesn’t work., after about another 20 retries. I’m wondering why the service seems to be started after

service moused start
service moused status

  • status:started

Moving the mouse constantly during start/restart/stop also didn’t work.


#33
Install TrueOS 18.06:
<URL:https://www.trueos.org/downloads/>

Configure network and ssh so you can remote into it.

Migrate it to Trident per the tool Rod posted upthread:
<URL:https://discourse.trueos.org/t/rc3-update-taken-from-telegram-discussion-thread/3431/17?u=jgroenveld>

If your mouse still doesn't work at least you can provide more 
live data in your bug report for the developers.
John
groenveld@acm.org

#34

Found the biggest culprit of the slow login in this thread:


Removing a connected USB-drive reduced the login-time to approx. 5 sec. - still longer than before RC3 but acceptable :slight_smile:


#35

Well, I installed 18.06 but it doesn’t boot. The system gets into an endless loop where nothing visible happens any more.


#36

1806 is the server.not desktop offering.


#37

I know that but at least it should boot using its own bool loader.


#38

1803 was the last using forth


#39
Agreed.
I guess its back to TrueOS 18.03 so you can grab 
dmidecode(8) and pciconf(8) -lv output for your bug report.
John
groenveld@acm.org

#40

I could successfully install 18.03 and Trident RC1 before - and they booted well, but neither RC2 nor 18.06 boots.


#41

Unfortunately I can’t install RC3 in a VirtualBox using Antergos.