RC3 - Current trident build


#1

This link is available via the Project Trident web site

okay folke, this is the upcoming build —> https://builds.ixsystems.com/poseidon/jail.html?mastername=trident-master-current <— fingers crossed in its success

edit Oct 26, 2018

quick update on the build status.

a number of builds have been done. A fair number of packages have been failing. in particular GCC7/8. with that failing, numerous other packages have either failed or been “ignored”.

@beanpole135 has been in touch with the trueos devs, and it seems fsb is/was having issues.

Maybe, one more update, and that issue will be resolved

edit: update: 27 Oct 2018

@JT will be taking over DE (development engineering) from @beanpole .

Build #186 is in the queue generated. This should, hopefully eradicate some of the major issues with ports

With FreeBSD-CURRENT about ready to become RELEASE, this may be our last 12 release as well

edit: update: 28 Oct 2018

taken from telegram

@beanpole135TrueOS just pushed out the new packages with the fixes for the base itself - needed on the build server to get those ports to build
I cancelled 186 before it started and updated the build server itself

so the good build should be running now

TrueOS snapshot packages. Apparently FreeBSD broke something in base which was causing all the GCC packages to fail to compile (with huge amounts of ports getting skipped due to this)

Okay, just looked. It was a full build. meaning it needed to rebuild the entire ports tree. At the time of this posting there are 26621 packages still needing to be built

keep track of it here --> https://builds.ixsystems.com/poseidon/build.html?mastername=trident-master-current&build=2018-10-29_15h21m18s

edit: update: 31 Oct 2018

taken from telegram

just walked in, so …

The word I received while out, FreeBSD is dropping support for QT4 in December. so it won’t be looked at. 4 of my programs are within the QT4 failures and skipped. Sucks but it is what it is.

As for NOT being released today. As some noted, the jenkins page lost connection with the build server… I watched the build server, thank you @q5sys for the pics. The build was successful, but could NOT run the ISO build & stage phases, they need the jenkins server functioning… That is being looked at by an iX employee, and doing what is necessary. Once at work, @beanpole135 will rerun build. at this point NOTHING should need to be rebuilt. It’s needed to the build ISO and stage portions. The it should be ready for testing.

As for the RC naming scheme, you may have noticed the mess chasing the trueos changes. as of now, and nothing has been said otherwise, until the 1812 trueos release is out in the wild, Project Trident will probably stay in RC status. When trueos get a better stabilized release, the going to full release.

now we all now @beanpole135 & @q5sys hang out here. Please, start a thread over on https:…duscourse.trueos,org … This way, they get the benefit of seeing this same message, and let the whole community get involved.

that is all :blush:

edit: 2 November 2018

Still chasing trueos changes. The actual build went smoothly. It’s the trueos specific changes that @beanpole135is chasing down. The built packages have not been lost. once the scripts have been tweaked enough. We should get a new ISO/release this weekend

taken from telegram:

Ken Moore, [02.11.18 12:46]
yep - so much is new in the build system itself that we are still finding/fixing/adding things to it as needed

Ken Moore, [02.11.18 12:48]
for example - we have a bunch of world config options staged as well, but discovered when we tried it that those flags are not properly updating the base packages for a successful build: Example: “WITHOUT_SENDMAIL=1” properly skipped building sendmail, but then it still tried to package up sendmail as a base package and failed

Ken Moore, [02.11.18 12:48]
still finding things like that

Ken Moore, [02.11.18 12:49]
so I have all those world config options staged, but not enabled yet until I hear back that those are fixed in teh base package builds

Edit:
4 Nov 2018

okay. it seems that LibreOffice is finally building properly, and as I write this, just the language translation files are successfully building as well.

So, fingers crossed

edit:
5 november 2018 0 Dark thirty

build was successful. only some of the qt4 app are depreciated.

will do a clean install and upgrade in a BE.

I think we may a winner

edit:
5 november 2018 0 light outside

the installer script failed to be installed on ISO

edit
taken from Telegram

Ken Moore, [05.11.18 08:09]
I found the issue - sending in fixes to the TrueOS build system…

Ken Moore, [05.11.18 08:09]
should be able to get these merged and another build finished in a few hours

Ken Moore, [05.11.18 08:10]
since all our packages are fine - just need some fixes to the build system itself

Edit: 6 November 2018
Build 203 is running as expected.

From telegram

Ken Moore, [06.11.18 09:49]
The big issues with build 201 were:

Ken Moore, [06.11.18 09:51]

  1. /sbin/service was removed - only /usr/sbin/service is available now (2 fixes in place for this now)
  2. Pulseaudio default config was getting installed by the pulseaudio port now - and installing a config that is fundamentally broken. We switched that back over to overwriting the default config with the Trident config file for pulseaudio and it all seems to be working again.

Ken Moore, [06.11.18 09:53]
the good news is that all those fixes could be placed into teh Trident packages directly - no need to commit and re-pull TrueOS in any way - so this build should be fairly fast as only a few ports got changed (from our ports overlay)

chasing the ever changing trueos updates.

so, once build #203 finishes, there will be a fresh install, on bare metal and virtualbox, and maybe a BE install. If promoted, I will attempt to do an in place upgrade as well

https://builds.ixsystems.com/jenkins/job/Trident-Master/job/Trident%20Master/

Edit Nov 07, 2018

Ken Moore, [07.11.18 09:59]
Update on the RC3 builds:
The latest builds seem to have all the ports/package issues resolved with TrueOS 18.10+, and the Trident packages are all working well in our testing.
We did run into one major issue though which is trivial to fix but will take a bit of time: The package cache on our build server apparently did not get cleaned out/updated appropriately when FreeBSD switched the base version of SSL to OpenSSL 1.1.1 - so quite a lot of our packages are crashing when started becuase they were older packages which were compiled against the libressl in base (TrueOS 18.06). I just logged into the build server and nuked all the pkg caches and build objects to ensure that the next build is completely fresh, but that means this build will probably take 48-72 hours to complete since it has to build the entire ports tree from scratch again.
So for those that want the short version: RC3 is looking good but will require one more long build before we can push it out.

I suppose I should mention that all the TrueOS build system updates also seem to be completely and working perfectly fine now as well. That is another big win because we can stay on the same “base” version of TrueOS for quite a while now

edit:
9 November 2018
Ken Moore, [09.11.18 08:54]
RC3 builds look like they will be done this afternoon sometime


#2

The most interesting thing about having this status online is the amount of time it takes to do a complete build. Looks like the average is about a day and a half. Reminds me of doing Ada builds on a Vax via batch jobs overnight.


#3

That’s a reason I try to keep here & telegram informed, and why it was decided to post the link via the web page.

I can see the builds and know what is going on, and I get frustrated. I can’t imagine being a regular user, waiting in things.

And thank you @mer and the others, that have helped everyone.


#4

Moving to 13-CURRENT. That winds up making almost 10 versions of FreeBSD I’ve run (first was something like 3.3).


#5

lucky bastard :slight_smile:

i found linux first, way before freebsd :frowning:


#6

I found BSD first, but it was way above my head, so I took the easy way out, and used Linux.


#7

I found Linux first as well but never understood where the software is getting installed or the home directory is placed. Then I discovered GPL, then BSD revealed itself to me :smile:


#8

Very good way to put it.


#9

just a thought, like the reason I switched to BSD was

Linux is thinking, I am thinking as well. We both are thinking, and nothing get’s done :laughing:

except for drivers I don’t honestly understand why would someone install Linux.

All Linux guru’s haven’t read the GPL, they think going against the law is contrarian. Except that GPL is contrarian contrarian.