RC1 has been unleashed


#1

RC1 Release Notes:

  1. Installer: Ability to customize ZFS pool name for installation
  2. New Xorg auto-configuration routine - will automatically pre-set the appropriate xorg driver for every GPU in the system (but uses Card0 by default at the moment). This can be overwritten by creating/customizing “/usr/local/etc/X11/xorg.conf” if manual changes are desired.
  3. Updated ports/packages (FreeBSD ports from 9/25/2018)
  4. SysAdm will no longer start automatic updates, and the AppCafe is now functional again.
  5. New Xorg setup script system: Can create *.sh bourne shell scripts in /usr/local/etc/xstartup[-parallel] to have them automatically loaded when starting a graphical session. All the TrueOS xorg script have now been re-activated in project trident for things like GTK scaling, [ssh/gpg]-agent, fcitx input methods, etc…

Not included in this release (will be included in future updates):

  1. Passing config options (for localization/keyboard settings in particular) from the installer to the installed system.

#2

Thanks for the Insider info :wink:

But. will it run iocage - lol

On the serious side, can trueos-update upgrade bring that into Beta 3?


#3

no updating, been disabled.

trueos-base is changing MANY underneath. :frowning:

until 1806 is released, we won’t chase that bunny

edit:

damn man, you’re picky :wink:

I did mean 1812


#4

I’m looking at this and I’m seeing 18.06 stable, interesting :thinking:


#5

I fell asleep at 18.03. Now, I’m waking up and looking around to see what’ going on :astonished:


#6

(Hit the snooze, go back to sleep)


#7

Does this mean the stable release isn’t planed until December?

I actually see that as a good thing since that may mean that it’s hopefully is really tested out so as few bugs as possibly will occur.

So did/am I :wink:

I will too, while I wait with excitement for the stable release :laughing: :sunglasses:


#8

this is STABLE. 1806 is the stable branch. no more UNSTABLE on trident. Correct, the trueos STABLE is on the 6 month release schedule.

we’ll be in RC status until trueos 1212, and hopefully they will have quit messing with things under the hood


#9

I’m still unable to install into a new boot environment.

I’ll keep on waiting for RC2… :persevere:


#10

whats happening?


#11

Still the same as before.


#12

the option is there.

This is RC1 in a BE.

Can you take a screen shot?


#13

No, I cannot.

The option is there - but disabled.

All disk partitions are displayed fine, including the ZFS partition. I can select it. But it does not enable that option. No matter how hard I click on it.


#14

It looks like there are 2 buttons, have you tried selecting them both?

This is a screen shot from RC1 within Virtualbox


#15

Yes. Only the first one is selectable.

Edit: I actually do it after having changed locale settings, time zone, machine name… I hope it doesn’t matter.


#16

can you install RC1 within VirtualBox to see it that works?

edit:
have you thought of installing rEFInd, and dropping grub


#17

VirtualBox? I have never used it. I think it is a little too much for me. :frowning:


#18

Dropping Grub? No. I don’t think it should be necessary. I already have some boot environments. I think I just need to add another one there.


#19

Try not choosing the ZFS partition specifically and just leaving the disk itself highlighted.

I didn’t have to click the specific partition that TOS was on. I just left the disk itself selected and it let me pick the boot environment option. Granted the system wouldn’t boot with RC1 so I rolled back but it should at least give you the option to use boot environment.


#20

Thanks. I have already tried it. My first action (having changed locale settings, time zone and machine name) was to click on the BE button. No response at all.