Qterminal missing top bar


#1

Hi,

When I installed TrueOS my qterminal has top bar. After system updates(not sure its package has been effected) it is disappeared. I did remove and install several times but no help. How can I recover it. Thanks.

Package Detail

[uguler@trueos-7861] ~% pkg search qterminal
qterminal-0.7.0_1 Lightweight Qt-based terminal emulator
qterminal-l10n-0.11.0 Translations of Qterminal
[uguler@trueos-7861] ~%

System Information

[uguler@trueos-7861] ~% about

===================
General information

boot environment now (N) … 12.0-CURRENT-up-20170626_185306 NR 2017-06-26
after restart ® … 12.0-CURRENT-up-20170626_185306 NR 2017-06-26
boot loader …………………………………… BSD
type ……………………… BIOS
CPU ………………………………………………………… Intel® Core™ i5 CPU M 560 @ 2.67GHz
number of cores ……………… 1
host ……………………………………………………… trueos-7861
memory ………………………………………………… 2047 MB available, 990 MB free
OS git branch ……………………………………………………………………………………… trueos-stable
OS git revision ………………………………………………………………………………… ac2f0aa3b
OS kernel build time ………………………………………………………… Wed 2017 Jun 21 01:09:23 UTC
OS kernel identity …………………………………………… (uname -i) GENERIC
OS platform (architecture) ……………………… (uname -m) amd64
OS release level ………………………………………………… (uname -r) 12.0-CURRENT
OS version and patch level …… (freebsd-version) 12.0-CURRENT
TrueOS package set ………………… STABLE
TrueOS version …………………………… TrueOS-Desktop-201706210948
uptime ………………………………………………… 54 mins
user …………………………………………………… uguler

More (TrueOS Desktop):

desktop environment …… Lumina
sound card driver ………… pcm0: <Sigmatel STAC9221 (Analog 5.1/2.0)> (play/rec) default
wireless driver ……………… 
X11 drivers ………………………… vboxvideo_drv.so

#2

I’ll confess to not quite understanding the differences, but there have always been two versions of the application: QTerminal and QTerminal drop down. With the drop down variant, the top bar doesn’t seem to be there, but the other version has the top bar (TrueOS-Desktop-201706210948 build).


#3

So strange. I also have same build but both version don’t have top bar. I install same build to Asus laptop, on it there is no similar issue.


#4

This happened to me while testing out TrueOS in Virtualbox. TrueOS never seems quite happy when it is virtualized. After installing TrueOS on my laptop the problem went away.


#5

I’ve seen this bug with intel driver several times - switch to modesetting or scfb video driver and this (plus other glitches) should disappear.


#6

i don’t have a title bar on either qterminal under virtual box either, which means i can’t find a way to move it.

However everything else seems to be working exceptionally well under virtualbox at this point. I’m really enjoying Trueos now.


#7

Thanks @sko. I have changed to vesa top bar came back :slight_smile: