Project Trident 1812 release - discusion here


#22
It was easier for me to backup my home directory and
my configuration and wipe and install fresh then to debug 
pc-sysinstall to figure out why it was falling over on my
TrueOS 18.03 GPT, zpool and BEs.
On further reflection, perhaps it wouldn't have been too
difficult to identify the upgradable check routines and run them on top of 18.03.
I didn't want to have to build installation media just to 
instrument the thing.
Didn't seem like much fun.
John
groenveld@acm.org

#23

more than likely the freebsd bootloader changing from forth to lua.

finding forth BE’s was a roll of the dice everytime


#24

Hello Rod,
May i ask you if is advisable once installed to keep the trident 18.12 prerelease2 and update it to reach the same level of features/security/stability update of the later released stable 18.12.
I mean keeping the prerelease and updating i lose something respect a fresh install of the stable one? also in terms of disk fragmentation of the installation and so in speed and smoothness and not just in terms of the updated packages and kernel.
Thank you and forgive this possibly silly question just before i start to understand better how this system works.
Cheers, Paolo.


#25

Not ready to go that “backup and start anew” route… :slight_smile:

Not sure if that

On further reflection, perhaps it wouldn’t have been too
difficult to identify the upgradable check routines and run them on top of 18.03.

goes in that direction but I once tried upgrading my TrueOS 18.03 system by editing files to match the trident ones for update check. Well, it went pretty wrong… I can tell you that much. I learned that my knowledge - if you even can tell it that - about trueos/trident/bsd isn’t sufficient enough to upgrade from 18.03 to trident. But if it were there would be an official tutorial because it could be difficult if I could figure it out… :slight_smile:


#26

I might be rolling the dice a few more time, just to make sure… maybe the number of existing BEs or some property of them plays a role…

But you can bet on it - should I succeed against all odds I’ll present my findings here!


#27

With a "release" version present, it was time to upgrade my main system which was still TrueOS 18.03 (Lumina).

First I tried to install into a boot environment. Initially the option was not accessible but the workaround via "Go to terminal - Login as root - start-trident-installer" did it on my system and I installed into a boot environment.

This installation went well but it was impossible to boot this boot environment. Looking into the available boot environments resulted in finding nothing. All the old boot environments were gone.

That didn’t surprise me since all the talking about the upgrade path for TrueOS 18.03 was very specific in clarifying there won’t be an upgrade path. :sunglasses:

The installation on a classic HDD was flawless but now is waiting the tedious work to organize everything again.

This fresh install is looking very different than my test system which was upgraded via release canditates and prereleases. The current defaults are better eye candies.

Dear developers, thank you very much for a nice looking and (at least up to now) well functioning desktop system!


#28

I’ve upgraded, pretty much every release on this laptop.

Occasionally, updates don’t go as planned. I had to roll back a dew BE’s to get a good upgrade to this release.

That’s what BE’s are for, that “just in case” moment.

No silly question.


#29

Here, web page, and on Telegram. We’ve made it very clear, there was NO direct upgrade path from 1803. for a number of reasons. trueos changed underneath so much, and the freebsd bootloader changing from forth to lua. Just to name 2 important reasons.


#30

The missing BE’s are a random issue with the FreeBSD bootloader language moving from forth to lua.

Once the devs were hit with that, myself included, was decided NO upgrade path from 1803, which was a pain, since I had 1803 on this laptop as well. :frowning:


#31

to install in an USB pendrive volume, are the instructions exactly the same as written in the Trueos installation section manual ?


#32

yes.

be advised it will be SLOW, but workable as a demo


#33

my Trueos 18.03 full installation on an usb 3.0 pendrive does not seem to be so slow


#34

well there must be something different from my previous TRUEOS 18.03 usb installation experience. I write the iso file to installation media (an USB stick volume) with Win32 Diskimager as per TRUEOS installation manual, but then the volume is not bootable, it is just not detected at boot menu.


#35

You state that you followed the instructions as per TrueOS. There are differences between TrueOS 18.03 and Trident 18.12, so the TrueOS instructions may not be reliable. Here are the Trident instructions:

  1. Download the installation ISO.
  2. Change the downloaded ISO’s extension from .iso to .img.
  3. Write the .img file to the USB disk using Win32 Disk Imager

Source: https://jdrch.wordpress.com/tag/project-trident/

I also found the following comment re Win32 Disk Imager:

“Warning: Issues have been reported when using to write to USB Floppy drives (and occasionally other USB devices, although very rare). While this has been fixed in v1.0, it is highly recommended that before an image is written to a device, the user should do a Read to a temporary file first.”

Source: How to create an a Project Trident USB installer disk in Windows


#36

ok, I had already followed the steps 1 to 3, and I use the Win32 Disk Imager 1.0 . I’ll might want to try to write the iso to a DVD for booting.


#37

Not sure why renaming the downloaded iso to img is necessary. I wrote trident isos using Win32DiskImager which booted fine.

I stopped writing the iso to the thumb drive using windows because the resulting medium is crashing windows as soon as it’s done and Win32DiskImager is closed, or if it’s plugged-in while windows is booting. Something that never ever happened with any TrueOS lecagy iso.
There are two partitions, one of which contains a uefi folder. Not sure if back in the TrueOS lecagy there were also two partitions on a usb install medium.

Anyway I resorted to write the usb inistall medium on my TrueOS medium (dd) to avoid harming my windows partition by constantly crashing it - but that problem will vanish anyway when I’m finally successful in getting the installer allow me to check the “install into ne BE” option on that particular system.

Not sure if

3. Switch boot mode from UEFI to Legacy.

shouldn’t be the other way around. As far as I remember, when trying to tweak my system in order to get the “install into new BE” un-grayed-out I swithced from UEFI to legacy and subsequently booting the install thumb drive didn’t work.
I might have to try that again just to make sure - and maybe trying a good old DVD medium.

[Update]
Just checked:
USB install medium only boots with UEFI enabled.

[Edit] Strange thing: On my laptop where I can choose between legacy and UEFI (or both) in BIOS the usb install medium only boots with UEFI enabled. On my test system where there is no option to choose between legacy and UEFI in BIOS - which lets me assume that system does not have UEFI - the usb install medium boots fine… ???
[/Edit]

DVD install medium boots with legacy and UEFI, respectively. But takes for ages and in legacy mode I couldn’t get x server to work, i.e. start-trident-installer does not load -> installation not possible on my system. In UEFI mode it’s not any different from USB install medium -> “install into BE” not “checkable”.
[/Update]

My last hope would be transplanting a trident BE from my test system over to my main system, get it to boot, update it and get the new bootloader installed on that system that way… we’ll see.

Regarding the problem with the “install into new BE” option being “checkable” on one system but not another might be due to the fact that on the first system the drive has 3 partitions, on the second system 4 partitions… who knows.

Ah, yes, and I also tried the following install isos just to get a new BE somehow - unsuccessfully:

  • Trident RC2
  • TrueOS 18.12
  • FreeBSD 12
  • GhostBSD 18.12

Except for Trident none of the install isos even offer the option “install into new BE” - at least as far as I could tell.
But at least the crappy resolution of the GhostBSD live medium forced me to learn how to change the video graphics driver on a “ROM system” - now I can get Trident installer also have a more acceptable resolution on my main system, on the test system where “installing into new BE” works fine the resolution if the install screen is also fine (different onboard intel graphics).


#38

IF you can get RC2 installed, we can get you updated to 1812 from there


#39

I know that.
The only reason I tried it was because of that:

In this script it says:

’ * TrueOS 18.03- : No clear upgrade path - may need manual intervention’

So, I assumed that it might be possible but ugly. Also, why can the install medium install into new BE “over” an existing 18.03 TrueOS but a running BE can’t when all TrueOS ever does when updating is installing into new BE - it would just need to use the same scripts? I know, there’s no solution out there and it’s been made “clear” etc. But that doesn’t mean it’s impossible, just that it’s not easy and no one has achieved it, yet - or didn’t even bother to go beyond a certain amount of time and coding effort trying it.

And no, I’m not expecting for that to change!
I just mentioned it because I wanted to give a heads-up for anyone crazy enough to try that - if it is at all possible - it most probably isn’t easy - at least for just-users like me.


#40

After some testing and tweaking I came to the conclusion that the problem with Trident installer on some systems not letting the user check the “install into new BE” option might be due to the fact how many partitions (or at least at what position the bsd partition is) are on the respective hdd. It might also be additionally due to the fact if the drive is formatted as mbr or gpt.
In my experience a drive with 3 partitions (or at least where the bsd partition is (at least) the third partition) works fine, with a drive with 4 partitions (or at least one where the bsd partition is the forth partition (or lower ranked)) the trident installer won’t let me check the “install into new BE” option.

I wonder if others can confirm my impression/findings.

On a system where you can’t check the “install into new BE” option, does the drive have 4 or more partitions?

On a system where you had no problem checking the “install into new BE” option, does the drive have 3 or less partitions? If it has 4 or more partitions, is the position of the bsd partition among the first 3 partitions?

In my case, partition means primary partition. Just as an additional information.


#41

A little Update:

I tested the TrueOS 18.03 install image via thumb drive. With that installer I can check the “install into new BE” option on my “sensible” system - even with 4 partitions and the trueos partition being the last one.

I also tested another drive where I tried with only 3, 2 or even only one partition present and the trident installer still would not let me check the “install into new BE” option.

So, apparently it is NOT an issue about the number of existing partitions on a drive (with the zfs partition being the last one).
I’m not sure what the actual reason might be, chipset, bios, legacy vs. UEFI.

At the moment I’m out of ideas how to get trident installed on my main system without having to format the existing partition. And I’m very reluctant of doing that because on my test system I did it and none (!) of the installed or upgraded Trident BEs work properly. The ones based on freebsd 12 won’t load services when booting and the ones based on freebsd 13 simply reboot at the moment that normally x server would start. On that system I was previously able to upgrade TrueOS 18.03 to Trident and go from there and no problems at all. Maybe there was some remnants of pcbsd that made that partition somehow “magically working” because since I deleted that tank and created a new one, on TrueOS 18.03 runs properly…

So, a lot work to do… but not many ideas at the moment… :slight_smile: