Problem with graphic installer Lenovo X250


#1

Encouraged (and emboldened!) by my discovery and use of FreeNAS for a home server I decided to try OpenBSD on a Lenovo X250 which I bought second-hand. I fitted an SSD in place of the HDD.

OpenBSD installed very easily but by this time I’d discovered TrueDOS. I downloaded a USB Desktop image for 17.12 and wrote a memory stick using dd as per the handbook. It fails to run the graphical installer - I get a brief band of mixed grey pixels occupying the lower third or so of the screen then nothing.

Lest it could have caused the problem I created a Live GParted USB and deleted the contents of the SSD - same result, sadly.

I am new here and have some experience of Unix and Linux. Any ideas what I may have done wrong, please?

Many thanks,

Ben


#2

What video card do you have?


#3

The boot process mutters about NVidia but to give an accurate answer I’ll need to put the Windows HDD back in, unless there is an alternative boot process and steps which would allow me to enquire. I’ll check the handbook meanwhile.

Many thanks,

Ben


#4

Lenovo quote Intel on-chip HD 5500 but I don’t know whether they also offer an additional card and, if so, whether mine has one fitted.

Ben


#5

perhaps stop the boot in the bios and look?


#6

I might be missing something but all that the BIOS seems able to tell me is that the CPU is an Intel Core i5-5200.

Any help?

Ben


#7

Most BIOS have a bunch of different tabs or selections that you can see what hardware is available. I don’t know what the specifications are for that laptop, but I imagine there is similar info somewhere. Maybe a “users manual” may help?


#8

I found a manual online but can see no trace of exploring the configuration, sadly.

Re-instating Windows is a pain as it requires pwering down the internal battery and then stripping enough hardware to swap SSD for HDD.

Having happily run Ubuntu on 3 Lenovo Thinkpads prior to this X250 I shall probably do a quick install of that and see whether it sheds any light.

Stand by…


#9

Ubuntu install in process.

Meanwhile I can find nothing which contradicts the idea that the Lenovo X250 uses these graphics: https://ark.intel.com/products/85212/Intel-Core-i5-5200U-Processor-3M-Cache-up-to-2_70-GHz and that is the processor listed by my BIOS.

Hope this may help,

Ben


#10

Ubuntu Live reports graphics as: Intel HD 5500 (Broadwell GT2).


#11

That should just work.

Try not to pick any driver during the initial install.

If this is a dual boot, try and turn off one video card during the install, since you said the TrueOS install mentioned nvidia. Nothing in the link ,mentions dual cards.


#12

It was a clean install to an un-partitioned SSD. I didn’t get as far as having any say over video cards - it was merely a message which appeared (I’d need to run it again to be precise) along the lines of ‘failed to load … nvidia … may be already loaded’ so I didn’t worry.

The trouble arises when the network connection seems to be established and forked and we get ‘starting graphical installer’. Since this never happens (I’ve waited for it - how long should it need?) but instead I get this band of uneasy looking pixels I never progress to making any choices.

Hmmm…


#13

The feature list of the X250 does not mention any dual graphics, so no NVIDIA. That would explain why the installer boot doesn’t quit work if it tries using NVIDIA drivers when there is only Intel graphics.

I don’t know why the installer would do that, though.

As I haven’t installed TrueOS in a while (knock on wood, updating just works and BEs make sure that even it something goes wrong I can always go back to a working BE) I have no idea if there is still - or again - some option to choose the graphics driver manually. Last time I used the installer it was all autoselect until the install menu appeared. And didn’t one of the Moore Bros. (or JMaloney - or simply the changelog at that time) say something along the lines that the install boot would fall back automatically to very basic settings, at least if appropriate settings could not be found?

So, not sure why it doesn’t work for you. My much older x121e got the installer (from way back though) to load fine.


#14

Thank you for all your help - I’ve learned more, which is always good. I’m glad everything is humming and ticking for you! There is mention out there on the forums of X250 users of TrueOS so there must be some work around, although Lenovo offer display options resolution and touch/no touch, I think, so maybe the problem lies there.

I am not sufficiently skilled or experienced to pursue this to the death on my own, so I may continue with the nascent Ubuntu install and see how it runs. Bit of a shame, but so it goes!

Again, my thanks for your time and input.

Greetings from Wells, Somerset, England’s smallest city!

Ben


#15

I have installed and ran TrueOS on X250 successfully, with no glitches.

  • Make sure you downloaded the USB image
  • Follow the Handbook.

If you intend to pursue this, I can always help.


#16

Many thanks.

I’ve been distracted but think I shall try again.

I confess I did think I’d used the USB image and followed the handbook, but making silly mistakes is one of my key skills :frowning:

Ben


#17

I tried again, following the handbook exactly and using the correct image, which I sum-checked. The same problem arose, sadly.

My other laptop is now showing signs of decay so I shall be forced to install Ubuntu on the ‘new’ one and make myself a workable machine. So sadly, my TrueOS experiments must end.

Thanks for help and offers of help,

Ben