Problem adding HP Deskjet 3845 printer


#1

A few months ago I added my HP Deskjet 3845 printer to CUPS after installing the hplip and hpijs packages. The printer driver was hp-deskjet_3840.ppd, version 3.17.4. Just recently, I reloaded TrueOS from scratch, installed hplip and hpijs, and attempted to re-install the printer. But when I attempt to add the printer via the CUPS GUI, the 3840 driver no longer shows up.

I tried “lpinfo --make-and-model “HP Deskjet” -m” and drv:///hpcups.drv/hp-deskjet_3840.ppd shows up. But if I try “sudo lpadmin -p ‘HP_Deskjet_3840’ -E -v ‘usb://HP/Deskjet%203840?serial=TH47K1348V040R’ -P drv:///hpcups.drv/hp-deskjet_3840.ppd” I get “lpadmin: Unable to open PPD file “drv:///hpcups.drv/hp-deskjet_3840.ppd” - No such file or directory”

I guess it is obvious that I am not familiar with CUPS. I am also a trueos noob, but I have some past experience with Unix and Linux, mostly as a non-administrator.

My environment: uname -a shows “FreeBSD trueos-5773 12.0-CURRENT FreeBSD 12.0-CURRENT #66 ac2f0aa3b(trueos-stable)-dirty: Wed Jun 21 01:09:23 UTC 2017 root@gauntlet:/usr/obj/usr/src/sys/GENERIC amd64”. The hplib version is 3.17.4.

I believe all my software is up to date. I tried un-installing hplib and re-installing, but it did not help.

I will appreciate any advice.