Playing DVDs not working


Fresh install of TrueOS-2017-06-01-x64 STABLE on Lenovo Thinkpad T520, 8 GB RAM, using integrated graphics with intel driver.

As suggested in the handbook, I navigated to /autofs and tried to open the files from there but VLC only produces read errors. Also tried Xine.


just tried using my Thinkpad t520. same issue.


Just attempted it on my STABLE box , same issue


DVD’s cannot be played/opened while mounted (if you mount it, you are trying to treat it like a data disk or filesystem - not a playback device). Instead, after inserting the DVD you just need to launch VLC and tell it to play the disk in the DVD drive (this will not mount the device - it actually need to interact with the raw device at a much lower level).

I am not positive, but I think if you right-click on the desktop icon for a removable device in Lumina it gives you the option to “play” the device (instead of “open” it) - that should launch VLC for you with the proper CLI flags to start playback on the device.


Thanks, I’ll look this afternoon when I get chance


Thanks to both of you from me, too! I am confused about what I tried already… :confused: but I will also check this afternoon.


@q_pa & @RodMyers might be having senior moments. That is correct, thank you @beanpole135. Just plopped a DVD into the Lenovo t520, pointed VLC at the device, NOT mouted, and the DVD is playing.

Should have remembered that.

Seems to working on my end

@beanpole135, no icon presented itself on the desktop


Hm, tried a few DVDs that I know worked before. Just got:

Playback failure:
DVDRead could not read -1/4 blocks at 0x245ad.

The window title even shows the title of the DVD for a short time.


sounds like a dying cd/dvd player


Can you play the same DVDs with the same hardware and another OS (Windows, Linux)?


Let me grab an Ubuntu flash drive


Only OS installed is TrueOS. But it worked a few days ago on PCBSD 10.3 on the very same machine.


Just tested a fourth DVD and that one worked. I tend to believe @RodMyers is right and the player might be dying. Which would be quite annoying because it is already the second one for that laptop.


It seems that there is only an icon directly appearing on the desktop when playback is working. The times when it does not work an icon only appears after reboot (DVD not in drive at that point!). In the latter case, /autofs is not showing the /cd0 directory, of course.

When trying to play a DVD messages log shows thousands of the following lines:

Jun 10 22:06:47 kernel: (cd0:ata1:0:0:0): Retrying command (per sense data)
Jun 10 22:06:47 kernel: (cd0:ata1:0:0:0): READ(10). CDB: 28 00 00 3b 45 98 00 00 04 00
Jun 10 22:06:47 kernel: (cd0:ata1:0:0:0): CAM status: SCSI Status Error
Jun 10 22:06:47 kernel: (cd0:ata1:0:0:0): SCSI status: Check Condition
Jun 10 22:06:47 kernel: (cd0:ata1:0:0:0): SCSI sense: ILLEGAL REQUEST asc:6f,3 (Read of scrambled sector without authentication)

[delipu@trueos-L] ~% vlc
VLC media player Umbrella (revision
[0000000802415150] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
libdvdnav: Using dvdnav version 5.0.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav: DVD Title: XFILES_SEASON3_DISC5
libdvdnav: DVD Serial Number: 2B41861A
libdvdnav: DVD Title (Alternative): XFILES_SEASON3_DISC5
libdvdnav: DVD disk reports itself with Region mask 0x00fd0000. Regions: 2
[000000081aa12050] core input error: ES_OUT_RESET_PCR called
[000000081aa12050] core input error: ES_OUT_RESET_PCR called
[000000081aa12050] core input error: ES_OUT_RESET_PCR called
[000000081aa12050] core input error: ES_OUT_RESET_PCR called
QObject::~QObject: Timers cannot be stopped from another thread


Solution: Install libdvdcss! :grin:

Good thing is I did not buy a new dvd player yet. I am almost 100% sure that PCBSD came with libdvdcss installed by default. I will open a request on github to integrate that into TrueOS.


never would have thought of that. I had libdvdcss installed early on

glad you got it fixed