Pkg delete (single) package


#1

I cannot find any reference on how to remove a single package and leaving others that depends on it. While compiling I got a message saying I needed to add a previous version of python(27) and then later another saying it needs a newer. I had python 34 or 36 in there and simply added 27 which I figure should be able to coexist, but when trying to remove 27 it says:
pkg-static: trueos-desktop is locked, cannot delete git
pkg-static: trueos-desktop is locked, cannot delete trueos-handbook

Either of those two could easily be reinstalled and find the newer version of python. But booting into single user mode (to remove them) claims I don’t have enough privileges to remove packages. There does not seem to be an option to ignore those who depend on one and go ahead and delete anyway. Never seen root not have enough privileges either. Odd.

For giggles I tried just moving the executable python27 by cmake still finds it, no doubt in the install db. Maybe I can handle it by modifying it?


#2

the are that way for a reason.

git, you may not need.

handbook is marked required.

Not sire how Project Trident will handle those.

For now, those 2 packages are required.


#3

I’m sure they are, I just need to get around removing python27 and fully intend to immediately put them back.


#4

I think I understand you correctly.

too many ports are hard coded to use python27.


#5

I could have sworn that I added 27 myself and it had 34 or 36 already. Which of course made it odd that it said git and handbook depended on them. :slight_smile:

Suppose a different tack could be to have it somehow find 34 first during the make. (Which I’m now way out of touch with.) There might be a flag I can use?

Edit
It says in the makefile 3.4, but that is of course what it wants. Trick is to have it find 34.


#6

look ar freshports.org. look at what it requires and what requires it


#7

Alright solved.

I did not remove it but found where to change the build config to use the newer version of python.

By using ports I got the latest version (Krita 4.1.1_2). All I had to do was to go into the work/.build/CMakeCache.txt file that listed python2.7 and change that to 3.4 and it compiled. (Plus I finally got to see something use all my cores which never happens.) :slight_smile:

This may very well apply to other applications needing a newer python version.

Unlike other reports I’ve read it starts up at a normal pace. It installed and was added to the menu by the install script. If you have used any earlier version the improvements are very noticeable and well worth the effort.

Thanks to all for helping!