No wireless on laptop with TrueOS, Debian, or Fedora but ok with old Knoppix or Porteus OSes


Wi-Fi is nonexistent on my recently-bought refurbished Dell Latitude E4300 laptop when TrueOS (version of 2017-04-21), Debian 8.8.0, or Fedora 25 Linux is installed or Fedora 20 or 25 is live but works fine when old Knoppix 7.2 is either installed or run live or with Porteus 1.1 64-bit running live on the same laptop. (I used to use Fedora 20 on another laptop for WiFi a lot, so that OS should work.) Except for TrueOS, all these are Linux. In nonroot TrueOS, I tried treating my usual home network as hidden but that only got me a profile, not a connection, although the wireless icon is on the Lumina desktop. TrueOS > SysAdmin: Update Manager ( window > Updates tab > Latest Check > “System is up to date!!” implies Internet access works but I think that message is probably an error, especially since the title bar shows a loopback address. (I didn’t test TrueOS root before trying Debian but would like to reinstall TrueOS.) In Fedora, the wireless icon was missing from the desktop panel, wireless was not in the network app, and WiFi didn’t work. Debian with the Xfce desktop in nonroot (root was unreachable) didn’t see any wireless and trying for the Gnome desktop kept getting me Xfce (unknown to me if issues are related). I never tried Windows, which I erased. All this is single-boot. BIOS settings are okay. Is there a TrueOS adjustment I should try?


FreeBSD/TrueOS is not linux.

What WiFi driver do those OS’s use. That “should” help narrow down what can be applied in your case.


I meant that only Debian, Fedora, Knoppix, and Porteus are Linux and I wrote above that TrueOS isn’t (I assume everyone here knows that TrueOS is FreeBSD).

I’m not sure how to find out what drivers the old OSes (Knoppix and Porteus) use but old may not be a good idea, for other reasons, and copying them out and into new OSes may raise other conflicts, and I’d have to find out how to edit related files for me to use the driver.

I’m getting the impression that many modern NICs including all USB NICs fail with open-source software and that may leave me with only the option of trying to get a many-years-old laptop in order to get WiFi, and they usually have less RAM and smaller HDDs, so finding one that’s TrueOS-compatible or even modern-secure-Linux-compatible may be even harder.

This also seems to suggest a priority in OSS development: creation, if possible, of an OSS NIC driver without a patent conflict over which Microsoft might finance a lawsuit against someone associated with OSS.


with linux loaded, open a shell, and type

lsmod -> Desktop/loaded-modules.txt

copy/paste the saved file “loaded-modules.txt” into, then paste link here


Three Linux distros gave the same results, all three from nonroot accounts and one also from root: Debian 8.8.0 (modern but no WiFi), Knoppix 7.2 (old but WiFi ok), & Porteus 1.1 (old but WiFi ok):

Terminal output (without quote marks): “Usage: lsmod”

No link to for these, since loaded-modules.txt on desktop was 0 KiB in every case (4 cases).

The root account is mysteriously inaccessible in Debian although the password works to authenticate me for a root-level function from a nonroot account. Knoppix appears to run (when live) in one account only; logging out brings me right back to the Knoppix desktop without a visible chance to log into any account. Porteus live gave the same result in root and in the nonroot account, and WiFi worked in Porteus in root and nonroot.

Someone else suggested different CLI input, and I’ve posted that output to (preserving brackets, leading whitespace (perhaps not as tabs), and blank lines as in original):

Does that clarify things? Thank you very kindly.


weird, I just copied/pasted my lsmod command (as regular user), and worked for me on an ubuntu laptop. very weird.

No expert here, but I see

intel - hard wired lan
broadcom - wireless

having trouble searching “broadcom WiFi freebsd” to verify your chipset. that gives you something to web search today.

It “should” work, but …


Tentatively solved: I got a USB Wi-Fi NIC meant for Linux without having to compile or install any software (it’s from ThinkPenguin, which has a long detailed compatibility list) and it’s working. I think a driver may have been taken out of the Linux kernel, which would be why old OSes worked but newer ones did not. Thanks for parsing for Broadcom. I tried Ubuntu 16.04 and it seems okay; Ubuntu is friendly but less secure so I’d rather use another distro but there are problems with Fedora 26 and reportedly Debian 9 apparently due to recent updates to both and so derivatives of both are probably problematic.


For future reference “lspci” tells more about what hardware you got. More importantly it can tell VID and PID of hardware so it can be identified with maximum precision. In my case:
example 1 “sudo lspci -nn”

04:00.0 Network controller [0280]: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)

example 2 “sudo lspci -vv”

04:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)
        Subsystem: AzureWave AW-NE771 802.11bgn Wireless Mini PCIe Card [AR9281]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 17
        Region 0: Memory at fdef0000 (64-bit, non-prefetchable)
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2- AuxCurrent=375mA PME(D0+,D1+,D2-,D3hot+,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
                Address: 00000000  Data: 0000
        Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L1, Exit Latency L0s <512ns, L1 <64us
                        ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
                LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
        Capabilities: [90] MSI-X: Enable- Count=1 Masked-
                Vector table: BAR=0 offset=00000000
                PBA: BAR=0 offset=00000000