No icons on desktop


#1

I just helped a friend installing TrueOS on his laptop. But for some reason all icons on the desktop disappears after reboot and I can’t ad new icons from the main menu. When to try to do that (right-click on a program in the main menu and choose “ad to desktop”) nothing happens.

When I install new programs the icons comes back but disappears again after reboot.

Interesting is that the icons/shortcuts are shown in the desktop folder but not on the desktop.
I can place icons as quick start and as favourites, but not on the desktop. How do I fix this?


#2

Did you try the “Pin to desktop” option on the kickstarter menu?


#3

I think that’s what I did. Right-click on a program and ad/pin to desktop.
Don’t know any other way.

I have it set to Swedish language and just try to translate what it says. It says “ad/fit/pin to desktop”.


#4

Some window managers attach the desktop to the file manager. As soon as the file manager is started, the icons appear at the desktop. If, for some reason, the file manager is not started, the desktop starts empty.

I have seen it happen with Gnome and LXDE, for instance.


#5

@Sergio brings out a good point… What DE are you using?.. I assumed you were using Lumina, also have you changed the wallpaper, or do you still have the default one?


#6

Yes, I’m on Lumina and I haven’t change wallpaper or anything. I tried to change the colour scheme, but it didn’t work well, so I set it back to default.

I did however install KDE-baseapps, but it didn’t change anything according to the icons. They came back directly after the install, but disappeared again when I rebooted. Actually, I just logged out and logged in again as a test, but that made the icons disappear anyway.

@Sergio had an interesting point. But is there a way around that?

Another thing. This laptop now also has the same issue as my own and won’t turn off normally. When I try to turn it off from the menu, it goes to the login screen. From there I can turn it off from the small menu at the lower right. But in this case it’s easier just hitting the power button, then I get a normal power off.

When I rolled back to 17-something (the DE before 17.12 - please note, I’m now talking about my own laptop and that has all icons) the power off and all system sounds worked. But now after I upgraded to 18.03 the roll back doesn’t work good anymore. It rolls back, but I only get the wallpaper, no main menu, no icons, no nothing.

I just hope all this with power off, system- and warning sounds and mic settings (that also not working on my laptop) will be fixed on Lumina 2.0 that if I’ve understood it correctly will come with the next STABLE upgrade in June if it’s not overdue.


#7

Right click on your desktop, click on, preferences::All Desktop settings, and go to desktop under interface configuration. Click both check marks, and hit save.


#8

Both boxes were checked. I tried to uncheck them and save and check them again and save. No changes.

But here is something really strange with this computer. When I now fired up the computer after a few hours I got this:
“gptzfsboot: error 1 lba”
“gptzfsboot: No ZFS pools located, can’t boot”

Scratched my head, started to type something about that it feels like hardware problem, but before I posted I used the Windows tool “Ctrl+Alt+Delete” to reboot and suddenly it fired up normally. It feels like there’s trolls in this computer. It’s luckily not my own and it has lived a hard life with kids who has played around with it, so it’s not in its best shape. Maybe it’s all a hardware problem?

It’s an Acer Aspire 5730Z built for Windows Vista 64-bit with a 320 GB mechanical HDD. But it makes no funny noises except for the fan sometimes.


#9

I think your problem is same for my last:

https://discourse.trueos.org/t/rooted-desktop-session

Try to install the TrueOS-Desktop-17.12 and upgrade it for the present TrueOS-Desktop-18.03 (maybe this will not easy :slight_smile: ) and don’t forget to install the meltdown and spectre security fixes :wink:


#10

Yes, that may solve it. But…

  1. I simply don’t have the power to redo everything again.
  2. We can’t be sure that it works, and to reinstall everything and then maybe be at the same stage would be just too much.
  3. Or is it possible to install the older 17.12 on top of the newer 18.03 and somehow roll back to it? It feels however like doing things backwards and that I would need to format and reinstall the OS.

It feels like the best alternative is to leave it as it is for now and hope the June STABLE update will fix this issue?


#11

Of course you have to clean (format) the HDD before you install the older 17.12 release.(you can find it on the linuxtracker.org if you has not already).
If you would like to wait for the June STABLE update, than you have to be careful because the present installed system is incorrect and maybe vulnerable, maybe dangerous to use it! This is your choice.
But if the 17.12. will work perfectly (as for me) than we will know that this is maybe an Acer bug (my machine is also Acer) or something went wrong with the installer or the endpoints of the download “way” is somehow compromised (penetration-packet injection, hijacked traffic etc). I’m very curious.


#12

I have the same issue with
TrueOS package set ………………… STABLE
TrueOS version …………………………… TrueOS-Desktop-201803131015
as guest on virtualbox.
One can place icons only to QickLaunch and not to the desktop. It seems like a bug.


#13

What kind of machine do you have (maybe Acer)?
Can you try to install xfburn or k3b by the AppCafe (as me in my older topic: Rooted desktop session) and after try to start these apps with double click on desktop’s icon of these? Please write a feedback what happening. Thank’s!


#14

My machine: see here https://discourse.trueos.org/t/the-trueos-release-does-not-fit-the-app-repository-or-vice-versa/2885/6
After I installed k3b I do not see any icon on the desktop. If I start k3b I get the massage:

“Could not start process Cannot talk to klauncher: The name org.kde.launcher was not provided by any .service files.”

After this I got the same informations as you in the older topic.
But brasero seems to work.