Newbie experience with TrueOS


#1

I have about 16 hours of usage of TrueOS now over the last 12 days. Started with the install of iso 12-27-2016. Things were good at first, but certainly not great. Then things went to H*ll. I tried to fix stuff, but finally broke my
install. I was determined. So I went to install it again using same old USB stick. I was flabbergasted at how well the install went. It never informed me that it was restoring my current system. Meaning, it saved my old custom wallpaper, my panel settings, my photos, my old game score history, etc. I have been in Lumina 1.2.1 for 5 hours now with only 2 problems. App Cafe and Control Panel sometimes freeze. I do not know what to do, so I reboot.
I verified I have some components from January 8, 2017, and Xorg is 1.18.4. SeaMonkey is the latest 2.46, so it
will play flash video. I wish the repository had the old game, “Puzzle Moppett.” My kid loves that game. It is in the Mageia repository.


#2

If there is an existing TrueOS installation on disk, it will install to a new Boot Enviroment instead of wiping out the old install. There are several advantages to this which I wont go into now as it’s a bit off topic… but… this is why all your personal files were still there. Nothing in the users home dir are deleted, so anything you had in there will remain. :slight_smile:

As for Puzzle Moppett, that’s a game I’ve not heard of, but if I get time this week I’ll see if there are any major issues to getting it to work on TrueOS.


#3

we answered on another thread. Puzzle Muppet is no longer being maintained, and windos/os x/linux only


#4

I have a similar problem with the latest update. I’m my case I got the home folder deleted and a missing library for openrc. Should I open a bug report? I’ve got the syslog.


#5

yes, especially since you have the syslog


#6

Hopefully a cause of the issue will become clear from a log. Did you recently remove any software? Or allow AppCafe to perform a cleaning routine?


#7

Thanks to ZFS, I decided to revert to an earlier snapshot, and rerun the update. This time it went properly and OpenRC was installed and launched correctly. I’m still trying to understand how this service management utility is working. Does one still edit the rc.conf file to automate the module loading at boot time? Or things are done differently now? My i915kms is not loaded automatically so I have to kldload it once I login. Should I still post the syslogs for the first update?


#8

I would like to confirm that suspend/resume works on my Lenovo L440. Used to suspend but on resume display would be black. Now it successfully resumes even with an attached external monitor through displayport. Should I post my dmesg?


Resume from suspend (wake from sleep) and from hibernation
#9

Loading the i915kms.ko kernel module

Here:

$ cat /etc/rc.conf | grep -v \# | grep load
kldload_i915kms="i915kms"
kldload_vbox="vboxdrv"
$ 

I’m prepared for that to change …

Conflict

/etc/rc.conf versus display – HP EliteBook 850 G2

OpenRC in the guide to TrueOS

Recently published:


#10

Thanks.

ThinkPad L440 Technical Specification – does that match the specification of your L440 and if so, which of the two types of display is integrated?

Do you drive the integrated display at its native resolution before the turn off?

What make and model is the external? Is that, too, at its native resolution?

If you like (if there’s nothing that you treat as sensitive), please do share output from
pciconf -lv and/or one of the three dmesg* files from /var/log/


#11
  1. Display: 14.0" (355mm) HD (1366x768), anti-glare, LED backlight, 200 nits, 16:9 aspect ratio, 500:1 contrast ratio
  2. Yes, it's on 1366x768
  3. Philips 49PUS6501/12. No, it's a 4k TV but I run it on 1080p due to not being able to drive 60Hz (although it's capable of 4k@60Hz) and the lag is unbearable
  4. [pciconf](http://pastebin.com/7ttJ2MLp) [dmesg](http://pastebin.com/XEbiHDC3)

Fun fact: as per the Lenovo technical sheet, my chipset can only drive 4k@30Hz thru mDP. The Intel technical sheet for the same chipset advertises 4k@60Hz. I actually was able to drive it 4k@60Hz, so haha on Lenovo!