New release 2018 12 19 - small changes


#5
Please try Trident PR2 as your host OS with a Virtualbox guest running
Trident or any other OS.

My guests spewed audio running on top of PR1 and prior.
John
groenveld@acm.org

#6

there is another build being generated. hopefully it fixes this


#7

I’ve noticed that OS-clang isn’t installed by default. However, packages such as p5-App-cpanminus seem to assume /usr/bin/cc is present. Is this an issue with the specific package/port, or should Trident be including OS-clang? I am not very familiar with FreeBSD ecosystem, but from what I’ve read online the common knowledge is that clang cc is normally available out-of-the-box in FreeBSD.

It looks like this might also have been the case with RC3; no idea about earlier builds.


#8

I just installed it - same problem on a multiboot (with Linux) system: it doesn’t boot after a successful installation. Just the blinking cursor and nothing else happens.


#9

install or upgrade?

video card?


#10

Fresh install. My video card is a NVIDIA GT 520 and works fine.


#11

are you using the correct driver set?


#12

Yes, version 390. And this works with GhostBSD as well.


#13

CTRL-ATL-F2, and then back again?


#14

Are automatic updates and reboot applied in the background?
I was pulling down a live audio stream and on my return found the user login dialogue.
On signing back in, Firefox that had been running was no long.

Thx


#15

No, it hangs at the boot loader. The same problem as with the prelast prerelease. I see an entry for FreeBSD (F3) but when I try to boot it, nothing happens and the system hangs.


#16

should not.

now if you start upgrade process, at the moment it does auto reboot to finish.

were you running Firefox?


#17

No I just installed it and tried to reboot.


#18

after install, it does ask to reboot, so probably good to go


#19

Thx Rod,
Yep, I was listening to an audio file (using Firefox) from the BBC.
I hadn’t initiated any upgrade as this was Trident-18.12-PRERELEASE2-x64-20181219 onto a new disc.
Installation was perfect. I’d added pbi programs from AppCafe [even though it showed ‘local’ not ‘trident’] - nothing ported. For example searching ‘font’ gave no hits, yet explicitly ‘gnu-unifont’ did. I’d updated xorg font conf.
I know update manager [and life preserver] are not in control panel yet - hence the default update question.
The only thing I’d yet to turn off was screensaver, which was running.
Thx


#20

firefox has a major memory leak> i have to close it every few hours to keep it from crashing as well

open a terminal and type

sudo pkg update -f

give a few minutes. Trident is supposed to show up in AppCafe


#21
<URL:https://github.com/trueos/trueos-core/issues/1558#issuecomment-448002212>

John
groenveld@acm.org

Trident 18/12 RC2 in VM - 'stdarg.h' file not found
#22

Tried it twice, it only worked once.

good try

Installed from Trident-18.12-PRERELEASE2-x64-20181219.iso in a VirtualBox running on Windows7 over a VM that had Trident-RC3-x64-20181110.iso installed.

  • Installer OK (as BE)
  • Boot OK
  • Was able to install via shell and use it for a quick ride

bad try

Installed from Trident-18.12-PRERELEASE2-x64-20181219.iso in a VirtualBox running on Windows7 over a VM that had TrueOS Desktop 18.03 (TrueOS-Desktop-18.03-x64-DVD.iso) installed.

  • Installer OK (as BE)
  • Book fails; it stops after the message Starting webcamd. ... [ ok ]
  • Can not change to terminal via CTRL + ALT + F2 (or any other function key)
  • System reacts to AHCI shutdown
  • System reacts to added and removed devices (e.g., adding/removing webcam)
  • Only one BE exists, the TrueOS 18.03 BEs are gone (at least in the boot menu) - is my VM bricked?

Same install ISO, same Windows7 “host”, same VirtualBox version.


#23
boot single-user, run /usr/bin/sh
# zfs list -r

Is the 18.03 BE still there?
John
groenveld@acm.org

#24

Yes, it is still there. Your answer pointed me in the right direction; now I could do a

mount -u -o rw /
beadm activate <name_of_precious_be>
shutdown -r now

Thank you!