Network manager fail to set default gateway


#1

Hello everyone, Today when I did try update my Trueos laptop I can not access to internet, I did check the network settings and all is ok. With network manager I set default gateway in “192.168.1.1” but dont work, I need use the command: “route add default 192.168.1.1” For the network to work fine.

Thanks.


#2

Network manager doesn’t work well for me either between home and work.
I usually use Ethernet at work and wireless at home. That’s fine.
But then, if I need to use wireless at work, my wireless settings get screwed at home. “Auto” settings don’t help. Somehow() the network manager remembers gateway or DNS settings from work and apply them at home. I have to set them to a fixed value as a workaround.
(
) I have not enough knowledge of network settings to tell exactly what happens. I would need help.

I don’t mean to hijack this thread… I just want to point out that there’s possibly a bug in default gateway and/or DNS settings in network manager.


#3

Same issue on my laptop. TrueOS network manager (and dating back to PC-BSD days) have always been wonky IMO. Perhaps the more experienced TrueOS users know the ins and outs of these network settings. I have played around with PC-BSD/TrueOS for several years but never seriously gave it a go for one reason or another. Last weekend I installed it for a second time on my Laptop and would like to keep it installed, but only if it’s not more hassle than it’s worth. As a fairly inexperienced user of TrueOS, I find most aspects of TrueOS’s network configuration utilities to be unintuitive, or at least to not work as one would expect coming from other desktop operating systems.


#4

Yes, is exactly this, I need change the default gateway with “route” command manually, the gui not change this network option.


#5

i’ve always created a script for the “home” computers, that assign the default gateway, and copy better resolv.conf file at login time

edit:

https://pastebin.com/D9JskTkn


#6

Mind sharing your script?


#7

Thanks for sharing :slight_smile:

But needing a script shows the truth in this thread: Network Manager in its current state is sub-optimal
Hopefully it will get some love in the future when some of the big pending tasks are completed…


#8

Most Linux distro’s are hit or miss as well which is why I started setting it manually.

So,not truly a TrueOS problem


#9

Personally I don’t care about linux - I just want my beloved TrueOS distro to thrive :wink: :slight_smile:


#10

That’s why we’re all here

I know the devs have been very conservative and apprehensive with the networking stuff. Too damn easy to Bork it all up


#11

Especially when talking about a default gateway. “Is this a real interface or a virtual one like a tun from OpenVPN?” I’ve been bitten by that a few times in the past when the OpenVPN config from work winds up putting in a default route through the VPN interface.