Network issue due to dual boot?


#1

Has anyone else noticed issues on TrueOS after having booted another operating system on the PC?

My situation:
TrueOS installed and used as my daily driver.
Windows 10 installed on another drive to be used essentially for gaming.
After shutting down Windows and booting TrueOS the IP will, 99.99% of the time, be 169.xx.xx.xxx. Pulling the ethernet out for a while, plugging it in and restarting the network seems to work to get me back to a usable IP.

Any thoughts on the situation? I’m doing some reboots in the little spare time I have to try to pin down something and see what I can figure out.


#2

Warm reboot or power off? I’ve run into situations in the past where the ethernet hardware did not actually do a complete reset when you just do a warm reboot. See if there is a difference in reboot vs power off/wait 30 secs/power on.


#3

It’ll happen after either a warm or cold boot. Only guaranteed way to avoid it is to completely unplug the PC and wait a few before booting. One theory I have is that the router is getting confused because it’s a different OS and assigning an internal IP as a security thing.


#4
In one terminal window,
# tcpdump -n -i $IF port 67

In another,
# dhclient $IF

John
groenveld@acm.org

#5

I will do that as soon as I make it home and post results.

I’ve just remembered that I noticed that there is always two network managers in the menu bar. One on each side of sysadm which makes me thing the system is starting it a second time later on.

Not sure if that may have anything to do with it.


#6

oh, that is interesting. are you using the default DE (Lumina)? If not, look for a “save session on logout”. I’ve run into situations where something is added to the autostart file, but then “save session” is enabled. Guess what happens when you log in next? Yep, one instance gets started from the saved session, another from the autostart. I’m not sure if the save session is an option in Lumina, but at least it’s something to check.


#7

It’s working right now. I’ll try the commands once it stops working.


#8

Yes, I’m using lumina. It started doing it randomly. I’m going to play around in the settings and see if I can figure out why.


#9

Sounds good. I’d go back to the “last thing you changed” because that’s probably what did it :slight_smile:


#10

I apologise for the long delay in getting to run these. It’s been crazy here. So I ran both when the issue popped up today. Here are the results:

Blockquote
andrew@trueos-r1600 ~> sudo tcpdump -n -i $IF port 67
Password:
tcpdump: port: No such device exists
(BIOCSETIF failed: Device not configured)

Blockquote
andrew@trueos-r1600 ~> sudo dhclient $IF
Password:
usage: dhclient [-bdqu] [-c conffile] [-l leasefile] interface


#11

It’s been doing this for so long I wouldn’t know where to start looking :rofl:. Having two running doesn’t seem to cause an issue, unless its what is causing the IP to set like it is.


#12
The ouput of this command will show us what value for interface:
# ifconfig -a

John
groenveld@acm.org

#13

Here’s the output:

Blockquote
andrew@trueos-r1600 ~> ifconfig -a
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
ether 4c:cc:6a:ff:c3:4c
inet6 fe80::4ecc:6aff:feff:c34c%re0 prefixlen 64 scopeid 0x1
inet 169.254.163.232 netmask 0xffff0000 broadcast 169.254.255.255
nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
media: Ethernet autoselect (100baseTX )
status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
groups: lo


#14
# tcpdump -n -i re0 port 67
# dhclient re0

John
groenveld@acm.org