My tor-tour de Trident - How to have Trident and still keep a TrueOS legacy BE


My goal was clear from my test system: I didn’t want to give up my TrueOS 18.03 legacy BE as Trident didn’t (and still doesn’t) work quite as well as “the old BE”. At least i286-wine is now available for Trident but there are still a few bugs I want to see get solved.

BUT: On my main system Trident wouldn’t let me “install into new BE” even though my test system is about 5 years older - and on that one every Trident iso (from the beta versions up to the most recent one, Release U2) let me install into a new BE. Unfortunately, because I tried to import a working BE from my test system into my main system I ruined my test system’s tank in the process with the result that the “transplanted” Trident BE didn’t boot on my main system (I didn’t know back then how to start looking for the reasons why) and I had to install my test system from scratch - which ultimately never quite worked because neither the newly installed Trident RC2 BE nor any of the Release / R-U1 / R-U2 BEs would boot properly. They would all reboot at the stage where normally x server would start and the login screen would appear.
And back then (a few days ago) I didn’t know how to start looking for a cure.

After a lot of testing I came to the conclusion that the reason that on my main system the Trident installer wouldn’t let me select “install into new BE” must have something to do with the MBR of that drive because no matter how many (or few) partitions I used it wouldn’ work - even if that drive was plugged into my test system!

So I made an image of my working BSD partition of my main system - just in case - and installed from scratch. First, I started with Trident Release but had to realize that then I couldn’t install TrueOS legacy 18.03, I guess because of the conflict FreeBSD 13 vs 12 - or rather because of a newer version of zfs that comes with v13 that the TrueOS legacy 18.03 installer doesn’t understand properly. So I installed Trident RC2 first, the TrueOS legacy 18.03 and finally upgraded to Trident Release U2 from within the Trident RC2 BE.

And with the problems I now had on my test system I made another image of my “new” BSD partition of my main system and transplanted that to my test system, made system-releated changes to loader.conf, rc.conf and xorg.conf. Now both my systems have a working 18.03 legacy and a working Trident Release U2 BE (I deleted the RC2 BE).

That wasn’t really fun. But at least I learned a few things. I would have been much easier if I would really understand how to manipulated (copy/clone/edit) pools and zfs systems - then I wouldn’t have to resort to imaging software and not very elegant heart surgery-like edits… :slight_smile:

My questions about / problems with Trident will be posted in a separate post.


Thanks for this post. I have same problem (can’t install Trident to new BE if TrueOS 18.03 is already installed), so your post is helpful.

Regarding your other post on this problem where you considered whether the problem was related to the number of partitions (“slices”) on your primary drive and asked what others have experienced, my setup is TrueOS installed as the only operating system on the drive which is partitioned into ada0p1 (GPT slice) and ada0p2 (FreeBSD-zfs).


Well… regarding the number of partitions theory I proposed a while back… I didn’t want to get into that whole experience in this thread above, but since you addressed it… here we go:

Spoiler alert regarding the number of partitions: At the moment and based on my experiences the number of partitions is not the reason for not being able to check “install into new BE”, at least not if it’s 4 vs 3 partitions.

The first thing I tried was to clone my existing main drive to test reasons.

  • With 4 partitions, the freebsd one being the last, “install into new BE” wasn’t “checkable”.
  • So I deleted the 3rd partition. That didn’t work.
  • So I expanded the second so the empty space couldn’t be considered a 3rd partition. That didn’t help.
  • So I used a “smaller” hdd. I.e. 500gb instead of 1tb. Nope. 320gb instead of 500gb. Nope.
  • And using those drives in my test system didn’t make any difference, either.

Well. But when I transplanted the image of the freebsd partition (that’s what my acronis version recognizes my TrueOS partion as) onto the hdd of my test system (250gb) I could check “install into ne BE”. As I don’t think, that 250gb vs. 320gb makes any difference or the fact that is was 3,5" vs 2.5" the only reason I can come up with is the MBR (or maybe the 100 MB W7 system partition) because that is the one thing that I didn’t transplant over from my main system to my test system.

So, going from there I set up a system based on the TrueOS 18.03 BE on my test system, added by a new-BE-install of Trident RC2 but as that would always reboot when x server should have been started I also made a new-BE-install of Trident Release U2 which I think also didn’t boot all the way to the login screen. But I made an image of that partition of the test system anyways and transplanted that to my main system. And lo and behold, with the Trident RC2 installer I now got the chance to check “install into new BE” - at least sometimes. Dropping to terminal a variable number of times and back to the installer (start-trident-installer) did give me that quite rare opportunity. But the installation also resulted in a BE that would not boot all the way to the login screen. “Back then” I didn’t know how to get to the bottom of the problem. So I resorted to the @RodMyers approach: Start from scratch and copy the home folder from backup. That was on my main system.
On my test system I just transplanted the new freebsd partition from my main system and edited a few files to get it running - actually I had to do the transplantation twice because the first time I somehow ruined at least one oft the BEs and didn’t know how to fix it. But at least I learned how I could have maybe solved the “not booting to the login screen successfully” problem I had at the beginning and the middle of my trials and errors…

That’s the long story of the whole “Trident + TrueOS experience”. I guess that’s a reminder of the PC-BSD-to-TrueOS transitioning phase when a few things didn’t quite yet work on TrueOS and I wanted / had to keep PC-BSD for a while as well.


Thanks for the details