My laundry list of issues with UNSTABLE (October 19/2017- RELEASE) as follow:


#1

System:

FreeBSD tros 12.0-CURRENT FreeBSD 12.0-CURRENT #14 5e243190c(trueos-master): Thu Oct 19 19:19:04 UTC 2017 root@chimera:/usr/obj/usr/src/sys/GENERIC amd64

1) In /etc/rc.conf

ifconfig_bge0="ALL"  - default seeting during install. It causes issues (in my double router set-up) due to duplicate IPv6, thus dmesg gets flooded with DAD messages.

ifconfig_bge0="DHCP" solved that issues

2) During initial installation TrueOS probes and finds nvidia GPU, but when trying to test the “nv” setting, the probe fails. When left as is, after complete install and user login , before and after updates, system runs in vesa mode.

3) Using “nvidia-xconfig” without custom options and then applying additional settings through NVIDIA’s X Server Control Panel, crashes GUI display after reboot. Setting display resolution with Lumina’s Display conf. works better, but again if nvidia-xconfig is not set with custom options the GUI display is a total mess – the display resolution does not match monitor’s DPI.

My current settings that make Luminal look&work OK:

nvidia-xconfig --mode-list=2560X1440 --use-edid --thermal-configuration-check

I’ll add the Coolbits Option, if I notice that the GTX960 is getting too hot under normal operation. While doing some OpenGL benchmarks, I noticed that Nvidia’s standard GPU thermostatically controlled fan RMPs curve doesn’t start the fans until GPU’s temp reaches 60 C and then gets up to 75C, for no resaon, during intensive load.

Nvidia X Server Video:
nvidia-xconfig:  version 384.59  (root@builds.trueos.org)  Thu Oct 19 07:35:33 UTC 2017

xorg.conf

Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "UseEdid" "True"
    Option         "ThermalConfigurationCheck" "True"
    SubSection     "Display"
        Depth       24
        Modes      "2560X1440"
    EndSubSection
EndSection

4) No sound with multimedia stream in Qupzilla. But now, full screen video works! Basic sound test checks OK, VLC sound is fine. OpenShot video editor has issues with sound.
My defualt (working) sound dev is pcm4

    dmesg | grep pcm
    pcm0: <NVIDIA (0x0072) (HDMI/DP 8ch)> at nid 4 on hdaa0
    pcm1: <NVIDIA (0x0072) (HDMI/DP 8ch)> at nid 5 on hdaa0
    pcm2: <NVIDIA (0x0072) (HDMI/DP 8ch)> at nid 6 on hdaa0
    pcm3: <NVIDIA (0x0072) (HDMI/DP 8ch)> at nid 7 on hdaa0
    pcm4: <Analog Devices AD1984A (Analog)> at nid 18 and 20 on hdaa1
    pcm5: <Analog Devices AD1984A (Analog)> at nid 17 and 21 on hdaa1


    pciconf -lv | grep Audio
    device     = '82801JI (ICH10 Family) HD Audio Controller'

    dmesg | grep Audio
    hdaa0: <NVIDIA (0x0072) Audio Function Group> at nid 1 on hdacc0
    hdaa1: <Analog Devices AD1984A Audio Function Group> at nid 1 on hdacc1

    lspci | grep Audio
        00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
        03:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)


     tail -f /var/log/messages                                                                               
    Nov  7 12:44:54 tros pulseaudio[70056]: [(null)] oss-util.c: '/dev/dsp2' doesn't support full duplex                   
    Nov  7 12:44:54 tros pulseaudio[70056]: [(null)] oss-util.c: '/dev/dsp3' doesn't support full duplex                   
    Nov  7 12:45:27 tros pulseaudio[70216]: [(null)] oss-util.c: '/dev/dsp0' doesn't support full duplex
    Nov  7 12:45:27 tros pulseaudio[70216]: [(null)] oss-util.c: '/dev/dsp1' doesn't support full duplex

I don’t need NVIDIA’a sound since I use DVI-D interface for this video connection. Tho, the GTX960 has several video ouput ports for every option - almost :slight_smile:

5) Lumina-texeditor has issues when selecting from lumina-fm “Open with” texeditor does not open the file. Double clicking opens the file.
[CORRECTION - C&P works fine! My error for not not highliting the text :blush:] "But, then copying of text doesn’t work. That menu option is gryed-out."

6) Unrecoverable crash in in lumina-fm when dragging objects from one window to another or from lumina-fm to an app. such as gimp. It happens randomly, otherwise dragging works OK.

7) TrueOS Hanbook icon can’t find Desktop/hanbook.desktop in user’s dir.

8) trueos-dektop LOCKED in AppCaffe - Was that always the case? No, just checked my STABLE-TrueOS laptop. The tureos-desktop in AppCafe doesn’t show lock.


Hardware Platfrom:

lspci
00:00.0 Host bridge: Intel Corporation 5520 I/O Hub to ESI Port (rev 22)
00:01.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 1 (rev 22)
00:03.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 3 (rev 22)
00:07.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 7 (rev 22)
00:14.0 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub System Management Registers (rev 22)
00:14.1 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub GPIO and Scratch Pad Registers (rev 22)
00:14.2 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub Control Status and RAS Registers (rev 22)
00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.5 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6
00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller
00:1f.2 SATA controller: Intel Corporation 82801JI (ICH10 Family) SATA AHCI Controller
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
01:00.0 PCI bridge: Pericom Semiconductor PCI Express to PCI-XPI7C9X130 PCI-X Bridge (rev 04)
03:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)
03:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)
06:00.0 Ethernet controller: Broadcom Limited NetXtreme BCM5761 Gigabit Ethernet PCIe (rev 10)

Lumina View

PS.
Overall, I’m impressed with the progress of TrueOS and Lumina, Great Job devs - Thanx!


#2

A tip. if you edit your post, please let us know where you make the edit(s).

helps figure out what you edited

thanks

edit: should have been post


#3

I’m lost. What does the “port” refer to?


#4

@RodMyers was providing an example for you :slight_smile: He had a typo originally “port” that should have been “post”, which he went back and edited.


#5

Ya, I ran into the sound thingy too.

Also, I have a favorite Windows chess playing program, “Chess Genius” but when I try to install wine, it seems to do it but then nothing afterwards. App Cafe says its installed but it doesn’t seem to be. Typing “wine” in a command box, it offers a correction.

My ATI Radeon 5000 graphics is recognized by TrueOS 11 Unstable (of 10/16/2017, I think) but doesn’t work until you have booted twice after the Install, as was pointed out to me here.

Thanks for providing details, I may look over that sound stuff, I have sound in everything except Cupzilla.
But then again, who uses Cupzilla ??

Thanks
J.


#6

Make that Qupzilla.

:slight_smile:


#7

@RodMyers

I’m not very handy with “discourse” and not sure howto “report my edits,” sorry.
I need bit more help than just “a tip”.


#8

@Jimserac

Godzilla or Qupzilla :smile:

I do use Qupzilla and I like it, because:

I don’t like spam&spy tools such as Chromium or the add-more -addons Firefox.
Not much has changed since the olden days of Mosaic which was fine with me. But then Netscape convinced the whole world that broken Java applets were good for a web browser, nuf said.


#9
  1. /etc/rc.conf initial network setup :
    Good find! I will take a look into that here in a bit and see if I can get that switched over to DHCP by default. If you could make a ticket on the trueos-core github repository about this that would be fantastic!
  2. “nv” driver functionality
    The “nv” driver (open source nvidia driver) has always had spotty performance. We highly recommend the proprietary “nvidia” driver instead (which comes directly from NVIDIA).
  3. “nvidia-xconfig” functionality
    If you are not using the official “nvidia” driver (see point 2), then the nvidia-xconfig utility will definitely not work properly for you. It is probably trying to set some special X11 flags that only work with the proprietary driver in your xorg.conf file, and the next time you start a graphical session it tries to read/apply those settings which don’t exist for you.
  4. qupzilla cannot play audio
    This should already be fixed. In preparation for the upcoming STABLE release, we switched the UNSTABLE repo back over to pulseaudio by default since a number of high-profile application ports still have not been patched to work with sndio yet. The pulseaudio backend for qt5-webengine does not work though, so we just re-enabled the alsa->oss option for that which we know works.
  5. lumina-fm “open-with app” menu will not launch lumina-textedit properly
    Please open a ticket about this so we can correct it ASAP. We are actually in the testing/staging phase for the next release of Lumina right now, so we will try to get this in for that.
  6. lumina-fm drag-n-drop
    This should already be fixed as well. We have been doing a lot of work on lumina-fm recently and probably fixed this already, but please open a ticket about it so we are sure to retest/verify it.
  7. TrueOS handbook shortcut
    Please make a ticket about this. If the shortcut is an actual file in your Desktop folder, then you are using an old system-install image - the newer installs no longer create that file for this exact reason (it gets out of sync with later updates). For newer images, the package should properly register the handbook in the application menu (if I recall correctly), but we should verofy that before the next STABLE update.
  8. trueos-desktop package lock
    This is a new change that we put into UNSTABLE to ensure that people cannot accidentally remove the trueos-desktop meta package. Package locks are bypassed/ignored during the TrueOS update routine (for more information about package locks see THIS THREAD) so this should not cause any issues for the user at all. Also note that you can lock/unlock any package you want within the “advanced” options in the AppCafe - so if you want to remove the trueos-desktop package for some reason you can still do so.

#10

I am/was using OFFICIAL NVIDIA driver. If I didn’t, I would not use “nvidia-xconfig” to configure X. Moreover, I would not be able to use “nvidia-settings”, as shown in my Lumina View above :slight_smile:

Qupzilla , lumina-fm and the others, as shown below in the message logs, are the most troublesome applications that crash at random. They make Lumina difficult to deal with.

    Nov 14 09:25:36 tros kernel: pid 2217 (sysadm-client), uid 1001: exited on signal 11
    Nov 14 09:36:17 tros kernel: pid 4096 (QtWebEngineProcess), uid 1001: exited on signal 11
    Nov 14 09:36:21 tros kernel: pid 4086 (qupzilla), uid 1001: exited on signal 11
   Nov 14 08:23:26 tros kernel: pid 11952 (lumina-fm), uid 1001: exited on signal 11


#11

Interesting results while I was looking at kldstat

kldstat | grep mps
nothing about mps :frowning:

kldload mps.ko
kldload: can’t load mps.ko: module already loaded or in kernel

ls /boot/kernel | grep -v kernel
mps.ko is compiled in

Is mps multi prossessor system module? If so, where is it loaded?

edit: oh. it must be in the kernel by default


#12

Bottom line:
I had to get’n touch with my ex-fav. OS :slight_smile: So, I did quick install for dummies to make sure and verify that there are no hardware or driver issues while using different UNIX-like env. with the same system as tested and reported here&above. As I’m sitting here and checking things in Leap, all seem to run solid as a rock with the same OFFICIAL NVIDIA - 384.90 driver as in TrueOS with Lumina. Inside Plasma, QupZilla 2.0.1 runs like a champ with sound and full screen video display, when needed. The eye candies for “kdeies” work great as always. Tho it looks cool, I dont’ miss the spinning cube - lol.

My conclusion:
As stated by me in this post, I think that Lumina has too many annoying issues, at this point&time, that need attention and fixes.


#13

PS.
After spending more time than expected with my ex-fav. UNIX-like OS, I was able to finally break few things there and refresh my good&bad memories about some *nix distros. Yes, Leap did nice job, during initial install, with probing my GPU and setting proper video output with their Open Source xf86-video-nouveau. But, I needed OFFICIAL NVIDIA driver with nvidia-settings to control my GPU fans. So, that took few extra steps with zypper to get nvidia repo in, remove the Open Source driver and create xorg.conf by hand to start with, more work than in TrueOS. Then, to make VLC, Kdenlive and rest of the multimedia apps play .mp4 videos, in the latest Leap’s KDE/Plasma5, I had to zypper packman’s repo that required replacement of many base installed libraries and utilities and adding others from packman to get the right codecs, which finally made all work. But after all that, my sound settings in Plasma5 developed issues, due to multiple sound sources in my system. I could not get my USB sound back as the default, in some apps, such as Qupzilla. So, the sound in Qupzilla was gone. Finally I manged to break Qupzilla in Leap too - lol

And the rest remains pretty much the same in the “*nix for dummies” world - if you don’t know which dependencies or configuration script you need when application has issues, then those applications either won’t work or just crash. I tried one in Leap known for having issues, and it still does - glmark2.

When I switched to TrueOS/FreeBSD, I was nicely surprised when most of applications or utilities worked fine from pkg or AppCafe without issues with dependencies, all from default repo sources.

Plasma 5 looks cool and KDE has some nifty utilities, but that’s not enough to make me drop Lumina - just because something looks nice outside, it doesn’t mean that all’s good inside. But, Lumina is a slim, mean and good looking too with enough basic DE utilities to handle all tasks within TruesOS/FreeBSD. And, if all else fails, there’s always Qterminal or CTL-ALT-F2 to take care of things when Lumina gets bit fuzzy. Eventually Qt5, QtWebEngine and Lumina will bring good things to GUI desktop in TrueOS, as time goes by. I will be here trying the cutting edge and rumble about it. Sorry for not participating in the bug reporting on git. I’m just a freeloading PC enthusiast who never developed anything useful in UNIX-like OS. I don’t want to mislead some developer with my rambling about things that I know very little about.

All the best to all devs who are working hard to make TrueOS/FreeBSD and Lumina end-user friendly UNIX-like OS and a great learning platform for *BSD noobs like me. A’men :slight_smile: