Multiple questions


#1

I’d prefer not to create different topic for each question I have - it would feel like spam for me , so I hope you forgive me listing them in single thread.

Q1.Explanatory (background) story.
I did a test measuring average boot times for various Linux, FreeBSD and Windows operating systems, all on the more-or-less same hardware (for some test-OS I HAD to switch graphics card). Machine had SATA SSD.
Took me most of the day but it yielded some interesting results. I noticed that TrueOS had ~35sec (35,64) boot time against vanilla FreeBSD’s ~15 (15,04) seconds. Exact numbers varied a bit and I took arithmetic average of multiple boots. FreeBSD install ran SLiM/XFCE4 combo on ZFS - not exact copy of what TrueOS would run but I wanted something easy to compare against Linux distros as well (especially against Alpine, which is also one Linux distro using OpenRC init - but it is musl-based and XFCE4 was only non-console option for it).

I noticed that majority of time went into “getting the kernel going” for TrueOS. Once OpenRC started doing it’s bit - boot became fast. Looking at it bit more closely I saw BUNCH (close to 50) of drivers were loaded up. Many of them totally unasked for. Example. I did not have wifi module in machine but for some reason - bunch of the wifi drivers had been loaded up. Which I think caused most of the time difference compared to vanilla FreeBSD.

I took time-out and installed PC-BSD 10.3 and found something similar. But I also found how and from where the loaded drivers were “called” from.check out line 135 for example

Now the question: Exactly where in TrueOS I could “adjust” the list of drivers being loaded boot-time? It’s obviously no longer in /etc/rc.conf.pcbsd , /etc/rc.conf.trueos nor could I find anything which could trigger it from /boot

Q2 How would I install TrueOS on a drive with a MBR partitioning scheme AND have it boot successfully?

I have Acer Aspire 5560 laptop. It has idiotic broken Phoenix UEFI bios implementation which does not allow installing anything besides Windows using UEFI. And even then it does not work properly - once you have deleted original Acer partitioning layout and “lost” recovery partition from it. Which I had, because original drive simply died and I put in replacement.
In Bios - no option for manual “legacy boot”. It seems to decide “which way to go” based purely on what partitioning scheme is on the disk.

Attempting to EFI boot TrueOS (and FreeBSD) ends up with a “kernel trap 12” message. Linux boot medias would just freeze. FreeBSD MBR install works just fine.

I used to do “manual install” using UFS2 file system on a MBR-formatted disk on this laptop but seems like this “terminal window option” for advanced installs is by now gone from more TrueOS installers.
Just selecting MBR install from “advanced” installer options would install the TrueOS but upon reboot all I would get would be # marks in boot loader. Any advice?

GRUB2 seems not to work with the ZFS. Would legacy GRUB be an option?

Q3 What’s the state of Lazarus and fpc in TrueOS ports? Do they work fine? If not, what problems have you been running into?


#2

Q1: take a look at /etc/defaults/rc.conf, look for a “modules=” line. Simply do the normal FreeBSD thing and override in your /etc/rc.conf. /boot/loader.conf should just have ZFS to be loaded at boot time.
Q2: Not sure
Q3: not sure


#3

Q2: I can offer to use the Gparted live CD (you can download it free and write for a CD or DVD or USB key and start the machine with this) or some other live linux distro which has the Gparted application (when the machine started, open a terminal,after in terminal type: sudo su (this will give you root privileges) and after in the root terminal type: gparted).

In the main menu of Gparted - Device - Create Partition Table - choose msdos and push the green pipe after again in the main menu choose Partition - choose NTFS primary and push again the green pipe.
After start the machine with an Windows installer DVD (Vista or newer) and when the installer booted up on the bottom left corner of the first or second screen have to be some “Repair the computer” or “Startup repair” and here have to be the CMD (command line or terminal) and type the command: format c:
After these when you will start the install procedure of the TrueOS than in the TrueOS installer will optional both the “GPT (Best for new hardware)” and the “MBR (Legacy)” options too (you need the last).

This picture is not the best (I could find this instantly), because the “MBR” option is almost invisible, but in your case (if you followed my advices) must to visible and optional.

Do not be sorry because the UEFI! Mainly the insecure UEFI BIOS mode, because for example you (and others) can override the UEFI partition in this mode (from a legacy BIOS mode started live linux on the same machine) or an harmful BIOS flash is also possible (I think so you or other professionals can bypass the secure level of the BSD) :slight_smile:


#4

I am aware of Gparted. I’ve also used EASEUS Partition Manager Windows PE disc. They work about the same.

I’ve found the “MBR (Legacy)” option long time a go but in combination with ZFS and BSD Boot Loader it does not seem to work out. Not on this Acer at least. I haven’t really tried booting TrueOS on MBR disk on other machines I have because my other machines can take UEFI TrueOS install just fine.

In FreeBSD forum I once saw some dev dropping a hint about relevant ZFS code being too large to fit into MBR boot sector…

I’ve even removed SSD from Acer, installed TrueOS on it on different machine in EFI mode and put the drive back in Acer later. “Kernel trap 12” upon boot which suggest firmware issue on Acer.

I am sorry because of th UEFI. Because I cannot use TrueOS with UEFI or without. With one this “kernel trap” error, with other utter inability to boot. It’s frustrating.


#5

Oh, sorry I just see "In Bios - no option for manual “legacy boot”, my brain is flying somewhere…everytime :slight_smile:
Than try the install procedure not for all HDD or SSD, because the ZFS filesystems need all the HDD or SSD and than maybe the installer will offer or make automatically a different file system as ZFS. Formerly I had an same old Acer laptop (TrawelMate) and before the install procedure I made an 50GB volume (for an 500 GB HDD after the Windows) for the PCBSD and I choosed and intalled the PCBSD for this 50GB place and in this case the PCBSD made an different filesystem not ZFS. And don’t forget the ZFS needs min 4GB RAM.The true so far I’m not tried this with TrueOS, but give a sance.

Or try the install with the help of Plop boomanager:
https://www.plop.at/en/bootmanager/intro.html

Or if you like the windows than install a Windows for the begin of the HDD or SSD (and of course for the MBR) and after install the TrueOS for the remain of the HDD or SSD. In this case the windows will manage the MBR (dual boot).

And don’t forget the cleaning procedure, before every install :slight_smile:


#6

I almost forget to write an other problem with the UEFI installed systems if you have NVIDIA video than:
“If secure boot is enabled; there’s no way to use the proprietary Nvidia driver without fiddling with UEFI keys. The module is built separately from the kernel package; so there’s no way for it to have the same signature as the kernel.”
“When UEFI is enabled, the free drivers work fine and replace the efifb framebuffer driver with their own; thus giving proper modesetting at the correct resolution and a speedy and responsive terminal.”
“With the proprietary Nvidia driver, the efifb is not replaced; so the console still operates with it and the Nvidia driver only operates the X part. Unfortunately, using this method, the framebuffer console is really slow, the resolution is not optimal, and the EFI framebuffer is exposed onto external monitors only from bios version “A14”. Before the update, pressing CTRL+ALT+Fx jumped me to the console that is shown in the closed laptop lid on the docking station; making it pretty useless.”


#7

Thanks. Its Radeon. HD6xxx chipset. Got it second hand because those Radeons are well supported by FreeBSD/TrueOS/OpenBSD and NetBSD - by all of 'em. Had to switch wifi out for Atheros though. Laptop overall worked well too,until FreeBSD/ PC-BSD 10.3, after 11.0 I’ve had to jump trough various hoops for getting the MBR installs on machine, because it would automatically attempt to use EFI and fail miserably.

Windows install media would at least give an option boot time if it would go with a MBR or EFI. Nothing such with open source OSes. TrueOS/FreeBSD does give it inside the installer (but neither doesn’t even boot in the same machine, have to use another PC for installing which has working CSM, then swap disk back to laptop) but boot loader does not function at all with the combination of ZFS on MBR. Serious pain in the butt.
Edit:fixed bunch of typos.


#8

A few months ago I could install the TrueOS for my 10 years old Acer TrawelMate 7514 laptop as a single OS with the Plop Bootmanager. :slight_smile:


#9

Never heard about it. It looks promising.


#10

I like to give new “life” for the old hardwares! :slight_smile: