Multiboot & rEFInd


I’ve have two new PC’s older ones (Laptop & Desktop).
On my Desktop (SFF) hp8300 i5-3470, on board Intel graphics I have 2 internal HDD one for storage formated as EXT2. My main drive is GPT with a efi boot partition(flags set as : Boot,esp). Currently grub is configured. I’ve installed two Linux OS’s ( Arch & Devuan), Installed TrueOs with Zfs on the same drive.

I’m unable to multi boot. I tried installing rEFInd twice, with installations of TrueOs. I’ve even tried installing rEFInd with Arch & Devuan, without success. I’ve even re-formatted the efi-boot partition & then attempted to install rEFInd, Nothing I’ve tried seems to work. BTW after reading here at discourse
about (CSM -bios compatibility) I disabled Legacy boot. This made no difference.

As most of you know I’m no techie. I HAVE been able to boot into TrueOS with “super grub disk”, TrueOs works as it should after an install. Still need to configure the graphics & install the updates. But there is no point in doing that if I have to reformat & start again. So I’ll hang off until the rEFInd bootloader is configured.

The version of TrueOs installed is TrueOS-2017-06-01-x64-USB.img downloaded from TrueOS website.

If you guys can advise me on what I’m doing wrong & how to resolve the boot issue it would be greatly appreciated. A big thanks in advance !

This is the configuration of the main drive
parted -l
Model: ATA WDC WD2500AAKX-6 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 537MB 536MB fat32 EFI System boot, esp
2 538MB 151GB 150GB ext4
3 151GB 172GB 21.2GB ext4
4 172GB 194GB 21.7GB ext4
5 194GB 215GB 21.3GB ext4
6 215GB 248GB 32.7GB
7 248GB 250GB 2147MB

Disklabel type: gpt
Disk identifier: 0592C9FD-65E4-4D00-AEF7-79067E5A7300

Device Start End Sectors Size Type
/dev/sda1 2048 1048576 1046529 511M EFI System
/dev/sda2 1050624 294651903 293601280 140G Linux filesystem
/dev/sda3 294651904 336113663 41461760 19.8G Linux filesystem
/dev/sda4 336113664 378447871 42334208 20.2G Linux filesystem
/dev/sda5 378447872 420007935 41560064 19.8G Linux filesystem
/dev/sda6 420007936 483966975 63959040 30.5G FreeBSD ZFS
/dev/sda7 483966976 488161279 4194304 2G FreeBSD swap

Taken from Arch Linux
sudo efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0002,0003,000A,0008,0009,0004,0006,0000,0000,0000,0000
Boot0000* boot
Boot0002* DTO UEFI USB Floppy/CD
Boot0004* Hard Drive
Boot0006* CD/DVD Drive
Boot0008* IP4 Intel® 82579LM Gigabit Network Connection
Boot0009* IP6 Intel® 82579LM Gigabit Network Connection
Boot000A* DTO UEFI USB Hard Drive

Lost access to TrueOS -none of all BE work either - after update in May