Mouse integration with VirtualBox


#1

I like to test translations of different distributions in VirtualBox but with TrueOS-Desktop-18.03-x64-DVD.iso the mouse cursor does not have mouse integration in VirtualBox.

So i have to select the window to make the cursor active and then the cursor moves like a few times quicker in the VirtualBox window so i have to move it slowly to get precision.

It would be nice if there was mouse integration so it would be better to test.
I dont know what it takes to make or how hard it is.


#2

virtual settings are always a pain to get .

have you tried searching discourse?


#3

I dont know what you mean about virtual settings.
Do you mean the cursor speed?
The cursor speed is normal in almost all the distributions i test in VirtualBox, just a few where it does not work so well.

In VirtualBox when i run a machine there is a menu called Input with a menu item called Mouse integration. Its grayed out when i test TrueOS-Desktop-18.03-x64-DVD.iso so i guess it does not support it.

If i test another distribution where mouse integration works i can move the cursor in and out of the window without having to click to get focus and press the keyboard when i want to stop using the cursor in the window because the cursor is locked inside the window content so its a bit harder/annoying when you want to switch window many times etc.

I did a little bit of searching.


#4

Running TrueOS within a virtual environment has always been a gamble.

Some systems work normally. Some are not worth the trouble.


#5

https://www.virtualbox.org/wiki/Guest_OSes


#6

It seems i can choose to install two guest addtions during the start of the installation so now i have mouse integration with normal cursor speed.
The cursor have got smaller for some reason and its transparent so its a bit hard to see.
I cant see to change the cursor in Theme Settings - Cursors.
There are 5 to choose from but i see the same cursor no matter what i choose.

It says version 1.4.2 at the bottom of the Theme Settings dialog.


#7

@scootergrisen: After changing your mouse cursor theme you will need to logout and login before the new cursors it take effect for everything. Otherwise you will only see the new cursors on new windows/applications which you launch after the change.


#8

The cursor still look the same to me in VirtualBox.


#9

@scootergrisen I just tested it using Lumina 1.3 and virtualbox 5.2.8, guest additions 5.2.6 (lastest in appCafe is out of date, I put in request to update to the lastest). It does change the mouse pointer (cursor) when you move to different window from the theme setting window. Also, it only changes the cursor on the title bar and when over some icons. The main window still has the same black arrow. Maybe a problem with the way the theme is defined or a bug in Lumina. I have not tested it on the Mate desktop yet (only use lumina for updating system - Lumina is too primitive for general usage by me).

@RodMyers your comments are not helpful and incorrect and this not the first time. If you are not experienced in the topic leave the topic to others who are experienced like beanpole, etc. By the way, there are numerous people that will not use TrueOS and other BSD’s unless it can be run in a virtual environment as it is safer if you have other OS’s on the system. So the virtual environment should be included in the test procedures.


#10

In the Theme Settings dialog if i look under Icons i see the names like Adwaita and icons to the left of the name like a preview.
But under cursors there are no icon next to the name. I dont know if there is suppose to be some but there are none.
But i guess it would be nice to have so people have an idea of what they look like.
The names alone dont give much clue as what icons to expect.

I updated to VirtualBox 5.2.8 r12100 but i can’t figure out this guest addion thing.
It seems i can’t find the cd drive when i mount the guest additions iso.


#11

Its in the AppCafe. search for “virtualbox-ose-additions”.


#12

I got virtualbox-ose-additions 5.2.6_1 installed.
I also see virtualbox-ose-additions-nox11.

Its the same cursor all the time also both in Lumina and Fluxbox so i guess it might have nothing to do with Lumina’s settings.