Mouse hangs every couple seconds


Every couple seconds I have the problem that the mouse hangs It just stops moving or needs a short moment before it moves. I am using no special drivers.
Any suggestions where I could look? I have the problem with the built-in touchstick and -pad.


Hi nielsk,
When my workstation was doing this it was due to an external drive that was having issues. I had a mirror set with an external eSata and the controller on the eSata kept losing connection to the drive so every time the mirror would try to sync the USB would stop working too since it couldn’t find the drive. ZFS is incredible because it never lost anything however I digress. While I know your issue may not be the same as mine was. Another thought is if you have a USB mouse you may want to switch to an older PS/2 mouse. The PS/2 port has an interrupt assigned to it while USB does not have that type of priority to the CPU. Either way it sounds like a hardware issue more than a software one. I hope this helps some.


Thanks johnny.
But this is the internal trackpad and touchpad of my laptop and I have only one internal SSD, no other disks are connected. I doubt that this is a hardware-issue because it worked fine before on Fedora.


It might be a graphics driver problem. I tried now the intel-options and the problem still crept up. Next up the FB-option but that on Friday or so. But this problem is really really annoying :frowning:


I need to go back to Linux on this laptop. The hanging mouse is too annoying, now i found out that virtualbox won’t run for some reason as well.
It is too much work for a machine I actually need to be able to work with :frowning: