Monitor Resolution Wrong with New 18.12 Installation


#21

Looked there and it’s like before at 1024x768 and the only other option is 800x600. I had better resolution on 18.03. Isn’t there a driver that can increase this?

When I go to /usr/local/etc/X11/xorg.conf (only in read mode) it still has

Section “Device”
Identifier “Card1”
Driver “vesa”
BusID “0:2:1”

EndSection


#22

please recap your video hardware.

type --> about <-- and post here


#23
                                Trident% about

Project Trident Information

OS Version: 18.12-RELEASE
Build Date: 20190113173435

TrueOS Sources Used:
Base Repository: https://github.com/trueos/trueos
Base Commit Branch or Tag: trueos-stable-18.12
Ports Repository: https://github.com/trueos/trueos-ports
Ports Commit Branch or Tag: b42445dec15979dabc50c64073c0fe08dd870a9a

System Specs:
Boot Method: BIOS
Genuine Intel® CPU U4100 @ 1.30GHz
Physical CPUs: 2
Physical Memory: 3.86 GB

GPU Information:
vgapci0@pci0:0:2:0: class=0x030000 card=0x029b1025 chip=0x2a428086 rev=0x07 hdr=0x00
vendor = ‘Intel Corporation’
device = ‘Mobile 4 Series Chipset Integrated Graphics Controller’
class = display
subclass = VGA
vgapci1@pci0:0:2:1: class=0x038000 card=0x029b1025 chip=0x2a438086 rev=0x07 hdr=0x00
vendor = ‘Intel Corporation’
device = ‘Mobile 4 Series Chipset Integrated Graphics Controller’
class = display

Network Device Information
alc0@pci0:1:0:0: class=0x020000 card=0x029b1025 chip=0x10631969 rev=0xc0 hdr=0x00
vendor = ‘Qualcomm Atheros’
device = ‘AR8131 Gigabit Ethernet’
class = network
subclass = ethernet
iwn0@pci0:2:0:0: class=0x028000 card=0x13058086 chip=0x00838086 rev=0x00 hdr=0x00
vendor = ‘Intel Corporation’
device = ‘Centrino Wireless-N 1000 [Condor Peak]’
class = network
Trident%


#24

okay, bios has 2 choices for video

vesa and/or intel.

you should change vesa to intel

logout and log back in

edit:
this is edited in the /etc/X11/xorg.conf


#25

I looked in bios and the video is Intel V1800 and it’s not changeable.

OK, but how? Shall I just change the vesa name to intel?


#26

how did you edit the /etc/X11/xorg.conf before?

yes, just change vesa to intel


#27

OK, tried to log out and in. Didn’t work, so I made a reboot, but now it don’t comes to the login screen. It just stops after OpenRC

Login: (date and time) localhost dhcpcd[66671]: timed out


#28

I did this in virtualbox to verify

reboot, when the trident ascii screen appears, hit the space bar. < – this give you time to look at menu

hit option 2, drop to single user mode

hit enter

1: type -> mount -u / <- this make the drive read/writable

2: type-> mv /etc/X11.xorg.conf /etc/X11.xorg.conf.bad <-- this moves the bad xorg.conf out of the way

3: type-> reboot <- this leaves your system without an xorg.xonf. but the instructions are in this thread

edit:
we’ll tackle changing video once you reboot


#29

OK, my bad, partly. I forgot the ‘mount -u /’
But anyway, I get “mv: rename /etc/X11.xorg.conf to /etc/X11.xorg.conf.bad: No such file or directory”

But then was the command wrong. It should have been “mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bad”

O well, I’m back in after some tries :wink:

Edit:
I removed the xorg.conf.bad file and replaced it with a new xorg.conf file in which i removed that second section (Card1). So I’m back where we started at ‘vesa’.


#30
Open a terminal
$ sudo cp /usr/local/etc/X11/xorg.conf /etc/X11/
$ sudo lumina-textedit /etc/X11/xorg.conf
change the "vesa" to "scfb"
$ sudo shutdown -r now

John
groenveld@acm.org

#31

scfb is for EFI, not BIOS, so won’t work


#32
Neither the scfb(4x) manpage nor the old Wikipage
are definitive.
The old wiki only mentions  "kern.vty: vt" sysctl.
<URL:https://wiki.freebsd.org/Graphics/SCFB>
I think it worth a try.

The OP's Intel VGA may also work with modesetting(4)

Caveat emptor, his mileage may vary, booting single-user to revert may be required. :)
John
groenveld@acm.org

#33

he has a BIOS machine, so scfb will not work


#34

I was almost about to test this, just thought to ask what the command “$ sudo shutdown -r now” is for instead of a normal reboot. But then I just forget it. Thanks for the info although I now I know how to fix the graphics if/when it crashes.

Anyway, as I said above, I’m back in the system where we started before I replaced “vesa” with “intel”.
Any ideas how to tackle changing the video?

Btw, I’m a he! :laughing:
I don’t know if my username may sound female, but it’s a combo of my name (Robert) and my website (iww) :wink:


#35

that’s what I said, “HE” :wink:


#36
Open a terminal
$ sudo cp /usr/local/etc/X11/xorg.conf /etc/X11/
$ sudo lumina-textedit /etc/X11/xorg.conf
change the "vesa" to "modesetting"
$ sudo shutdown -r now

John
groenveld@acm.org

#37

BIOS mode graphics --> vesa & intel

EFI mode graphics -> scfb & modesetting


#38
# about | grep -i boot
  Boot Method: BIOS
# grep Driver /etc/X11/xorg.conf
  Driver          "modesetting"

John
groenveld@acm.org

#39

The first command has the outcome you said.

The outcome this = card/driver configuration


#40
Open a terminal
$ sudo cp /usr/local/etc/X11/xorg.conf /etc/X11/
$ sudo lumina-textedit /etc/X11/xorg.conf
change the "vesa" to "modesetting"
$ sudo shutdown -r now

John
groenveld@acm.org