Monitor Resolution Wrong with New 18.12 Installation


#1

Wanted to relate my experience in case this helps others. I have a Supermicro motherboard with an Aspeed built-in video card. I performed a fresh installation using UEFI settings in the system BIOS. The resolution was stuck at 800x600 for an older Acer monitor (capable of 1280x1024). The driver which was automatically selected was SCFB. I researched this in the freeBSD forums and came across a comment that deleting the xorg.conf file would force the system to recreate the xorg.conf file and to put in a separate file of resolution.conf settings in would solve the problem. So:

  1. use Package Cafe to install the correct driver from x11-drivers/driver-for-your-card. For Aspeed it was identified by searching Freshports and had ast in the title.
  2. create /usr/local/etc/X11/xorg.conf.d/screen-resolution.conf. I will add a copy of this file to this thread when I get home later today. Twas very basic and had the maximum resolution for the monitor listed: 1280x1024
  3. rename /usr/local/etc/X11/xorg.conf and xorg.fallback.conf to xorg.conf.etc and xorg.fallback.conf.etc
  4. log out then log back in. Restart was not necessary.

The lumina display preferences window then had options for all resolutions up to the maximum for the monitor. The appropriate setup was confirmed by examining /var/log/Xorg.0.log.

May be Aspeed video driver installation is not part of the trident installation scripts?

Looking Good!
2otherjobs


#2

To complete the above post, the name of the driver installed with App Cafe is:
x11-drivers/xf86-video-ast

And here is /usr/local/etc/X11/xorg.conf.d/screen-resolution.conf
root@XX:/usr/local/etc/X11/xorg.conf.d # cat screen-resolution.conf
Section “Screen”
Identifier “Screen0”
Device “Card0”
SubSection “Display”
Modes “1280x1024”
EndSubSection
EndSection


#3

But I just found that after rebooting, the change to the Aspeed driver did not stick. Xorg reverted to scfb with 800x600 resolution which is essentially unusable. If I delete xorg.conf and logout/login the correct driver loads. Any help making the change stick?


#4
# cp /usr/local/etc/X11/xorg.conf /etc/X11/
and edit the Driver setting in /etc/X11/xorg.conf
John
groenveld@acm.org

#5

Interesting thread!
As you probably have seen in the other thread Trident successful installed, but with major problems started by me, @RodMyers attempted to help me out with a similar problem. One issue is that I can’t access the xorg.conf file, it just says “Read_Only File” and I get the following text in Terminal:

#===========
# Auto-generated X11 graphics
#    card/driver configuration
#===========
# Created by Project Trident
#===========
# DO NOT MODIFY
# - Will be replaced on every bootup by trident_i
# - Place alternate X11 settings into separate fi
#  /usr/local/etc/X11/xorg.conf.d/[something].con
#    OR
#  /etc/X11/xorg.conf
#===========
Section "ServerLayout"
        Identifier     "XFree86 Configured"
file "/etc/X11/xorg.conf", 39 lines

Now, looking in AppCafe I find a whole lot of xf86-video files. How can I know which one is for my card? It’s a small Acer laptop with Intel CPU and everything is integrated.

One thought I got about the non accessibility xorg.conf was when I started searching AppCafe and came across this: “transfig” and “fig2dev” both with the explanation “tools to convert Xfig .fig files”. May that be something I need?


#6

Thanks. That worked.

Tom (2otherjobs)


#7

Robiww

You have outlined several different (and I think unrelated) problems above. I found the type of video card and therefore driver package from my main board manual.

To edit xorg.conf I logged on as root and used ee as editor. Not sure why you see the file as read-only.

/use/local/etc/X11/xorg.conf gets overwritten with each reboot. If you copy it to /etc/X11/ and edit it in its new location, it remains unchanged there. It also is used in place of the original file.

Not sure if I am answering your questions.


Trident successful installed, but with major problems
#8

Re: " . . . Not sure why you see the file as read-only"

If one starts in – or shifts down to – the “single user mode” you get a “root prompt” (i.e. #) but you cannot save edits (i.e. “write”) to files on the hard disk because the main file system is not “mounted” in the single user mode. You can confirm you have this problem by issuing the “mount” command from the terminal:

mount

Output from the command is: /dev/gpt/rootfs on / (ufs, local, read-only)
Notice the words “read-only” at the end of the line.

If you experience this problem, you can overcome it with some simple commands.

==== SINGLE USER COMMMANDS TO MOUNT FILE SYSTEM FOR NEWER SYSTEMS (FREEBSD 12 & 13) TO CHANGE READ ONLY FILES =========

mount -u /

mount -a

FOR OLDER SYSTEMS, TRY THIS:

mount (to confirm that the system or directory is mounted read-only)

mount -rw /

mount -a

Another alternative set of commands for older systems . . .

fsck -y
mount -u /
mount -a -t ufs
swapon -a

Ian Robinson
Salem, Ohio


#9

When I Boot as Single user hit Enter and type “mount” I get this reply:

trident/ROOT/initial on (zfs, local, noatime, read-only, nfsv4acls)
devfs on /dev (devfs, local, multilabel)

But I have no idea what to do with the info.

I tested around a little with other files and came up with an idea.
Since you can point files to various programs. Isn’t it possible to force point Terminal to open a file, in this case xorg.conf to open Lumina Text Editor, Kate, Kwrite or so, instead of showing the content within it self (in Terminal)?

I tried for fun just typing /etc/X11/xorg.conf after adding the root password, but I get “Permission denied”. My thought is that with the root password added I should get access to everything, or am I wrong?


#10

sudo ls -la /etc/X11

to look in the driectory

sudo cat /etc/X11/xorg.conf

to read the xorg.conf file


#11

It give me this:

root@Trident:~ # ls -la /etc/X11
total 14
drwxr-xr-x   2 root  wheel    3 Jan 29 05:17 .
drwxr-xr-x  34 root  wheel  119 Jan 25 18:39 ..
-rw-r--r--   1 root  wheel  775 Jan 29 05:17 xorg.conf
root@Trident:~ # 

And # cat /etc/X11/xorg.conf lets me read the file in Terminal. But it’s still useless since I can’t edit it. I need Terminal to open xorg.conf from root and somehow point Terminal to open a text editor.

I can open it from Lumina Text Editor or Kate, but it’s as just Read-Only. I need to go the other way around.


#12

sudo sudo lumina-textedit /etc/X11/xorg.conf

as i pointed out a few messages ago. this will open lumina-textedit and allow you to make changes and save them

edit:

your original situation had NO xorg.conf


#13

Yes I know and I tried that, but it opens nothing, I just get this:

root@Trident:~ # lumina-textedit /etc/X11/xorg.conf
qt.qpa.xcb: could not connect to display 
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-org.kde.kwin.qpa, bsdfb, minimal, offscreen, vnc, xcb.

Abort
root@Trident:~ # 

Yes I know that too. But creating that didn’t have any effect on the graphics. What now?


#14

you can’t log in as root. you have to do that as your user, the sudo, like I typed


#15

Ah! OK!!! Finally some success! :slight_smile:
Now I was able to remove the section

Section “Device”
Identifier “Card1”
Driver “vesa”
BusID “0:2:1”

EndSection

you told me a few days ago AND save. What next?


#16

log out, then log back in


#17

Done, but no change.


#18

not sure what resolution you have set, and want. But sounds like you need to compare with vs. without an xorg.conf to find what works best for you


#19

It’s still on 1024x768 as before. I would probably need it to be 1280x1024 or so like the thread starter @2otherjobs . Is that possible to get now that I can edit xorg.conf ?


#20

open the display preferences

start menu, applications, Lumina Screen Configuration

You can select any screen size that is listed there. that is what the drivers support. If not shown, then not available.