MicroSD card doesn't show in auto mount

#1

I tried to connect a device (phone) with a MicroSD card in it to the computer by USB, as I’ve done successful several times on PC-BSD, but it doesn’t show up on auto mount (an icon on the desktop) as USB-pins and even my USB-adapter (when I connect an internal HDD external) do.

So I looked in my list of useful commands that I saved over time as I learned them and found this:

% pc-sysconfig "mount da0s1"

But Trident doesn’t have a panel for mounting devices (at least I don’t find one) as PC-BSD had (in fact it had two). So questions:

  1. Is this command useful?
  2. If yes, where will the device show up? On the desktop as an auto mount or elsewhere?
0 Likes

Total catastrophy installing Trident
No mic output and not even a mic setting in mixer
#2

sudo pkg install pc-diskmanager

0 Likes

#3

I’ve no solution but maybe a hint.

To my knowledge the storage of an Android or Windows phone (Apple does IMHO provide no way to access the storage) is not presented as a usual storage device like an USB disk or USB thumb drive. It is accessible via MTP.

If I enter

tail -f /var/log/messages

in a terminal window and then plug in my phone, all I get is

Mar 23 11:39:29  kernel: ugen0.2: <Blackview BV5800> at usbus0

No mentioning of a storage device.

So installing the mtpfs package and playing around like here might help. I had no success so far.

0 Likes

#4

@RodMyers I installed the disk manager, but the phone nor the memory card doesn’t show up in it when I plug it in.
I’m thinking that if I would know where in the file system auto mount/USB-devices show, maybe I could access it that way?

@hardcodes I tried the command you provided and got this: (the USB connection was a temporarily a little loose)

Mar 23 11:02:52  kernel: ums0: <vendor 0x15ca USB Optical Mouse, class 0/0, rev 2.00/5.12, addr 2> on usbus2
Mar 23 11:02:52  kernel: ums0: 3 buttons and [XYZ] coordinates ID=0
Mar 23 11:07:32  /etc/init.d/bootmisc[36430]: WARNING: you are stopping a boot service
Mar 23 12:07:32  pkg[5167]: pc-diskmanager-201710171153 installed
Mar 23 11:11:26  kernel: pid 90854 (intel_backlight), uid 0: exited on signal 11
Mar 23 11:14:26  kernel: ugen0.2: <Nokia Nokia C2-01> at usbus0
Mar 23 11:14:33  kernel: ugen0.2: <Nokia Nokia C2-01> at usbus0 (disconnected)
Mar 23 11:14:43  kernel: ugen0.2: <Nokia Nokia C2-01> at usbus0
Mar 23 11:14:47  kernel: ugen0.2: <Nokia Nokia C2-01> at usbus0 (disconnected)
Mar 23 11:16:13  kernel: ugen0.2: <Nokia Nokia C2-01> at usbus0

I’m still thinking the same as in the initial post. In PC-BSD you where able to open a USB-device from terminal and if you can see the device from terminal, you should also be able to access it. I’m thinking of trying that mount command, but I before that I want to know where it may mount and/or show up. Any hint?

0 Likes

#5

for phone, search AppCafe for mtpfs.

make sure the phone is set to be viewed as storage

0 Likes

#6

Installed

It is, but it doesn’t show anywhere, at least not as auto mount or in the disk manager. Even tried to plug out and plug in again - no change.

0 Likes

#7

what does

sudo dmesg

say?

0 Likes

#8

A lot. I used pastebin not to fill the thread
https://pastebin.com/rPCmuLTy

0 Likes

#9

do you have mtpfs installed?

0 Likes

#10

Yes, in post 6.

0 Likes

#11

in AppCafe, search android file

also look for “pc-diskmanager”

0 Likes

#12

Found four of them. But the Nokia isn’t an Android phone, just an ordinary phone with buttons https://static.toiimg.com/photo/54076208/Nokia-C2-01.jpg

And since I have a memory card in it, in all other computers (incl. PC-BSD) it’s act like a normal USB-device. If I want to access its system, then I need “Nokia PC Suite”. But that’s not relevant since it’s only available for Windows (.exe)

Only the system (Trident) drive there.

0 Likes

#13

do you have a card reader for your computer?

I use the card reader, pc-diskmanager to mount my sd-cards to a directory in the /media directory

edit:

they need to be installed when running pc-diskmanger.

make sure you have the necessary fuse modules loaded

0 Likes

#14

Yes I do. A quick look in the specs said that it can fit MicroSD cards.But I don’t know how to insert it since its tray is too large and a MicroSD card will just slide around on it. Is it possible that I need some other insert for that? I never used memory cards slides on computers before, only USB-devices.

Your edit I don’t really understand. What are the “necessary fuse modules”?

However, the computer also have a bluetooth unit and I tried to see if it shows up on the phone, but it doesn’t. If there is a way to find it, maybe that’s a solution. A look in AppCafe gives eight “OS-libbluetooth” things. but I don’t know if it’s what I need to activate the computers bluetooth?

A request to the devs is that they fix so units with inserted memory cards can be found by the auto mount.

0 Likes

#15

With mtpfs installed, I was finally able to mount my phone storage (as root), could read but not write as user:

mkdir -p /mnt/phone
simple-mtpfs --list-devices
1: MediaTek IncMT65xx
# mount (the only) shown device number 1 
simple-mtpfs --device 1 /mnt/phone -o allow_other -o umask=0000 -o uid=1001 -o gid=1001

The user id (uid) and group id (gid) can be shown by simply using the id command as regular user.
Right now I am not sure what prevents writing, the files and folders are shown as if I own them.

1 Like

#16

I just tested your suggestion in root mode.

  1. Plugged in the phone with the microSD card inserted.
  2. mkdir -p /mnt/phone
  3. This created a “phone” directory inside /mnt
    Then
  4. simple-mtpfs --list-devices
  5. “no raw devices found”.

It look like I will have to make use of my old off-line Windows XP computer to access the phone until the devs find a way to auto mount memory cards in devices (like phones) in the same simple and advantageous way as other USB-devices.

They other alternative is to keep PC-BSD on my desktop, that in fact can access those kind of memory cards. But I don’t want to keep that anymore since that OS is now very old and I think it’s high time to upgrade to Trident, now that it works so well.

I fully understand if Trident can’t access the inner stuff like phone books etc. in mobile devices since e.g. Samsung-kies or Nokia-suite is required for that and those are only available for Windows and maybe for Mac. But accessing a memory card should be possible, not at least since it was in PC-BSD.

0 Likes

#17

Sorry to hear that. I’ve just looked up what a Nokia C02 actually is. Maybe I led you on the wrong path. According to the phone manual there is a mass storage mode for USB data cable access. That sounds like it can behave like other storage devices.

When that mode is selected on your side and it still does not show more lines like

Mar 23 11:16:13  kernel: ugen0.2: <Nokia Nokia C2-01> at usbus0

in /var/log/messages there is probably something going on in the guts of FreeBSD which have changed a lot since PC-BSD to my understanding.

0 Likes

#18

pc-bsd was based on FreeBSD 12, Trident is based on FreeBSD 13.

My andoid phone shows up as a storage device, though it is laggy.

I use “ES File Explorer” with it’s WiFi setup.

As for the microSD cards, Mine show up when I use pc-diskmanager. I can mount them and copy/paste

0 Likes

#19

Hello
I suggest to take a look on my post:


Hope that helps.
vTT

0 Likes

#20

I tried it all. First with my new Cat B35 that has KaiOS (it’s a kind of lightweight Android) - Nothing.
Then I moved the microSD to the Nokia and tried again - Same negative result.

Maybe it could be a kinda similar issue as with the mic on the laptop? I’ll try it again after I installed Trident into the desktop maybe some day this week if I come around to it.

0 Likes