Mate on the TrueOS ... problem


#1

Friends, I installed the Desktop Mate on TrueOS, but I’m having difficulty adjusting the brightness of the monitor … how do I do this by operating system terminal? I’ll await your answer.

Everaldo


#2

Hi Everaldo, I’m brand new to TrueOS (FreeBSD) world. Have you added the Mate screen brightness control to your panel? If that does not work you can try xbacklight from terminal. There are some complicated syscontrol prcedures you can try but before doing so can you please check the manufacturer & BIOS of your machine - some manufacturers implement ACPI in their BIOS firmware either incompletely or non standard (i.e. broken). Was it working in Lumina using ‘Peferences’ from the main menu?


#3
sudo kldload acpi_video
sudo sysctl hw.acpi.video.<device>.brightness=42

acpi_video(4)
or Fn keys.


#4

Thank you for answer! Yes, it is working in Lumina when I use “Preferences” from the main menu, ok! Only on the Mate Desktop I don’t know how adjust the brightness … but I’ll try your tip and I will put here the result, again, thank you!


#5

But what do I put in “device”???


#6

device is what’s shown by sysctl.
Read: “man 8 sysctl”.


#7

Depends on which monitor you want to adjust brightness :slight_smile:
sysctl hw.acpi.video should give you a list of available options imho. The important piece is that it should be supported by acpi/bios.

Edit:
As @Sigawan suggested, xbacklight might work for you too without requiring sudo. See also: xgamma, xrandr (maybe even redshift?).


#8

I am thinking about TrueOS, how would I install mate???


#9

An easy way would be going via AppCafe:
MATEinAppCafe2018-05-14-10-46-30