Lumina-textedit not closing --- SOLVED


#1

After start of lumina-textedit, hitting the X top right button, opens “save as” dialog box instead of closing the app. I have not entered anything to editor. The “New file” tab also has X to close just that document and it does close it (without asking to save), but after that top right X (or menu “File - Close”) does nothing (can’t close the app). Also if I start program from command line I get:

% lumina-textedit 
lthemeengine: using lthemeengine plugin
Loading Locale: "l-te" "en_US" "UTF-8"
lthemeengine: D-Bus global menu: no
QKqueueFileSystemWatcherEngine::addPaths: open: No such file or directory

% about

===================
General information
===================

boot environment now (N) … 12.0-CURRENT-up-20171001_214719 NR 2017-10-01
       after restart (R) … 12.0-CURRENT-up-20171001_214719 NR 2017-10-01
boot loader …………………………………… BSD
            type ……………………… EFI
CPU ………………………………………………………… Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
    number of cores ……………… 8
host ……………………………………………………… i7.sokolc.local
memory ………………………………………………… 16384 MB available, 12715 MB free
OS git branch ……………………………………………………………………………………… drm-next
OS git revision ………………………………………………………………………………… 2a2a3070d
OS kernel build time ………………………………………………………… Fri 2017 Sep 22 13:48:41 UTC
OS kernel identity …………………………………………… (uname -i) GENERIC
OS platform (architecture) ……………………… (uname -m) amd64
OS release level ………………………………………………… (uname -r) 12.0-CURRENT                                                                                                                                  
OS version and patch level …… (freebsd-version) 12.0-CURRENT                                                                                                                                  
TrueOS package set ………………… UNSTABLE                                                                                                                                                           
TrueOS version …………………………… TrueOS-Desktop-201707111911                                                                                                                                        
uptime ………………………………………………… 3:46                                                                                                                                                               
user  …………………………………………………… samob                                                                                                                                                              

More (TrueOS Desktop):

    desktop environment …… Lumina
    sound card driver ………… pcm0: <Realtek ALC1150 (Rear Analog 5.1/2.0)> (play/rec) default
    wireless driver ……………… 
    X11 drivers ………………………… nvidia_drv.so

#2

i’m having the same issue…

I will let the devs know tomorrow

edit:

I think this looks like the error we are looking at

https://github.com/trueos/lumina/issues/465


#3

I have the same issue with the text-editor is their any solution out?


#4

waiting on the next UNSTABLE release


#5

I am running the stable Version !! Guess that i have to wait until next stable release…
right?


#6

correct. STABLE will be update early Decemeber


#7

@michael.ger
This bug should only be impacting the latest UNSTABLE, it was a small bug that crept into one of our minor bumps.
Please run lumina-desktop --version or pkg info lumina to see which version of Lumina you are using and report back.
If this last Lumina update accidentally got pushed to STABLE, then I will make sure the next minor update to Lumina with the fix will also get pushed to STABLE as a minor version bump.


#8

$ lumina-desktop --version && pkg info lumina

"1.3.3"
lumina-1.3.3_201709211618,3
Name : lumina
Version : 1.3.3_201709211618,3
Installed on : Fri Sep 29 15:55:38 2017 CEST
Origin : x11/lumina
Architecture : FreeBSD:12:*
Prefix : /usr/local
Categories : x11
Licenses : BSD3CLAUSE
Maintainer : kmoore@FreeBSD.org
WWW : http://lumina-desktop.org
Comment : Lumina Desktop Environment (meta-port)
Annotations :
Flat size : 378B


#9

@michael.ger : I have verified that the STABLE packages of Lumina are at version 1.3.0 - if you are running 1.3.3 then you are either running with UNSTABLE packages, or rebuilt Lumina manually from source. In this case, I recommend updating your Lumina packages (either rebuild from source again with newer sources, or update to the latest UNSTABLE packages).


#10

Confirming it is working now on Lumina 1.3.3 TrueOS CURRENT 201711140940


#11

thanks. it works well