Lost access to TrueOS -none of all BE work either - after update in May


I really would like to keep using TrueOS - please advise if I have to wipe it totally or it is repairable.
The update seemed to come in normal, but after the reboot this showed up:
attached 2 photos

hope the upload worked,
Thank you in advance


Are you sure none of the boot environments work?

Do you get the splash screen that pops up for 3 seconds?


thanks for answering so swiftly - I tried rebooting them each back - no splash screen - it is everytime stuck, but I can try again…it took me while to get going here to post it
also do I need to make a better photo again?


grab the latest ISO/IMG, and “install”. it should find the current pool and keep everything in tact


ok - what about GRUB - will it keep it?
I have a multi boot setup -(I would love to run TruOS solely, but ever since PCBSD I can’t get our printer to work even so I have the rpm drivers, but have not solved to install them; but this is another topic)


that I do not know. I know the devs have removed grub for numerous reasons.

When you try and boot into Trueos, I think the menu option is 3 (someone will correct me if I’m wrong) which allows you to select boot envirnments


well I will see how it will turn out - let you know the result


I had something similar after picking up the latest Stable update (installed 0603). Openvpn client is not working so I rebooted to go back to a known working BE. Selected it at boot loader, hit enter to boot it, it would boot but during startup failed trying to load modules with a bunch of “kvm kernel not ELF format”. But if I was booted into the 0603 BE, used beadm to activate an alternate BE and rebooted, it was fine. So something early on is a bit borked.


I might have had a similar problem on one of my machines. But as that one also has that strange 0x40 error it might also have arisen from that error.

In any case: None of the pre-June BEs would boot properly - lots of red indications while trying to load modules etc.

Initially I just wanted to upgrade the latest BE via update. But as none of the BEs would boot I just installed from the USB image into a new BE and deleted all the other BEs - I didn’t think I could repair them (didn’t think of @mer’s trick), and honestly I didn’t really care.
For one I’m only still testing TrueOS and that system is not even my main test system, and secondly, the June 2017 image brings so much new stuff that I wouldn’t need an older BE anyway. The things I use work (except for the mentioned minor bug) as far as I can tell.

So, I also had this strange problem that none of the existing BEs (I guess they were all based of the April 2017 image) even though they worked fine last time I fired up that machine.

But as I mentioned, between the BTX loader and the BSD (boot)loader I get that not very healthy sounding error message - so my problem might have a different cause.


I wonder if there was an upstream KABI change that got picked up and is causing this.


What kind of printer is it?.. Have you tried installing trough CUPS?


Hi, it is a Brother “MFC-845CW” and I tried all the CUPS drivers through.
Got TruOS back installed new, but have yet to figure out how to boot back to Linux (rEFInd buttons non existent in the installer, but the systems are listed for booting F1, F2,…I get only #####)
Thanks for all your answers!


check out https://www.openprinting.org/printers/ for your printer. it does not show anything for me. nut your mileage may vary.

if you have access to the “ppd” file, you’ll be in luck


I went on an old Macbook (10.4)and copied the ppd file…then tried to install it via the “manage printer” option and it declared:
“bad ppd file”…but it is not bad in the Macbook
yes I looked through all, didn’t find anything - in Linux I just install the .rpm file from the brothersite and it works.
Anyway…I have the CD, but TrueOS can’t open it, or do I have to install something for that?


Hi! got now the same issue on netbook… All BEs trashed backwards from latest update, So: I still have grub working for the other systems, but TrueOS is disabled by itself…
New install looses my setup as happened on laptop, and the update lost TrueOS.
Hope to figure it out someday.


I’m having a similar problem, with my multi-boots, grub is still there for my Linux OS’s, no luck on TrueOs.

This is not a permanent fix, but this will allow you to boot into TrueOS.
Download & install to Usb as a boot disk. Super grubdisk. http://www.supergrubdisk.org/category/download/

This works for me. Although I’m waiting for some tech support on how to configure"rEFInd" boot installer working. I’ve tried to install it with arch & Devuan.Without success.

Read my post. Multiboot & rEFInd.


I appreciate your help… I was using Rescatux always for “repair” but never booted through it…have to try your solution : )


i talked with Kris, Ken, and other devs. seems there was a bug in beadm of some sort. beadm is what reads boot environments.

it was patched an STABLE was this past week


Thanks for your tip…I could boot into Linuxes with the supergrub disk and TrueOS can boot directly into it’s own partition…now installing the other laptop