Logging in as root!


#1

Too old for lectures, I am already aware of all the hype on why root login is bad. However, some of us are old dogs that have been doing this successfully, for many years.

I have 1 single system as a configuration sandbox where I do everything as root. Every time I configure/install a new OS/Desktop/Server/Router/Firewall/etc… OR, buildworld for a custom kernel or patch level, I expect the system may crash. Therefor it is regularly scratch installed.

Once a config is completed, beat on, abused, & finalized, the new system is built & configuration moved to it.

Now comes TrueOS ( I started with BSD when it was still at Berkely ). Based on the bleeding edge, with its own desktop. I love it, many kudos to the developers. However, we really need way to work graphically as root in many cases.

So, how can one login to Lumina As Root?


#2

a place to start

/usr/local/etc/pcdm.conf


#3

Tried that last week to no avail. Then again, that was before a reboot ( custom kernel ), which crashed…


#4

the “simple” way.

disable PCDM, via service system, search for it, don’t recall off the top of my head.

And from the bootup terminal login as root, and startx with your .xinitirc looking like;

exec lumina-desktop


#5

Just because I love this page so much… https://www.garyshood.com/root/

In seriousness though, I ran as root for a very very long time when I ran my customized version of Slackware that ran entirely in RAM. It’s not the worst thing in the world. On TrueOS I’ve always don wht Rod suggested and disable PCDM and log in the original way.


#6

Yep:

  1. Turn off PCDM from startup: (CLI: rc-update delete pcdm default, or use SysAdm service manager)
  2. Login as root via CLI prompt the standard “server” way.
  3. Run start-lumina-desktop to initialize a graphical Lumina session (other DE’s will have other commands)

NOTE: When a graphical session is running, it is still possible to use Ctrl-Alt-F# to switch back to the non-graphical terminal session - even when the graphical session is “locked”. This can be a security concern for the computer (in addition to all the other issues with running graphical apps as root) — you have been warned!! :wink:

Alternatively, I would recommend logging into the system normally through PCDM as a user, then setup your “sudoers” rules to allow that user to switch to root permissions without a password. Then setup an automatic-launch rule to run “sudo lumina-open -terminal” to automatically open your default terminal with root permissions whenever you log into Lumina.