Keyboard and menu not working in Virtualbox in fullscreen display


#1

[I mentioned most of this in my post on virtualbox v. suspend-wake, but it’s become clear that really it’s own set of issues…]

Virtualbox 5.2.6 on TrueOS 18.03:

In virtualbox guests in fullscreen (but not windowed display) keyboard input is largely lost. “Largely” because even though everything including the host-key doesn’t do anything, ctrl-alt-F? does switch to consoles (and the keyboard works fine there). Also “largely” because the keyboard did start working at one point in a linux-4.16 guest in fullscreen after not working, but was lost on return to fullscreen. Note that linux-4.16 attempts integrating at least much of the virtualbox guest-additions functionality into the kernel…fullscreen at native resolution does work…

Also in fullscreen, the popup virtualbox menu at the bottom (optionally top) of the screen doesn’t come up at all (never seen it).

(Note that the same machine with EL7 as the host-OS had none of these problems…)


#2

Okay, so a silly user-interface hack-maneuver gets guests (or at least one) keyboard input back in fullscreen:

ctrl-alt-right/left-arrow to switch to a different workspace, type something there (that’s necessary) then switch back. Keyboard input received by guest.

This is in the lumina desktop with the workspaces widget; the fact that this works suggests that the problem might be with virtualbox’s interaction with lumina…I haven’t checked any of this with fluxbox or any other desktops.

[Edit] Spoke to soon; this does not work reliably, but only sometimes.
[Edit] …though it seems more often than not. It’s also possible but far from definite that enabling PAE/NX and/or selecting the PII3 chipset help… Additional observation is that limiting cpu to less than 100% carries too much cpu overhead for this to be useful (there was something on the FreeBSD forum about setting kern.hz=100 maybe mitigating that but I haven’t tried it)
.