Kernel: WARNING: autofs_task:


#1

autofs seems to want to access all my disk partitions on booting - so it takes a huge amount of time if I don’t kill it to by-pass it.
I have about 6 drives on my desktop - some with multiple partitions - so it takes an age if left on its own.
Even if I do let it run to the end - none of the disks are available even as root.
Also, it doesn’t detect newly inserted USBs .
Messages at boot time are typically:
kernel: WARNING: autofs_task: request 1 for /.autofs/ timed out after 30 seconds
Dec 15 22:38:08 kernel: WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
Repeats forever.
This is me:
boot environment now (N) … 12.0-CURRENT-up-20171215_223521 NR 2017-12-15
_ after restart ® … 12.0-CURRENT-up-20171215_223521 NR 2017-12-15_
boot loader …………………………………… BSD
_ type ……………………… BIOS_
CPU ………………………………………………………… AMD Phenom™ II X4 955 Processor
_ number of cores ……………… 4_
host ……………………………………………………… JJMsTrueOS
memory ………………………………………………… 16384 MB available, 12274 MB free
OS git branch ……………………………………………………………………………………… trueos-master
OS git revision ………………………………………………………………………………… 7a0a0994e
OS kernel build time ………………………………………………………… Sun 2017 Dec 3 15:25:30 UTC
OS kernel identity …………………………………………… (uname -i) GENERIC
OS platform (architecture) ……………………… (uname -m) amd64
OS release level ………………………………………………… (uname -r) 12.0-CURRENT
OS version and patch level …… (freebsd-version) 12.0-CURRENT
TrueOS package set ………………… UNSTABLE

Hope someone can help - at least to turn this off at boot time.
Thanks,


#2

Answer my own question by disabling automount commands in Services.
Would still like to know the purpose of this utility sometime - and of course the future or alternatives to Disk Manager which seems to have disappeared.


#3

automounter is how external devices like USB drives get automounted by Lumina.
I’m not sure exactly what the warnings mean, but the netmount service also has a hook into /.autofs. If you aren’t mounting any network shares from /etc/fstab, you can probably turn this off and remove it from the default runlevel

as root:
rc-service netmount stop
rc-update delete netmount


#4

Thanks for the information - especially the commands.

However, I’m still puzzled how automounte or netmount mistakes my SATA drives for either external USB drives or network shares.
No doubt it will become clearer or fixed some time.


#5

“6 disks with multiple partitions” are these partitions BSD native partitions like ZFS or UFS? If not, that could be why: it sees Linux or Windows partition types and tries to mount them.


#6

Some partitions are other TrueOS installations - so are ZFS.
Some are linux partitions such as EX2 where I was transferring files between Linux and TrueOS.
You could be right - it is trying to mount them. But if that’s the case, it fails every time.
I have never seen anything appear in the /.autofs or the /media directory for that matter.
ZFS is fine - I have been able to mount one of my key ZFS pools with no trouble at all.
In fact the zpool import command shows me everything I need to know ZFS wise.
Trouble is - I can’t see or use anything else.


#7

gpart list should be able to walk the devices and dump information about them. Look at the “Providers” information, that gives you disk/partition name then the “type” a bit further down tells you what it is.

then you can use that information to add mountpoints in your /etc/fstab to get them mounted. If you don’t want them always mounted, make sure to add the “noauto” option. Having them in fstab means you can simply do:
mount /linux1

instead of
mount -t ext2 /dev/ada4p3 /linux1


#8

Many thanks - I’ll take your advice.
I used to use Linux because it had good partitioning utilities - especially openSuse - but I use it less and less these days.
But it does prompt the question of what is the best way of recognising and mounting usb sticks or cds?

Many thanks again - good advice.


#9

The way I’ve done it for years is by adding an entry to /etc/fstab or entering the full mount command by hand. Just my way of doing it. I feel I have more control that way, because nothing is mounted unless I do it (think of a USB drive that you want to dd trueos.latest.img to), I can mount it read only, no exec if I want.

mount -t msdosfs takes care of pretty much all USB drives
mount -t cd9660 takes care of CD, DVDs

If you poke around with man pages, you’ll figure out how to mount an ISO image on a memory disk so you can look at it, there are also ways of mounting Linux ext2/3/4 and NTFS partitions (I don’t recall the specifics, been a while)


#10

The automounter service should not be “mounting” any of the devices/partitions unless they are specified in “/etc/fstab”. The service only pokes the devices at service init with the gpart/fstyp utilities to try and figure out if they can be used at all (these tools do not mount the device), and generate shortcuts for the ones that can be used in the /media directory.
It is possible that since most of them are ZFS-based partitions (which should be ignored by automounter), one of the ZFS listing commands might be picking up on them and getting bogged down. Not positive though.


#11

Preliminary - but I thought you should know.
Automount is innocent - it is netmount that was causing the trouble.
I noticed that dmesg was giving me continual messages such as below.
Have now stopped netmount and resumed automount - and every seems to be behaving.
Automount detected a USB, mounted it properly and didn’t create huge streams of messages.
Have included all of the dmesg messages rather than just a sample as there may be a clue for you guys into what is going on here.
Thanks for all the help.
WARNING: autofs_task: request 0 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 1 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 2 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 3 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 4 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 5 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 6 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 7 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 8 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 9 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 10 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 11 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 12 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 13 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 14 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 15 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 16 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 17 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 18 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 19 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 20 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 21 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 22 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 23 for /net/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /net/ completed with error 60
WARNING: autofs_task: request 24 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 25 for /net/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /net/ completed with error 60
WARNING: autofs_task: request 26 for /net/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /net/ completed with error 60
WARNING: autofs_task: request 27 for /net/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /net/ completed with error 60
WARNING: autofs_task: request 28 for /net/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /net/ completed with error 60
WARNING: autofs_task: request 29 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 30 for /net/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /net/ completed with error 60
WARNING: autofs_task: request 31 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 32 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 33 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 34 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
WARNING: autofs_task: request 35 for /.autofs/ timed out after 30 seconds
WARNING: autofs_trigger_one: request for /.autofs/ completed with error 60
`


#12

The “netmount” service (if my memory is correct) is what looks at the entries in /etc/fstab and tries to mount any network drives. Try looking in that config file and see if you have any network drives registered that might not be available on your current network.


#13

Here is my /etc/fstab - it doesn’t seem to have any network references.

# Device		Mountpoint		FStype		Options	Dump Pass
/dev/label/swap1.eli	none		swap	sw	0	0
procfs			/proc			procfs		rw		0	0
linprocfs		/compat/linux/proc	linprocfs	rw		0	0`Preformatted text`

Is there anything I can do to help?
This system was only recently installed UNSTABLE into an already existing ZFS Pool (I think).


#14

the December release of UNSTABLE?


#15

I did see the warnings - but I’m sure this came out after the warnings.
Did a roll-back as advised on a previous update.

This one seems very stable - but needs the netmount command not running.
Could enable it again of course and report on whatever you may be looking for.

boot environment now (N) … 12.0-CURRENT-up-20171224_195155 NR 2017-12-24
       after restart (R) … 12.0-CURRENT-up-20171224_195155 NR 2017-12-24
boot loader …………………………………… BSD
            type ……………………… BIOS
CPU ………………………………………………………… AMD Phenom(tm) II X4 955 Processor
    number of cores ……………… 4
host ……………………………………………………… 
memory ………………………………………………… 16384 MB available, 13445 MB free
OS git branch ……………………………………………………………………………………… trueos-master
OS git revision ………………………………………………………………………………… 81fec14cc
OS kernel build time ………………………………………………………… Wed 2017 Dec 20 14:49:06 UTC
OS kernel identity …………………………………………… (uname -i) GENERIC
OS platform (architecture) ……………………… (uname -m) amd64
OS release level ………………………………………………… (uname -r) 12.0-CURRENT
OS version and patch level …… (freebsd-version) 12.0-CURRENT
TrueOS package set ………………… UNSTABLE
TrueOS version …………………………… TrueOS-Desktop-201712111405
uptime ………………………………………………… 1:45
user  …………………………………………………… xxxxx

#16

I’m having this problem in my PC … appear those messages in the initialization of the TrueOS and the beginner is very slow … there is a solution to the problem??? I’ll await your answer.

Everaldo


#17

Have you attempted to update this month?


#18

I believe yes! But why??? Is there a new update now???


#19

updates are/were available last week.


#20

RodMyers, the trouble is I don’t get access Internet, it’s disable … how will I run the service network, again in the terminal/Konsole??? Before, the service were working, but now … not!!! I’m write that message via linux ubuntu, ok!