Installing KDE onto TrueOS


I very much appreciate that You intend to ‘do it right’, and not: ‘quick and dirty’.

I fully trust in Your wisdom regarding this.


I’ll see if it helps. No more Hasell, Xmonad, PlayonBSD or KDE5-5:

[ ~% sudo pkg delete gcc-ecj
     Checking integrity... done (0 conflicting)
    Deinstallation has been requested for the following 53 packages (of 0 packages in the universe):

Installed packages to be REMOVED:

Number of packages to be removed: 53

The operation will free 2 GiB.


Since you are using KDE, notice the last 2 lines.

It’s going to remove PlayOnBSD and kde5. I htink KDE5 is the meta package which will cause KDE to removed/not upgrade next time


I just removed the package and rebooted (just to see what happens). Plasma5 still works and seems to be stable. I had some problem with a pkg update earlier. So I have reverted to a previous Boot Enviroment. I’ll soon reboot (so I have a known state) and see if Lumina is stable now.


Just a warning:
Check the AppCafe’s “installed packages” list and see if your KDE installation is flagged as “orphan” packages. Anything listed as an “orphan” (accidental left-over from a previous removal) will be ignored by the package system during the next upgrade, result in the removal of those orphans. If you want to ensure that your packages will continue to work, run the “pkg autoremove” command on the CLI, or hit the “Clean” button in the AppCafe to find/remove all the orphan packages (both methods will let you see a list of what will be removed before starting the procedure).

In the next UNSTABLE package set we have physically unhooked and disabled the gcc-ecj package - so it will no longer even be an option in the repo.


Something strange happened recently to the kde-baseapps installation.
When I start the computer and open Dolphin everything works normal. But if I close and open it again, it opens but won’t show my files instead I get the message “The process for the protocol file died unexpected”. (?) :thinking:
The Insight file manager works, and if I log out and log in, Dolphin works again ones, then the same thing appears if I close and open it again.

Any ideas? I’m thinking that kde-baseapps may be outdated and will works normal again after the coming STABLE update, at least I hope so.
The other KDE apps that I installed like Gwenview and Okular works normal.

BTW, as reply on older posts above:

@jmdavis You probably know that you can install kde-baseapps onto Lumina. I did it and that way I got the best of both worlds. They again I miss a few functions from KDE, but I hope they will show in coming updates.

Another thing. When i was playing around with the KDE apps, I also installed kde-workspace. I don’t recommend to do that, it looked like crap and not even close to the nice KDE in PC-BSD. Also IMHO I think KDE 5 looks very much like KDE 4 in PC-BSD and I don’t know which one of Lumina or KDE I prefer, I like them both.

@beanpole135 I tried to plug in an external mic on the laptop, no change. There is still no mic option in Mixer => System Configuration.

Another questions: How do I adjust the clock in TrueOS/Lumina? It’s easy in PC-BSD/KDE but I don’t find any option for that in TrueOS/Lumina.
Daylight-saving time is over, for now I adjusted the clock in BIOS, but I believe there must be a way to do that inside the OS.


Regarding TIME-Setting:

EFI/BIOS time should be UTC. All Operating Systems want this, and work best this way. Only exception: Microsoft (Of course…).


PC-BSD 10.3 and TrueOS run virtually the same version of KDE (it would just be a minor version difference with bug fixes, because there has been no major KDE 4 release in some time). If there’s a significant difference in how they look, then it’s a difference in the settings, and PC-BSD may have tweaked the default settings more. The software is the same though. And in my experience, KDE 5 really doesn’t look much different from KDE 4. But the look depends heavily on your settings. My KDE desktops have looked virtually identical on several machines for years now whether they’ve been running FreeBSD or Linux and regardless of the version of KDE. I wouldn’t expect to be able to tell the difference between a KDE 4 and KDE 5 system at a glance (though there are certainly differences once you start digging). And while I do change the look of KDE, I don’t change it much (mostly just the color scheme and how I configure the taskbar). Regardless, the look and feel is highly dependent on how you configure it, and KDE can look like most anything you want. But if you like how Lumina looks and it works for you, then that works for you.

Yeah. I don’t know why TrueOS defaults to localtime. It’s definitely a mistake IMHO. I suspect that it’s because at some point, there was a I relatively high expectation of folks dual booting with Windows, which is the only case where localtime would make sense. Sure, some folks still dual boot, but those folks can choose localtime if they need to. The default should be the correct one, not the one that’s needed to make dumb OSes happy. Personally, while I do still dual boot (though I’d like to get Windows onto a separate machine the next time I upgrade), I just chose UTC for Windows’ time zone so that I don’t have to set the bios to localtime and deal with the subtle problems that ensue.


Have you seen this post?
That seems to be a way to go, doesn’t it?


I don’t believe that TrueOS defaults to localtime in BIOS. Every FreeBSD system that I’ve run (since about FreeBSD3.3) I’ve set the BIOS clock to UTC, set the local timezone to North America/New York (Eastern Time) and then setup NTP. Never had an issue with DST/Standard Time.

You run into issues when you have a machine that is dual booting with Windows because as pointed out MS wants BIOS in localtime; you worked around this by telling Windows to use UTC for the timezone.


Then run the installer, and you’ll see. It gives you a choice, but it defaults to localtime. You have to check the checkbox for it to treat what’s in the BIOS as UTC. Of course, I always set it to UTC, but that’s not the default.


Ok, so it’s been a while that I’ve run the installer, but if most of the systems being installed are recycled Windows or dual boot with Windows, BIOS is most likely set to localtime, so in the installer localtime actually makes sense as the default. That way on reboot the time is correct if you do the date command but now it’s “+/- timezone” off if you are using NTP; that’s where the problems happen.

Since I’ve always set my BIOS to be UTC I must have checked the “BIOS is UTC” without thinking about it.


I continue on this thread since it’s mainly a KDE issue. Please help me out with these issues. Anyone?

Like I said above I installed kde-baseapps that comes with Dolphin. Then I also installed kde-gwenview and kde-okular. I like those programs better than Lumina’s equivalents.

At first everything did run perfect, but later an error occurred which turned out as follow:

  1. When I start the computer everything runs normal and I can open all programs.
  2. If I close Dolphin and later a try to reopen it, the text “The process for the protocol file died unexpected” come up as a drop down on top of the window.
  3. Insight continuous to work normal, but the only way solve the Dolphin-problem seems to be to logout and login again (I don’t need a full reboot). But that only solves it temporarily. Closing Dolphin and trying to reopen it fails again.

I thought that was due to that some parts of it may have been outdated and that the latest STABLE 17.12 update would fix it. But even after I successfully got the update to run the problem with Dolphin remains.

Is there some way to fix this?

Another thing is that I noticed is that Gwenview can show videos in PC-BSD, but not TrueOS.
This is not a serious problem since I can run videos in VLC, but I’m curious why it won’t work in the same way in TrueOS as in PC-BSD?

There is also another problem that remains.
I can’t get the mic to work and it doesn’t matter if I try to use the internal screen mic or connect an external one.
The option “mic” simply isn’t there in Mixer => System Configuration => Recording Unit (drop down menu). I think all other options are there except “mic”.

I’ve installed PulseAudio = No change.
I tried all kind of settings both in Mixer and PulseAudio = No change.
I can get “mic” to show up if I change the speaker settings, but it doesn’t help, and then I have no sound either.

However, there are a number of click boxes in PulseAudio Preferences in four tabs named “Network Access”, “Network Server” “Multicast/RTP” and “Simultaneous Output” that I don’t remember if I tried. None of the boxes are checked as default. Could any of these settings make a change? Or would it just ruin everything?

This has nothing to do with Firefox, but I need the mic to be able to use Skype. I have Skype running and I can receive but not send.

Some thoughts and strange behaviour on TrueOS STABLE 17.12