Installing KDE onto TrueOS


#35

STABLE or UNSTABLE?

If on UNSTABLE, from a terminal type --> sudo pkg info | grep gcc-ecj <-- and report either way


#36

Along the same lines as @RodMyers, it sounds like you have other issues with your systems rather than anything with Lumina, since Lumina does not effect applications at all. If an app like Firefox or chromium is crashing, then something associated with that utility is having trouble, not the desktop that happens to be running at the time.
In particular, Rod is referring to a known issue where installing the GCC compiler instantly start causing GTK-based applications to behave erratically and crash frequently - in part becuase of the “gcc-ecj” plugin, and in part because a number of applications (such as the ones that are crashing) are written on/for Linux and if they see the gcc libraries installed they will automatically link/use them instead of the FreeBSD libraries with the same name!!

So the moral of this story is that if you are having crashes or system instability like this, please report it! More often than not, we can track down the problem and/or give you a solution (example: the “gcc-ecj” issue should be fixed on UNSTABLE).


#37

I switched to UNSTABLE since I had the problems described in my previous post on STABLE. So I figured my problems would be addressed sooner on the UNSTABLE branch. I could try to switch back to STABLE if it is helpful.

Output from sudo pkg info | grep gcc-ecj:

gcc-ecj-4.5 Eclipse Java Compiler used to build GCC Java


#38

that is the cause of your crashing

in the terminal type --> sudo pkg delete gcc-ecj

note what will be removed. if you can live with what will be removed, type --> y <-- and remove it


#39

I’m not sure about this because I didn’t test this. But, nonetheless:

Maybe, it’s possible to add a ${…LIB…} variable to the default process environment for executables with origin from the Linux-world. This could possibly mitigate the problems with dynamic linking and GCC.


#40

Yes, we have been looking into solutions like that but are trying to find one that does not require patching every single GTK application port. If that is the only way to fix this, then we are going to have to get the FreeBSD porting community involved in the patches and wait on them to fix it, simply because there are so many ports that do this and we don’t want to maintain our own special “blend” of patches to ports (we try to keep port differences between FreeBSD/TrueOS to a minimum when possible).


#41

I very much appreciate that You intend to ‘do it right’, and not: ‘quick and dirty’.

I fully trust in Your wisdom regarding this.


#42

I’ll see if it helps. No more Hasell, Xmonad, PlayonBSD or KDE5-5:

Summary
[ ~% sudo pkg delete gcc-ecj
     Checking integrity... done (0 conflicting)
    Deinstallation has been requested for the following 53 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
        gcc-ecj-4.5
        gcc6-6.4.0_2
        wcslib-5.16_2
        hs-xmonad-contrib-0.13_1
        hs-xmonad-0.13_1
        hs-X11-xft-0.3.1_15
        hs-extensible-exceptions-0.1.1.4_8
        hs-setlocale-1.0.0.5
        hs-utf8-string-1.0.1.1
        hs-X11-1.8_1
        hs-data-default-0.7.1.1
        hs-data-default-instances-base-0.1.0.1
        hs-data-default-instances-containers-0.0.1_8
        hs-data-default-instances-dlist-0.0.1_8
        hs-data-default-instances-old-locale-0.0.1_9
        hs-dlist-0.8.0.3
        hs-data-default-class-0.1.2.0
        hs-cabal-install-1.24.0.2
        hs-async-2.1.1.1
        hs-hashable-1.2.6.1,1
        hs-random-1.1_1
        hs-hackage-security-0.5.2.2
        hs-HTTP-4000.3.7
        hs-vector-0.12.0.1
        hs-stm-2.4.4.1
        hs-tar-0.5.0.3
        hs-zlib-0.6.1.2
        hs-base16-bytestring-0.1.1.6_3
        hs-base64-bytestring-1.0.0.1_9
        hs-cryptohash-sha256-0.11.100.1
        hs-ed25519-0.0.5.0
        hs-old-time-1.1.0.3_1
        hs-network-2.6.3.2
        hs-network-uri-2.6.1.0
        hs-primitive-0.6.2.0                                                                                                                                                                 
        hs-old-locale-1.0.0.7_1                                                                                                                                                              
        hs-parsec-3.1.11                                                                                                                                                                     
        hs-mtl-2.2.1_1                                                                                                                                                                       
        hs-text-1.2.2.2                                                                                                                                                                      
        ghc-8.0.2_2                                                                                                                                                                          
        py27-numpy-1.13.3,1                                                                                                                                                                  
        suitesparse-4.0.2_7                                                                                                                                                                  
        openblas-0.2.20_1,1                                                                                                                                                                  
        lapack-3.5.0_3                                                                                                                                                                       
        cblas-1.0_7                                                                                                                                                                          
        blas-3.5.0_3                                                                                                                                                                         
        kstars-17.08.2                                                                                                                                                                       
        py27-PyOpenGL-3.1.0_1                                                                                                                                                                
        kdeedu-17.08.2                                                                                                                                                                       
        py27-wxPython28-2.8.12.1_9
        py27-wxPython28-common-2.8.12.1_5
        kde5-5.11.2.17.08.2
        playonbsd-4.2.10_1

Number of packages to be removed: 53

The operation will free 2 GiB.

#43

Since you are using KDE, notice the last 2 lines.

It’s going to remove PlayOnBSD and kde5. I htink KDE5 is the meta package which will cause KDE to removed/not upgrade next time


#44

I just removed the package and rebooted (just to see what happens). Plasma5 still works and seems to be stable. I had some problem with a pkg update earlier. So I have reverted to a previous Boot Enviroment. I’ll soon reboot (so I have a known state) and see if Lumina is stable now.


#45

Just a warning:
Check the AppCafe’s “installed packages” list and see if your KDE installation is flagged as “orphan” packages. Anything listed as an “orphan” (accidental left-over from a previous removal) will be ignored by the package system during the next upgrade, result in the removal of those orphans. If you want to ensure that your packages will continue to work, run the “pkg autoremove” command on the CLI, or hit the “Clean” button in the AppCafe to find/remove all the orphan packages (both methods will let you see a list of what will be removed before starting the procedure).

In the next UNSTABLE package set we have physically unhooked and disabled the gcc-ecj package - so it will no longer even be an option in the repo.


#46

Something strange happened recently to the kde-baseapps installation.
When I start the computer and open Dolphin everything works normal. But if I close and open it again, it opens but won’t show my files instead I get the message “The process for the protocol file died unexpected”. (?) :thinking:
The Insight file manager works, and if I log out and log in, Dolphin works again ones, then the same thing appears if I close and open it again.

Any ideas? I’m thinking that kde-baseapps may be outdated and will works normal again after the coming STABLE update, at least I hope so.
The other KDE apps that I installed like Gwenview and Okular works normal.


BTW, as reply on older posts above:

@jmdavis You probably know that you can install kde-baseapps onto Lumina. I did it and that way I got the best of both worlds. They again I miss a few functions from KDE, but I hope they will show in coming updates.

Another thing. When i was playing around with the KDE apps, I also installed kde-workspace. I don’t recommend to do that, it looked like crap and not even close to the nice KDE in PC-BSD. Also IMHO I think KDE 5 looks very much like KDE 4 in PC-BSD and I don’t know which one of Lumina or KDE I prefer, I like them both.

@beanpole135 I tried to plug in an external mic on the laptop, no change. There is still no mic option in Mixer => System Configuration.

Another questions: How do I adjust the clock in TrueOS/Lumina? It’s easy in PC-BSD/KDE but I don’t find any option for that in TrueOS/Lumina.
Daylight-saving time is over, for now I adjusted the clock in BIOS, but I believe there must be a way to do that inside the OS.


#47

Regarding TIME-Setting:
https://www.freebsd.org/cgi/man.cgi?query=tzsetup&sektion=8&manpath=FreeBSD+11.1-RELEASE+and+Ports

EFI/BIOS time should be UTC. All Operating Systems want this, and work best this way. Only exception: Microsoft (Of course…).


#48

PC-BSD 10.3 and TrueOS run virtually the same version of KDE (it would just be a minor version difference with bug fixes, because there has been no major KDE 4 release in some time). If there’s a significant difference in how they look, then it’s a difference in the settings, and PC-BSD may have tweaked the default settings more. The software is the same though. And in my experience, KDE 5 really doesn’t look much different from KDE 4. But the look depends heavily on your settings. My KDE desktops have looked virtually identical on several machines for years now whether they’ve been running FreeBSD or Linux and regardless of the version of KDE. I wouldn’t expect to be able to tell the difference between a KDE 4 and KDE 5 system at a glance (though there are certainly differences once you start digging). And while I do change the look of KDE, I don’t change it much (mostly just the color scheme and how I configure the taskbar). Regardless, the look and feel is highly dependent on how you configure it, and KDE can look like most anything you want. But if you like how Lumina looks and it works for you, then that works for you.

Yeah. I don’t know why TrueOS defaults to localtime. It’s definitely a mistake IMHO. I suspect that it’s because at some point, there was a I relatively high expectation of folks dual booting with Windows, which is the only case where localtime would make sense. Sure, some folks still dual boot, but those folks can choose localtime if they need to. The default should be the correct one, not the one that’s needed to make dumb OSes happy. Personally, while I do still dual boot (though I’d like to get Windows onto a separate machine the next time I upgrade), I just chose UTC for Windows’ time zone so that I don’t have to set the bios to localtime and deal with the subtle problems that ensue.


#49

Have you seen this post?
That seems to be a way to go, doesn’t it?


#50

I don’t believe that TrueOS defaults to localtime in BIOS. Every FreeBSD system that I’ve run (since about FreeBSD3.3) I’ve set the BIOS clock to UTC, set the local timezone to North America/New York (Eastern Time) and then setup NTP. Never had an issue with DST/Standard Time.

You run into issues when you have a machine that is dual booting with Windows because as pointed out MS wants BIOS in localtime; you worked around this by telling Windows to use UTC for the timezone.


#51

Then run the installer, and you’ll see. It gives you a choice, but it defaults to localtime. You have to check the checkbox for it to treat what’s in the BIOS as UTC. Of course, I always set it to UTC, but that’s not the default.


#52

Ok, so it’s been a while that I’ve run the installer, but if most of the systems being installed are recycled Windows or dual boot with Windows, BIOS is most likely set to localtime, so in the installer localtime actually makes sense as the default. That way on reboot the time is correct if you do the date command but now it’s “+/- timezone” off if you are using NTP; that’s where the problems happen.

Since I’ve always set my BIOS to be UTC I must have checked the “BIOS is UTC” without thinking about it.


#53

I continue on this thread since it’s mainly a KDE issue. Please help me out with these issues. Anyone?

Like I said above I installed kde-baseapps that comes with Dolphin. Then I also installed kde-gwenview and kde-okular. I like those programs better than Lumina’s equivalents.

At first everything did run perfect, but later an error occurred which turned out as follow:

  1. When I start the computer everything runs normal and I can open all programs.
  2. If I close Dolphin and later a try to reopen it, the text “The process for the protocol file died unexpected” come up as a drop down on top of the window.
  3. Insight continuous to work normal, but the only way solve the Dolphin-problem seems to be to logout and login again (I don’t need a full reboot). But that only solves it temporarily. Closing Dolphin and trying to reopen it fails again.

I thought that was due to that some parts of it may have been outdated and that the latest STABLE 17.12 update would fix it. But even after I successfully got the update to run the problem with Dolphin remains.

Is there some way to fix this?

Another thing is that I noticed is that Gwenview can show videos in PC-BSD, but not TrueOS.
This is not a serious problem since I can run videos in VLC, but I’m curious why it won’t work in the same way in TrueOS as in PC-BSD?

There is also another problem that remains.
I can’t get the mic to work and it doesn’t matter if I try to use the internal screen mic or connect an external one.
The option “mic” simply isn’t there in Mixer => System Configuration => Recording Unit (drop down menu). I think all other options are there except “mic”.

I’ve installed PulseAudio = No change.
I tried all kind of settings both in Mixer and PulseAudio = No change.
I can get “mic” to show up if I change the speaker settings, but it doesn’t help, and then I have no sound either.

However, there are a number of click boxes in PulseAudio Preferences in four tabs named “Network Access”, “Network Server” “Multicast/RTP” and “Simultaneous Output” that I don’t remember if I tried. None of the boxes are checked as default. Could any of these settings make a change? Or would it just ruin everything?

This has nothing to do with Firefox, but I need the mic to be able to use Skype. I have Skype running and I can receive but not send.


Some thoughts and strange behaviour on TrueOS STABLE 17.12
#54