Installing KDE onto TrueOS


#1

Since I don’t come along with Lumina yet I tried to install KDE on TrueOS. It worked, but it filled the whole screen with all kind of KDE utilities (I was about to call it garbage, but of cause it’s not, but it’s stuff I don’t need).

Question: Is there a way to clean that out in a efficient way without having to pick every single utility?
I tried to clean it for a while but got tired of it and tried the orphan cleaner in AppCafe but that cleaned out all the utilities including the one ones I wanted and also the whole KDE.

Note: I never logged out and logged into KDE, maybe that was the problem, but the utilities I mentioned came up inside Lumina.
Or is there a way to install KDE and just get the base-apps?


Dolphin file manager
#2

Open the file manager, browse into your “Desktop” folder, and then you can do mass-delete operations in there. Note that this will just remove the icons on the desktop - it will not remove the applications/packages themselves.

As for the KDE applications themselves, most of them are not designed to run outside of the KDE desktop environment itself, and if you do launch something like Dolphin from within Lumina you actually end up with a ton of KDE desktop/init processes which get spawned in the background and can clog up your system. If you still want to give that a shot, I think there is a “kde-baseapps” package which will install all the “basic” applications from KDE (no way to pick and choose which ones you want, since KDE apps are not written to be used on their own).


#3

What I tried to do was to delete the applications/packages I don’t need from AppCafe “View All Packages”. Is that the wrong way to do this?

As for the other question. My plan is to run the KDE desktop environment but without all the applications/packages that comes with it, just the base-apps as it use to be in PC-BSD. Is it possible somehow to install KDE from AppCafe or from Terminal, and not get the whole bag of applications/packages that comes with it?
If it’s possible yo do this but only from Terminal, then please provide me with the command for it.


#4

Any applications which have packages in the package system can be removed (e.g. amarok is its own package, so if that were installed, and you didn’t want it, you could remove it). However, KDE does group many of its applications, so unless the ports team went to the extra effort of splitting them up, you can’t remove them individually (e.g. if you install the kde-baseapps package, you’ll get both dolphin and konqueror, and they cannot be installed or removed individually). So, there’s a limit to how much you can pair down KDE, but any applications you see that have their own package can be removed by uninstalling their package.

I don’t know what you can and can’t do from the AppCafe though, since I never use it. I just always use pkg from the command line. So, I have no idea what AppCafe hides and what it exposes.


#5

Ok, what the command line for kde-baseapps? My guess is “% pkg install kde-baseapps”, is that correct?

In AppCafe there is only one kde-option and that’s KDE.


#6

Well, if you haven’t installed anything from KDE, then yes, you’d run pkg install kde-baseapps to install the really core applications, and it will likely pull in kdelibs and maybe a couple of others. Make sure that you have kde-runtime installed as well, since without that, you really don’t have KDE itself. After that, it’s a question of what you want to be using (e.g. kdepim is required for kmail).

Now, if you’ve already installed KDE and are trying to trim it down, then that’s a different ballgame, because that involves figuring out which packages to remove. When I set my system up, I installed everything piece by piece, adding a package when I realized that I was missing something, rather than starting with everything and trying to pair it down by uninstalling stuff.


#7

I had KDE installed, but it removed itself after I ran orphan cleaner in AppCafe. SO at the moment there is no KDE installed at all. The orphan cleaner in fact removed the VLC-Player as well, but I reinstalled it.

The only things I plan to use from KDE aside from the basic DE is more or less Dophin, Okular and Gwenview.

I tried that first, and I planed to remove the packages I saw on the desktop that I figured I don’t need, but it went south as I described it above.

But of cause it must be a better idea to install everything piece by piece like you say. I guess that by running, pkg install kde-runtime and then pkg install kde-baseapps and see what come with it is the correct way, correct?
Hopefully I’ll get the basic kde apps with that.

I don’t need Konqueror, Kmail etc. since I run Firefox and Thunderbird, but I can accept if they come along in the baseapps as long as I won’t get a KDE installation with all apps that fill my desktop with icons.


#8

Konqueror is considered a base app (and I don’t know why anyone would want dolphin instead of konqueror, but to each their own). Kmail is in kdepim, so unless you install kdepim for whatever reason, you won’t get kmail. Actually, running pkg query "%Fp" kde-baseapps | grep bin, I get

/usr/local/bin/dolphin
/usr/local/bin/fsview
/usr/local/bin/kbookmarkmerger
/usr/local/bin/kdepasswd
/usr/local/bin/kdialog
/usr/local/bin/keditbookmarks
/usr/local/bin/kfind
/usr/local/bin/kfmclient
/usr/local/bin/konqueror
/usr/local/bin/nspluginscan
/usr/local/bin/nspluginviewer
/usr/local/bin/servicemenudeinstallation
/usr/local/bin/servicemenuinstallation

So, that’s what the current list of “base” apps - not very many applications, really. But any time you have to install a kde package that isn’t for a specific application and is not a meta package, you’re likely to get at least a for applications that you don’t want - especially if you’re trying to only use a few of the KDE applications in general.


#9

Now you got me confused. AFAIK Dophin is KDE’s file manager and Konqueror is KDE’s own web browser. I would say that Konqueror is the alternative to Firefox, not to Dophin. It’s possible that you can browse local files in Konqueror, but that wouldn’t be my first choice.


#10

Konqueror does a ton of different protocols (several come with it and more can be added via a plugin system), and it was KDE’s file manager long before dolphin even existed. Konqueror is a swiss army knife. Yes, it will do HTTP(S), though it’s outdated enough (especially with the KDE 4 version) that I wouldn’t necessarily recommend it for that. But it will also do file browsing, (s)ftp, fish, svn, so and and so forth. For some reason, with KDE 4, they introduced dolphin and made it the default. I don’t know why. They essentially took their flagship program and hid it in the back so that new users wouldn’t have a clue about it. Maybe they thought that Konqueror was too much of a power user tool, and they wanted something more dumbed down. But regardless, Konqueror is still there, and I continue to use it.

The funny thing about konqueror as a web browser though is that its default html rendering engine (khtml) is the ancestor of the html rendering engines used in pretty much every web browser today that isn’t from mozilla or microsoft, because webkit was forked from khtml. So, it helped get a lot of the internet where it is today, but as a web browser, it’s fallen very much behind. :frowning:


#11

I installed kde-runtime and kde-baseapps in that order, but the result is kinda strange. I got Dolphin and a few other KDE utilities inside Lumina which I didn’t think was possible, although they work. But I didn’t get KDE as a login option. It’s still only Lumina and Fluxbox (I don’t know why Fluxbox is there, but that’s another story).

I thought I would get the entire KDE desktop environment, but I didn’t. Is this the way KDE behaves when you install it onto TrueOS or did I do something wrong here?


#12

in AppCafe -> search KDE. look for the meta package. this will install the full desktop if you want


#13

kde-workspace is probably the other key package you’re missing. Looking at the packages installed on my system that have kde in their name, it’s the only one that looks like it would be critical enough to make it so that you can’t log in to kde.


#14

I’ve been working some with TrueOS and testing things on the laptop today and it’s starting to come out pretty well.
I got the Swedish language pack (i10n) for KDE as well as Gwenview in that feels better than the image viewer in Lumina.

In fact I got TrueOS working that good so I’m now starting to think of installing it on my main desktop machine that’s still on PC-BSD 10.3

A few questions.

  1. I installed kde-workspace on the laptop, but that feels like a mistake. It doesn’t feel a bit like KDE on PC-BSD, not even after I made some settings to it. In face adding Dolphin (kde-baseapps), language pack and Gwenview to Lumina works, feels and looks way better.
    Question: If I run the command “sudo pkg uninstall kde-workspace” will that remove it and all traces of it?

  2. PulseAudio setting isn’t working so I can’t get the mic to work. Is there some solution on that?

  3. I would like a virtual desktop switch on the command line like on KDE, instead on having to go into the main menu and settings. Is that possible to fix somehow?

  4. About the desktop computer again. It has an Asus motherboard with AMD CPU (Asus and TrueOS are known not to get along very well) but it has an additional GeForce 210 NVIDIA PCI Express card in it. What chance would you guys give it (lets say on a 1 thru 10 scale) that it’ll run all the way with TrueOS? (it runs perfect with PC-BSD 10.3 right now)

  5. I want to install Flash Player to see some webpages that use it. But I found two in AppCafe. Which one shall I use?

  6. And something that has topped my wishing list for some time, although I haven’t mentioned it for a while now. Is there some ETA on porting the WYSIWYG Website editor BlueGriffon?


#15

Update, changes and addendum to my post above.

As some of you know I had a mishap with my laptop last week System crashing all the time (fixed now).

With Dolphin and a few other KDE utilities like Gwenview and Okular TrueOS/Lumina starts to feel familiar and better than Luminas equivalents (before I installed Okular e.g. pdf’s opened in LibreOffice Impress - not good).

So like I said I’m now starting to think of installing it on my main desktop machine that still is on PC-BSD 10.3 also since it has started to limp a little at start up.

Questions (most of them updated so please ignore ones in my post above) :

  1. If I install TrueOS on top of/on the BE of PC-BSD, will I then be able to shift between them or will it be some sort of a mix? Or is it better to make an all new installation? (of cause I take a backup on Firefox and Thunderbird first)

  2. It seems still to be some missing functions on TrueOS like PulseAudio setting isn’t working on the laptop so I can’t get the mic to work. Is there some solution for that?

  3. I would like a switch for the virtual desktop on the command line like on KDE instead of having to go into the main menu and settings. Is that possible to get somehow?

  4. The desktop computer has an Asus motherboard with AMD CPU (Asus and TrueOS are known not to get along very well). Could that cause a problem? Maybe it helps that it has an additional GeForce 210 NVIDIA PCI Express card in it? What chance would you guys give it (lets say on a 1 thru 10 scale) that it will run TrueOS with no problem? (it runs perfect with PC-BSD 10.3 right now although the little limp at start up which I hope won’t be worse before I upgrade to TrueOS)

  5. I want to install Flash Player to see some webpages that use it. But I found two in AppCafe. Which one shall I use?

  6. And something that has topped my wishing list for some time, although I haven’t mentioned it for a while now. Is there any ETA on porting the WYSIWYG Website editor BlueGriffon?


#16
  1. Until about April update I was able to switch between TrueOS and PC-BSD boot environments. Up then, not anymore. Boot crashed with some error message, I can’t remember which. It seems PC-BSD is not compatible anymore.

#17

in the June or July update, the underlying FreeBSD base had an ABI change, that I would assume making that the way it is


#18

For flashplayer just pkg install linux-flashplayer, nspluginwrapper, and run nspluginwrapper commands mentioned in the FreeBSD handbook.


#19

For pulseaudio probobly installing pavucontrol, and selecting mic would fix. With sndio in unstable I have not found it neccessary to change anything to get microphone in webrtc working in firefox. It just works.


#20

Lifting this thread again. I don’t use the laptop that much, that’s why I haven’t got to this sooner.

I installed pavucontrol with success, but the mic still doesn’t work When I look in Mixer => System Configuration, the option mic simply isn’t there as an option in the drop down menu for Recording Unit. Is there a way to fix this?

I’m trying to get Skype to work. It installed with no problem and the sound works when I make a test call, but the mic won’t work.
Well, so far I just tested with the laptop’s internal mic. But since there is no mic option in the Recording Unit settings I doubt it will make any difference if I plug in an external mic.