Installation failed to overwrite old disk


#1

I’ve this problem lately, whenever I install a new version to an old drive with previous version on it, I can’t recall exactly when it may be start from U2 I couldn’t simply reinstall a new version to overwrite the old one, the installation exits after couple minutes, the error was something related to zpool, What I did to fix that was to wipe the drive and create a ext4 full disk partition with Gpart, I believe any file system will do, the installer may have problem to reuse the old partition or to re-part it, I used default settings during install, coz I couldn’t create a swap otherwise the installation will exit soon after it started with the same error as above, what is going on here ?


#2

“a” way, try changing the zpool name


#3

So the installer will check the old data on the drive before install, other than simply to reformat it to reuse that’s strange.


#4

for me, that has worked reliably.

if it doesn’t work for you, there are other things you can do


#5

Drop to command line

gpart destroy -F adaX

where adaX is whatever drive you want to reuse.


#6

I read somewhere that if the installation “sees” a previous installation of FREEBSD on zfs, it wont write over it. Been several months so I dont remember the logic as to why, but the solution is to overwrite a good portion, like a few hundred MB with zeros using dd. I’m not at home for another few weeks so no access to my old notes so im a bit sketchy on the exact syntax but it goes something like this:
dd if=/dev/zero of=/dev/ada count=80 bs=1m Please check the syntax but that will destroy tge data on the disk that’s preventing installation. Problem is that simply “destroying” the partition then creating a partition does not wipe whatever is there, so you have to do It deliberately.
Sems to me a gpart format to just about any (other, possibly preferring fat32?) should accomplish about the same thing, but ive found often when using usb flash drives for instance, it pays to zero out at least the first few hundred MB or even first few GB works when other things dont.


#7

Thanks, I simply create a whole disk partition with Gpart, much more easier for newbie to do that.


#8

This is crazy, Trident has it’s own mind to decide when to and not to install, I reinstall again the U5 on the same drive, I got same error again

File Sanity Check -> OK
Deleting all gparts
Clearing gpt backup table location on disk
Running gpart on /dev/ada0
Stamping boot sector on /dev/ada0
NEWFS : /dev/ada0p2 - ZFS
vfs.zfs.min_auto_ashift : 9 ->12
EXITERROR : Error 1 : zpool import -f -N trident
Cleaning up…

I tried few things, I format the whole drive to FAT32/Ext4 and also delete the partition without create a new one, I used default install without swap that worked before, but this time no matter what I try all failed to complete the install, but I can install and overwrite another drive with ms windows on it without a hiccup. I tested the problem drive for error but can find none, it must be the weather !


#9

Ok, to me that implies whatever physical drive is at /dev/ada0 is having physical problems.
If you want to install Trident, it sound like you can install it fine on a different physical disk. Is that correct?

If so, I’d do that and then use the disk that has problems as a “play with it but don’t store anything important on it”.
What brand and model is it (the one you have problems with)?

After install I’d also install smartmontools first thing and then set up /etc/periodic.conf to get the SMART status of the disks every day (I can provide samples of the settings later on).


#10

Yes I successfully install on other drive even with ms win on it, the problem drive is a Hitachi notebook drive, I don’t see problem when use it as non booting data drive, my setup is for testing where my important files are on a Linux box, so I wouldn’t mind playing around with the test setup.


#11

Not sure if you did or did not try @RodMyers’ suggestion

That would also be my suggesttion. I had a partition with TrueOs on it and the trident installer wouldn’t install on it even after I deleted and (quick) reformatted the partition using partedmagic. Only after I used another zpool name it would install.
I have no idea how the installer could have possible known that there had been a zfs system on that partition. Either normal (= quick) format on partedmagic doesn’t do a good enough job - or there’s some info in the MBR which isn’t touched by the formatting process of a partition?


#12
ZFS stashes configuration information about the pool within the vdevs at both the 
front and the back.
if your new partition table happens to align with the old one then ZFS will 
detect and try to resurrect the previous pool on import.

ISTR that Rod wrote that the Trident Installer developers are working on fixing 
your issue.
John
groenveld@acm.org

#13

Glad to know that I am not alone on this issue, in the mean time I will try ‘zero’ the drive so that the installer will not try to recuse it from crash. It is strange that the installer returned error with mention of gpart that I used for partition the drive, coz I also used other tools to do it without creating a partition, so gpart must have left a signature somewhere on the drive so Trident still see it, and maybe gpart is widely used by other tools, Trident may also used it for preparing the drive too.


#14

I tried to dd the drive with zeros but without a process indication I have no idea how far it gone, so I used a gui tool to do it, it took couple hours to wipe 1/3 of the drive, since I was in a hurry I did not wait to complete and try again to install, I guess 1/3 is more than enough to erase the partition table and mbr but I was wrong, still it won’t install with the same error, so I will try again tomorrow.


#15

a lot of BSD things are using gpart

gpart destroy -F ada0 should wipe the partition table.


#16

And if you put “uck” after “-F”, it’s going to destroy your hard drive. :wink:


#17

I just finished clean wipe the drive and reinstall everything worked fine, hopefully I don’t need to go thru’ the pain on later release.


#18

I’m going to say “probably not”.
Partition tables are simply bits written on the device, in a format that tools understand. “Quick” things usually do the minimum work needed and leave traces around that can be recognized and reused. I’m guessing that’s what happened to you.


#19

The devs silently fixed the installer on U7, now I can install over the old partition painlessly without breaking a sweat well done !