Install under hyper-v


#1

Hi,

Newcomer to trueos, trying my first install under hyper-v/windows 10.

It hangs up during install, just after ‘using system config directory “/usr/loca/share/X11/xorg.conf/d”’.

Settings are:

Generation 1.
8096 MB ram
127gb ide disk

Anyone tried a hyper-v install of late?

Thanks,

Scott Franco
San Jose, CA


#2

Have you tried both EFI, and BIOS boot options with hyper-v? Are you able too?


#3

The “generation 1/generation 2” option controls this. However, selecting the generation 2 option with UEFI results in:

  1. SCSI DVD (0,1) The unsigned image’s hash is not allowed (DB)
  2. Network adapter (00155D018000) DHCP failed.
  3. SCSI Disk (0,0) No UEFI-compatible file system was found.

Looks like it is running into UEFI boot protection.

FWIW, I was able to load and run FreeBSD into a generation 1 mode virtual machine.


#4

So I went ahead and installed on real machine/disk. It is coming up on that. Same ISO.


#5

What make/model of computer?

Sounds like an older BIOS

Also to rule out TrueOS, grab 12/0-CURRENT https://www.freebsd.org/where.html and try booting that. TrueOS is tracking CURRENT so you need to try that


#6

Wouldn’t doubt it. Its about a 10 year old Asus MB.


#7

I have a laptop like that, and the manufacturer has no plans on updating the BIOS to fix it :frowning:


#8

So I tried installing the latest TrueOS under Hyper-V on Windows 10. I tried both the Gen 1 and Gen 2.

Gen1 did not boot the live cd. The kernel loaded but when attempting to run the graphical installer something failed (looks xorg ish).

trueos-install-fail

Gen2 would not boot the live cd unless I turned off secure boot. There was an option for something called OpenSource Shield but it didn’t help. The live cd booted and I got the graphical installer. The mouse wouldn’t work, but I was able to tab through the basic setup (nicely done guys!). I finished the installer and rebooted without the CD. It went to some weird land-of-misfit-gifs-from-1999 boot recovery screen that said something about mounting from MSDOS partition. That boot system tried to load from the CD drive (which I had removed). I tried this twice, so it wasn’t just a failed installation.

FWIW,
dinsdale


#9

So the “land-of-misfit-gifs-from-1999 boot recovery” is the new boot Manager!
https://www.trueos.org/handbook/postinstall.html#booting-into-trueos

OMG, like a REAL Boot Manager?
http://www.rodsbooks.com/refind/

I’m intrigued…


#10

FreeBSD works on Hyper-V.
TrueOS-10 works on Hyper-V.
PC-BSD worked on Hyper-V.
Microsoft claims Hyper-V supports FreeBSD, and TrueOS is built upon FreeBSD. Someone broke TrueOS’s ability to install of work on Hyper-V. What happened, and why isn’t it fixed yet?