I can not install TrueOS 17.12 [SOLVED]


#1

I’m trying to install TrueOS 17.12 three days ago, without success. I burned the ISO image to a DVD, and in the first four attempts it was installed on my HD, but the entry for the system was not installed on Ubuntu 17.10 GRUB … now, after several attempts, the installation locks when it is making copies of the files to my computer. Can someone here help me?

Everaldo

Below my hardware:


#2

If you installed it fine “the first four attempts”, then the problem is that you just need to manually make an entry for it in your “Ubuntu 17.10 GRUB”. TrueOS does not use GRUB by default/design, and if you are multi-booting TrueOS with something like GRUB then we kind of expect that you know how to manage that boot loader itself.

It should be something relatively simple in GRUB, such as making an entry to “chainload” the TrueOS partition, but since I have not used Ubuntu’s version of GRUB I can’t really give you anything more specific. Maybe ask on the Ubuntu forums?


#3

Thanks for answering! I was able to create a bootable USB stick with TrueOS and deleted the partition in question and installed it on the USB stick, then. So, I just need to put an “entry” for it in the Grub2 of my Ubuntu 17.10 … again, thanks for the reply!

Everaldo


#4

I solved the problem: I edited the file “40_custom” inside the folder “/etc/grub.d” and added the following lines:

menuentry “TrueOS ZFS Loader” {
insmod part_gpt
insmod chain
set root=’(hd0,gpt2)'
chainloader /EFI/Boot/bootx64-trueos.efi
}

The TrueOS installer has placed the EFI driver on the specific partition for that, ie, sda2. So I put the path to the same, being able to enter the system and make the settings.


#5

I tried a fresh install of STABLE into my new machine, and it fails to stamp rEFInd. I’m able to boot into TrueOS with an USB stick with rEFInd.

Linux Mint’s GRUB is installed and there’s an entry to boot into TrueOS, but it fails.

Now I tried this solution (gpt5 here), but it still fails. No /EFI found. Indeed, there’s no such thing in gpt5. Instead, I can see /ROOT and an entry for each boot environment there, and each one of them is empty (no files can be seen there).

How can I find the correct path for TrueOS’s EFI driver?


#6

Hello Sergio! In the terminal, you use the command: “sudo fdisk -l” … see below the result here in my machine:

everaldo@pc-positivo:~$ sudo fdisk -l

Disk /dev/sda: 465,8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: CD021324-04E7-4506-8308-209925C0588F

Dispositivo Start Fim Setores Size Tipo
/dev/sda1 2048 923647 921600 450M Windows recovery environment
/dev/sda2 923648 1128447 204800 100M EFI System <------ here
/dev/sda3 1128448 1161215 32768 16M Microsoft reserved
/dev/sda4 1161216 489078357 487917142 232,7G Microsoft basic data
/dev/sda5 489078784 490838015 1759232 859M Windows recovery environment
/dev/sda6 490840064 499193855 8353792 4G Linux swap
/dev/sda7 499193856 555182079 55988224 26,7G Linux filesystem
/dev/sda8 555182080 767877119 212695040 101,4G Linux filesystem
/dev/sda9 767877120 968148991 200271872 95,5G FreeBSD ZFS
/dev/sda10 968148992 976537599 8388608 4G FreeBSD swap

Disk /dev/sdb: 465,8 GiB, 500097376256 bytes, 976752688 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0005b098

Dispositivo Inicializar Start Fim Setores Size Id Tipo
/dev/sdb1 2048 976752639 976750592 465,8G 7 HPFS/NTFS/exFAT
everaldo@pc-positivo:~$


#7

Thanks! It works now. I should have chosen gpt1.


#8

So, all of good!

Everaldo