HP Z420 won't boot after update to 18.03


#1

Hiya,

I upgraded a desktop machine I use to play music to 18.03 today and it won’t boot. In fact, it won’t boot my older BE’s, one from last September and one from July, I believe. It gets to the TrueOS splash screen and just hangs.

Since all I do is play music on this, I decided to download the latest installer for stable and reinstall. Booting off the install DVD hangs at the same spot, TrueOS splash screen.

Anyone else have this problem? I can’t log into do “about” as it never gets close to booting.

I may have a very old ISO I can try, just to get it working and find out more. But this is a standard HP Z420 with a different hard drive and nothing else changed.


#2

what actually happens?

Do you get past the rEFInd menu?

Do you get the TrueOS Boot menu?

edit:

are you on telegram or IRC


#3

Nah I’ll worry about it tomorrow. It sits in the shipping area at work and plays music. I can select BE and then the TrueOS splash screen comes up and that’s it. Just hangs. Gave it an hour and no love so I shut it down.

Same happens booting off newly burned install DVD.


#4

if you get to the trueos boot menu, in there is “verbose boot”, try that


#5

OK TrueOS splash screen comes up and then after a few seconds it drops to the mountroot prompt.

I tried various iterations of the device trying to get it to boot, primarily ada0s1a.eli and ada1s1a.eli but no go.

While at the mountroot prompt the keyboard response is incredibly slow. Entering “?” to show a list of possible devices took up to a minute.

Eventually it drops the the debugger, keyboard is at normal speed, and I reboot and repeat.


#6

is there any way you can take a pic of where it stops, and post it?


#7

These are UFS/UFS2/FFS partitions. Therefore, You’re not using ZFS? Is this correct?

Edit: On the other hand, You talk about Boot Environments.

Your info is inconsistent.


#8

No it isn’t. I tried to boot zfs and ufs. I believe it’s zfs but can’t recall. Either way it’s GELI encrypted and won’t boot after the update.

I’m going to try to find an older ISO to see if it will work.


#9

UEFI, by chance?


#10

Good question. I’m burning an old (TrueOS-2017-07-05-x64-USB.img) image to try out.

Again, this box isn’t high priority. I use it to listen to music and occasionally to ssh around. I haven’t missed it except shipping/receiving is quiet.


#11

if it’s UEFI, then I believe it won’t boot, as it’s looking for you to type in your password.

A known bug in FreeBSD 12.0-current, EUFI & GELI do not play well together


#12

Well it gets past the GELI password prompt and starts to boot. As I said, the TrueOS splash comes up and then it freezes up. I took your verbose boot advice and that’s when I saw it drops to the mountroot> prompt.

I’d like to see the pause bumped up by a second or two. Hard to read the options and hit “3” quickly enough. And yeh, I like a fast boot as much as anyone which is why the openrc stuff is a welcome addition.


#13

hit the space bar to stop the count down


#14

Good news is old image booted and is installing.

And I suppose this is also bad news.


#15

Just installed 18.03 from USB thumb drive and it worked. Did not use GELI so I’m thinking Rod is right.


#16

I want to use my best Roseanne Roseannadanna voice to say “nevermind”.

Rebooted after the install of 18.03 (which went fine) and when it boots, once again I get the splash screen and it freezes up. I’m going to reinstall the old image again and do an “about” to find out exactly which hardware so I can post it here.

Obviously a regression of some type.


#17