HP Z400 Nvidia Quadro 4000 install issues


#1

System 2012 HP Z400 xeon processor, Quadro 4000. Non uefi bios.

I have tried installing 18.03 both stable and unstable. I
Install attempts:
I boot via USB and the system hangs at X when booting normally.
retry:
I can press 6 at boot menu and select safe boot. This will boot into the initial installer I select the latest nvidia drivers, configure the drives 3 drive RAIDZ1, the install completes and reboots.

First boot:
Sytstem starts normally I notice and error loading nvidia kernel module(Something like module could not be loaded or it is already installed). system continues to boot. Flashes starting X vesa and then I just get a curser ing the middle of a black screen and white box in the top left corner.

Troubleshooting:
Mouse functions prior to starting X server.
Keyboard seems to work. Capslock numlock etc work. I try Ctrl-Alt F2 a sometimes i get a login prompt. If I Ctrl-Alt-ESC screen goes to sleep and the keyboard stops functioning.

I can boot to single user mode but I am not sure what to edit in order to get video functioning enogh to finish setup.

Thank you for any help.


#2

Remove PCDM from the Default runlevel.

https://www.trueos.org/handbook/using.html#managing-system-services-and-daemons

Then reboot. And Login.

Then “startx” manually.

Then look in /var/log/X… logs.


#3

Thank you that got me started. I could hit I for interactive and skip PCDM. That allowed me to login as root and get a logfile to review. From there I ran Xorg -configure creating a xorg.conf.new that I could edit and replace my /etc/X11/xorg.conf .

Now when I startx I get the display driver configuration but after I try that the display goes to sleep and will not wake.


#4

Here are my config and log files:

/var/log/xorg.0.log

[ 268.335]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[ 268.335] X Protocol Version 11, Revision 0
[ 268.335] Build Operating System: FreeBSD 12.0-CURRENT amd64
[ 268.335] Current Operating System: FreeBSD trueos-2416 12.0-CURRENT FreeBSD 12.0-CURRENT #25 fa797a5a3(trueos-master): Fri Mar 23 13:28:18 UTC 2018 root@chimera:/usr/obj/usr/src/amd64.amd64/sys/GENERIC amd64
[ 268.335] Build Date: 08 March 2018 02:00:13PM
[ 268.335]
[ 268.335] Current version of pixman: 0.34.0
[ 268.335] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 268.335] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 268.336] (==) Log file: “/var/log/Xorg.0.log”, Time: Sun Jun 3 03:08:37 2018
[ 268.361] (==) Using config file: “/etc/X11/xorg.conf”
[ 268.361] (==) Using system config directory “/usr/local/share/X11/xorg.conf.d”
[ 268.375] (==) ServerLayout “X.org Configured”
[ 268.375] (
) |–>Screen “Screen0” (0)
[ 268.375] () | |–>Monitor “Monitor0”
[ 268.375] (
) | |–>Device “Card0”
[ 268.375] () |–>Input Device “Mouse0”
[ 268.375] (
) |–>Input Device “Keyboard0”
[ 268.376] (==) Automatically adding devices
[ 268.376] (==) Automatically enabling devices
[ 268.376] (==) Not automatically adding GPU devices
[ 268.376] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 268.385] (WW) The directory “/usr/local/share/fonts/misc/” does not exist.
[ 268.385] Entry deleted from font path.
[ 268.409] (WW) The directory “/usr/local/share/fonts/Type1/” does not exist.
[ 268.409] Entry deleted from font path.
[ 268.410] (WW) The directory “/usr/local/share/fonts/100dpi/” does not exist.
[ 268.410] Entry deleted from font path.
[ 268.410] (WW) The directory “/usr/local/share/fonts/75dpi/” does not exist.
[ 268.410] Entry deleted from font path.
[ 268.410] (WW) The directory “/usr/local/share/fonts/misc/” does not exist.
[ 268.410] Entry deleted from font path.
[ 268.410] (WW) The directory “/usr/local/share/fonts/Type1/” does not exist.
[ 268.410] Entry deleted from font path.
[ 268.410] (WW) The directory “/usr/local/share/fonts/100dpi/” does not exist.
[ 268.410] Entry deleted from font path.
[ 268.410] (WW) The directory “/usr/local/share/fonts/75dpi/” does not exist.
[ 268.410] Entry deleted from font path.
[ 268.410] () FontPath set to:
/usr/local/share/fonts/TTF/,
/usr/local/share/fonts/OTF/,
/usr/local/share/fonts/TTF/,
/usr/local/share/fonts/OTF/
[ 268.410] (
) ModulePath set to “/usr/local/lib/xorg/modules”
[ 268.410] (WW) Hotplugging is on, devices using drivers ‘kbd’, ‘mouse’ or ‘vmmouse’ will be disabled.
[ 268.410] (WW) Disabling Mouse0
[ 268.410] (WW) Disabling Keyboard0
[ 268.410] (II) Loader magic: 0x813e50
[ 268.410] (II) Module ABI versions:
[ 268.410] X.Org ANSI C Emulation: 0.4
[ 268.410] X.Org Video Driver: 20.0
[ 268.410] X.Org XInput driver : 22.1
[ 268.410] X.Org Server Extension : 9.0
[ 268.410] (–) PCI:*(0:15:0:0) 10de:06dd:103c:0780 rev 163, Mem @ 0xec000000/33554432, 0xe0000000/134217728, 0xe8000000/67108864, I/O @ 0x0000e000/128, BIOS @ 0x???/65536
[ 268.410] (II) “glx” will be loaded. This was enabled by default and also specified in the config file.
[ 268.410] (II) LoadModule: “glx”
[ 268.424] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[ 268.617] (II) Module glx: vendor=“NVIDIA Corporation”
[ 268.617] compiled for 4.0.2, module version = 1.0.0
[ 268.617] Module class: X.Org Server Extension
[ 268.618] (II) NVIDIA GLX Module 390.25 Wed Jan 24 19:21:39 PST 2018
[ 268.618] (II) LoadModule: “nvidia”
[ 268.635] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[ 268.670] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 268.670] compiled for 4.0.2, module version = 1.0.0
[ 268.670] Module class: X.Org Video Driver
[ 268.676] (II) NVIDIA dlloader X Driver 390.25 Wed Jan 24 19:00:20 PST 2018
[ 268.676] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 268.676] (–) Using syscons driver with X support (version 2.0)
[ 268.676] (–) using VT number 9
[ 268.700] (II) Loading sub module “fb”
[ 268.700] (II) LoadModule: “fb”
[ 268.700] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[ 268.723] (II) Module fb: vendor=“X.Org Foundation”
[ 268.723] compiled for 1.18.4, module version = 1.0.0
[ 268.723] ABI class: X.Org ANSI C Emulation, version 0.4
[ 268.723] (II) Loading sub module “wfb”
[ 268.723] (II) LoadModule: “wfb”
[ 268.723] (II) Loading /usr/local/lib/xorg/modules/libwfb.so
[ 268.733] (II) Module wfb: vendor=“X.Org Foundation”
[ 268.733] compiled for 1.18.4, module version = 1.0.0
[ 268.733] ABI class: X.Org ANSI C Emulation, version 0.4
[ 268.733] (II) Loading sub module “ramdac”
[ 268.733] (II) LoadModule: “ramdac”
[ 268.733] (II) Module “ramdac” already built-in
[ 268.735] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 268.736] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 268.736] (==) NVIDIA(0): RGB weight 888
[ 268.736] (==) NVIDIA(0): Default visual is TrueColor
[ 268.736] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 268.736] () NVIDIA(0): Enabling 2D acceleration
[ 269.407] (–) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:15:0:0
[ 269.407] (–) NVIDIA(0): CRT-0
[ 269.407] (–) NVIDIA(0): DFP-0 (boot)
[ 269.407] (–) NVIDIA(0): DFP-1
[ 269.407] (–) NVIDIA(0): DFP-2
[ 269.407] (–) NVIDIA(0): DFP-3
[ 269.407] (–) NVIDIA(0): DFP-4
[ 269.409] (II) NVIDIA(0): NVIDIA GPU Quadro 4000 (GF100GL) at PCI:15:0:0 (GPU-0)
[ 269.409] (–) NVIDIA(0): Memory: 2097152 kBytes
[ 269.409] (–) NVIDIA(0): VideoBIOS: 70.00.67.00.08
[ 269.409] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 269.426] (–) NVIDIA(GPU-0): CRT-0: disconnected
[ 269.426] (–) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[ 269.426] (–) NVIDIA(GPU-0):
[ 269.459] (–) NVIDIA(GPU-0): LG Electronics W2053 (DFP-0): connected
[ 269.459] (–) NVIDIA(GPU-0): LG Electronics W2053 (DFP-0): Internal TMDS
[ 269.459] (–) NVIDIA(GPU-0): LG Electronics W2053 (DFP-0): 330.0 MHz maximum pixel clock
[ 269.459] (–) NVIDIA(GPU-0):
[ 269.460] (–) NVIDIA(GPU-0): DFP-1: disconnected
[ 269.460] (–) NVIDIA(GPU-0): DFP-1: Internal TMDS
[ 269.460] (–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[ 269.460] (–) NVIDIA(GPU-0):
[ 269.461] (–) NVIDIA(GPU-0): DFP-2: disconnected
[ 269.461] (–) NVIDIA(GPU-0): DFP-2: Internal TMDS
[ 269.461] (–) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
[ 269.461] (–) NVIDIA(GPU-0):
[ 269.461] (–) NVIDIA(GPU-0): DFP-3: disconnected
[ 269.461] (–) NVIDIA(GPU-0): DFP-3: Internal DisplayPort
[ 269.461] (–) NVIDIA(GPU-0): DFP-3: 480.0 MHz maximum pixel clock
[ 269.461] (–) NVIDIA(GPU-0):
[ 269.461] (–) NVIDIA(GPU-0): DFP-4: disconnected
[ 269.461] (–) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[ 269.461] (–) NVIDIA(GPU-0): DFP-4: 480.0 MHz maximum pixel clock
[ 269.461] (–) NVIDIA(GPU-0):
[ 269.464] (II) NVIDIA(0): Validated MetaModes:
[ 269.464] (II) NVIDIA(0): “DFP-0:1600x900”
[ 269.464] (II) NVIDIA(0): Virtual screen size determined to be 1600 x 900
[ 269.468] (–) NVIDIA(0): DPI set to (90, 91); computed from “UseEdidDpi” X config
[ 269.468] (–) NVIDIA(0): option
[ 269.469] (–) Depth 24 pixmap format is 32 bpp
[ 269.469] (II) NVIDIA: Reserving 6144.00 MB of virtual memory for indirect memory
[ 269.469] (II) NVIDIA: access.
[ 269.492] (II) NVIDIA(0): Setting mode “DFP-0:1600x900”
[ 269.584] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 269.584] (==) NVIDIA(0): Backing store enabled
[ 269.584] (==) NVIDIA(0): Silken mouse enabled
[ 269.585] (==) NVIDIA(0): DPMS enabled
[ 269.585] (II) Loading sub module “dri2”
[ 269.585] (II) LoadModule: “dri2”
[ 269.586] (II) Module “dri2” already built-in
[ 269.586] (II) NVIDIA(0): [DRI2] Setup complete
[ 269.586] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia
[ 269.586] (–) RandR disabled
[ 269.586] (II) Initializing extension GLX
[ 269.586] (II) Indirect GLX disabled.
[ 269.797] (II) config/devd: probing input devices…
[ 269.797] (II) config/devd: adding input device (null) (/dev/kbdmux)
[ 269.797] (II) LoadModule: “kbd”
[ 269.798] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[ 269.798] (II) Module kbd: vendor=“X.Org Foundation”
[ 269.798] compiled for 1.18.4, module version = 1.9.0
[ 269.798] Module class: X.Org XInput Driver
[ 269.798] ABI class: X.Org XInput driver, version 22.1
[ 269.798] (II) Using input driver ‘kbd’ for ‘kbdmux’
[ 269.798] (
) kbdmux: always reports core events
[ 269.798] () kbdmux: always reports core events
[ 269.798] (
) Option “Protocol” “standard”
[ 269.798] () Option “XkbRules” “base”
[ 269.798] (
) Option “XkbModel” “pc105”
[ 269.798] () Option “XkbLayout” “us”
[ 269.798] (
) Option “config_info” “devd:kbdmux”
[ 269.798] (II) XINPUT: Adding extended input device “kbdmux” (type: KEYBOARD, id 6)
[ 269.799] (II) config/devd: kbdmux is enabled, ignoring device ukbd0
[ 269.799] (II) config/devd: kbdmux is enabled, ignoring device atkbd0
[ 269.799] (II) config/devd: adding input device (null) (/dev/sysmouse)
[ 269.799] (II) LoadModule: “mouse”
[ 269.799] (II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
[ 269.808] (II) Module mouse: vendor=“X.Org Foundation”
[ 269.808] compiled for 1.18.4, module version = 1.9.2
[ 269.808] Module class: X.Org XInput Driver
[ 269.808] ABI class: X.Org XInput driver, version 22.1
[ 269.808] (II) Using input driver ‘mouse’ for ‘sysmouse’
[ 269.808] () sysmouse: always reports core events
[ 269.808] (
) Option “Device” “/dev/sysmouse”
[ 269.808] (==) sysmouse: Protocol: “Auto”
[ 269.808] () sysmouse: always reports core events
[ 269.808] (==) sysmouse: Emulate3Buttons, Emulate3Timeout: 50
[ 269.808] (
) sysmouse: ZAxisMapping: buttons 4 and 5
[ 269.808] () sysmouse: Buttons: 5
[ 269.808] (
) Option “config_info” “devd:sysmouse”
[ 269.808] (II) XINPUT: Adding extended input device “sysmouse” (type: MOUSE, id 7)
[ 269.808] () sysmouse: (accel) keeping acceleration scheme 1
[ 269.808] (
) sysmouse: (accel) acceleration profile 0
[ 269.808] () sysmouse: (accel) acceleration factor: 2.000
[ 269.808] (
) sysmouse: (accel) acceleration threshold: 4
[ 269.809] (II) sysmouse: SetupAuto: hw.iftype is 4, hw.model is 0
[ 269.809] (II) sysmouse: SetupAuto: protocol is SysMouse
[ 269.809] (II) config/devd: device /dev/ums0 already opened
[ 308.090] (II) config/devd: terminating backend…
[ 308.090] (II) UnloadModule: “mouse”
[ 308.090] (II) UnloadModule: “kbd”
[ 308.100] (WW) NVIDIA(0): Free swap group failed.
[ 308.120] (II) NVIDIA(GPU-0): Deleting GPU-0
[ 308.120] (II) Server terminated successfully (0). Closing log file.`

And my /etc/X11/xorg.conf

Section “ServerLayout”
Identifier “X.org Configured”
Screen 0 “Screen0” 0 0
InputDevice “Mouse0” “CorePointer”
InputDevice “Keyboard0” “CoreKeyboard”
EndSection
Section “Files”
ModulePath “/usr/local/lib/xorg/modules”
FontPath “/usr/local/share/fonts/misc/”
FontPath “/usr/local/share/fonts/TTF/”
FontPath “/usr/local/share/fonts/OTF/”
FontPath “/usr/local/share/fonts/Type1/”
FontPath “/usr/local/share/fonts/100dpi/”
FontPath “/usr/local/share/fonts/75dpi/”
EndSection
Section “Module”
Load “glx”
EndSection
Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”
EndSection
Section “InputDevice”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/sysmouse”
Option “ZAxisMapping” “4 5 6 7”
EndSection
Section “Monitor”
Identifier “Monitor0”
VendorName “Monitor Vendor”
ModelName “Monitor Model”
EndSection
Section “Device”
### Available Driver options are:-
### Values: : integer, : float, : “True”/“False”,
### : “String”, : " Hz/kHz/MHz",
### : “%”
### [arg]: arg optional
#Option “SWcursor” # []
#Option “HWcursor” # []
#Option “NoAccel” # []
#Option “ShadowFB” # []
#Option “UseFBDev” # []
#Option “Rotate” # []
#Option “VideoKey” #
#Option “FlatPanel” # []
#Option “FPDither” # []
#Option “CrtcNumber” #
#Option “FPScale” # []
#Option “FPTweak” #
#Option “DualHead” # []
Identifier “Card0”
Driver “nvidia”
BusID “PCI:15:0:0”
EndSection
Section “Screen”
Identifier “Screen0”
Device “Card0”
Monitor “Monitor0”
SubSection “Display”
Viewport 0 0
Depth 24
Modes “1600x900”
EndSubSection
EndSection


#5

I have tried a few options still not luck screen goes to sleep(maybe out of range) with these settings when I boot with PCDM disabled and startx from root manually. If I boot normally still just a black screen with a frozen mouse pointer and a white square in the upper left corner.


#6
WAG: try the latest nVidia driver?
<URL:http://www.nvidia.com/download/driverResults.aspx/134265/en-us>
John
groenveld@acm.org

#7

in FreeBSD, hence TrueOS, there are 3 different sets of drivers, supplied by nvidia


#8

Like Rod wrote, “there are 3 different sets of drivers”. So, you have to use the correct Nvidia-driver-version for the video-card/adaptor in your workstation.

From the X11 log file you posted, there is this line:
“NVIDIA dlloader X Driver 390.25 Wed Jan 24 19:00:20 PST 2018”

390.25 is a mostly-recent version of the Nvidia-driver and since your having problems, then I suggest an “older” version of the driver, 340.106.

This web-site contains a list of all the video cards supported by the 340.106 driver/version:
http://www.nvidia.com/Download/driverResults.aspx/130045/en-us

In the “Quadro” section it lists specifically “Quadro 4000”.

This web-site contains a list of all the video cards supported by the 390.25 driver/version:
http://www.nvidia.com/Download/driverResults.aspx/130648/en-us

The 390.25 list doesn’t list “Quadro 4000” specifically but does have variants of it, for example K4000 etc.

To install the 340 driver from the command-line:
pkg install nvidia-driver-340-340.106


#9

FYI:
list of latest nvidia drivers short and long term

396.24 is newer than 390.25 and English Bob in UTube just did a video on performance issues on linux lite 4.0 with the 390.25 driver that were fixed by 396.24. The newest driver may or may not fix your problem.