How to switch desktop


Hi there,

Since I am from Mint and quite fresh with Trident, I still need a familiar GUI to work with, so I installed Cinnamon via AppCafe, but I don’t know how to switch desktop, I don’t see it in the login prompt, how do I set Cinnamon as my default desktop ?


Not sure what you (don’t) see at your login promt.

This screenshot is from TrueOS legacy but still generally true for my trident BE. But maybe a fresh trident install does not use pcdm?
With pcdm the 3rd row from top gives you DE selector.

As for default, back in the TrueOS legacy (as in “up to 1803”) days there was a “feature” (as in code change) implemented that the last DE used will be the next “default” - before that lumina was always default, IIRC. I guess this feature hasn’t been removed for trident as xfce is always default on my system on reboot.


I installed Cinnamon Desktop but I couldn’t find it.


Joe Lee


I haven’t used Cinnamon lately in TrueOS, but there are reports that it can be broken in FreeBSD. I have confirmed it myself some time ago.

Maybe give LXDE a try. Each installed Desktop Environment should appear as an option at your login prompt.


I was trying to install LXDE but the system paging heavily and
became unresponsive, it also reboot couple times I can’t even
uninstall Cinnamon, it is an old Dell Core 2 Duo with 2G memory
may be too weak to run the system, but it has no problem with Mint


Should be enough to run Trident. The system is mostly memory hungry, but 2G is plenty. Not to repel you from using Trident, but you can try Ghost or even vanilla FBSD to compare.


I tried few varient of FBSD but most of them failed to load the GUI even booted fine with live CD, Trident is my best bet, and I don’t know why the image is so big but without a office suite like in other Linux distro or I missed ?


2G and zfs won’t work… A minimum, when using zfs is 4G.


Lotech said, “I installed Cinnamon via AppCafe, but I don’t know how to switch desktop, I don’t see it in the login prompt”

On the login screen, below the fields for your name and password, you will see another field that probably contains the name of the last used desktop manager. Look for a small downward-pointing triangle. If you click on the triangle, the field box should open to list all other installed desktop managers. Select Cinnamon from the list and click the right-pointing white arrow in the blue box. If you do not understand what I mean, you can see this illustrated in the TrueOS Handbook @ Section 2.18

If you do not see Cinnamon in the list, then your installation was defective and you should install it again.


I don’t see Cinnamon on the list, I will try install the whole thing again on another computer with more memory to try.


cinnamon was skipped, because it depends on enchant, and enchant is broke. requires python-2.7


IC, but it still in the AppCafe


Joe Lee


just put cinnamon on a virtualbox. it installs, but not functional.

to change BE, underneath the passwork block, click lumina, and change to what you want


Thanks I know, there is nothing else I can choose beside Fluxbox.


lumina & fluxbox.

did you install cinnamon?


I think I know what went wrong, I only install ‘Cinnamon Desktop’ but it doesn’t contain everything need to run the desktop in the package, this is unlike Linux which something-desktop is always a complete package, so I install all Cinnamon related stuffs and then I see it pop up on the login prompt, but still it won’t work, it shown a desktop full of blank icons, there is no task bar, although I can still run application by click on the icons but this is no use, so I gave up and remove all Cinnamon related stuffs.


I’d try two things:

  1. I’m not familiar with cinnamon, but if there’s no task bar, can you set up one?

  2. You might try another DE that is known to work on Trident to make sure you base system is properly working. The only DE I have tried with Trident so far (other than Lumina) is xfce which is working fine for me. But keep in mind that I didn’t do a fresh install (of either Trident nor xfce) but “install into new BE” with xfce (and all personal settings) already present on the ancestor TrueOS legacy 18.03 system. That might lead to a different outcome - who knows… :slight_smile:


Yep, that’s what I got in virtualbox. Had to kill the session to start over.

This IS NOT linux. programs have to be ported over to *BSD, and remove the systemD crap, and modify things are are only in linux. Most time this works, sometimes it doesn’t.


After some messing around I finally successfully installed MATE desktop and it worked fine, so I can manage things more easy with familiar UI, but the strange thing is that, the desktop icons ran wild, the original Lumina icons became super size, and those MATE ones are normal but with a locking symbol on it although I can still use it, is there a simply way to fix that ?


GTK & QT themes/icons sometimes do play not place nice together :frowning: