How to disable mouse acceleration?


#1

I need to disable mouse acceleration by default. I go into control panel and change it from 10 to 1. But after reboot it goes back to 10. Do I need to do something to save it? On the cli I can run “xset m 1”. What file can I add that to? I tried /etc/rc.conf but it messes up boot?

Thanks


#2

If a control panel can not keep control of what you prefer, there’s a bug; please make a report at https://github.com/trueos/lumina/issues – thanks.

I ran opensnoop(1m) whilst performing changes with the control panel, could not tell what is changed. Sorry.

… On the cli I can run “xset m 1”. What file can I add that to?

If you can script a little, then you might write a script to be run by OpenRC at the default runlevel.


#3

Thanks for the reply.

I herd this was a great product and decided to try it in a proxmox vm. Probably a common way to try it. It presents very basic hardware to the installer. The installer went fine with no errors. After rebooting the network was not working. Farted around with that and got it working. Not sure why it would not get a dhcp address. After a couple of major updates that seems to work. Don’t have a lot of free time to try this. So on to the mouse issue.

I can script a little and could fill out a bug report. Ok for scripting I would use nano. HM not installed, ok try to install it and it fails. nano-2.7.2… not found.

I wish the project well and will try again some day. Something so easy should not be so hard.

Best reguards


#4

If you want to re-use your “xset m 1” command, just put it into ~/.xprofile. That is the standard way of running X11 session startup modifications. The Lumina way of changing mouse settings is brand-new and we are still testing it out and fixing various things before we enable the option to save/reload those settings on session start.


#5

Thanks for the reply. I didn’t see it before wiping it and install the 1/27 iso hopping that might fix it. The mouse acceleration was a problem during the install. But I was able to suffer threw that. After rebooting the mouse was accelerating worse than before. To the point of being unusable. Unfortunately “xset m 1” no longer works.

I have been looking forward to trying TrueOS for quite a long time. Unfortunately I don’t have any spare hardware at the moment. I think Proxmox should be a viable option for this. It presents simple hardware, not some bleeding edge stuff. I have used many operating systems with success. Not all perfect but all fixable. TrueOS will be the first one I give up on.

Maybe someone with access to a proxmox server and better knowledge can try this.

Thanks


#6

If you open up the control panel on TrueOS now (SysAdm connection to localhost), there is a new “Mouse Settings” page under the “System Management” Category. That is the best way to manage mice on the system now instead of the X11-based config tool in Lumina. The SysAdm page directly configures the “moused” service on the system and those settings are automatically applied and saved for future use as well.

Basically, after a lot of testing we found out that “moused” is what is controlling the physical hardware settings on TrueOS/FreeBSD, while the X11 settings were applied like an overlay on top of that. However, “moused” collects all physical devices and only lets X11 know about a single “synthetic” device (where all the physical devices are redirected to), so trying to configure individual mice through X11 is nearly worthless. We will be disabling the X11 mouse settings in Lumina via another update in the near future.


#7

The mouse acceleration is so bad it is impossible to use the control panel. About the only usable thing is terminal. Is there anything to eddit from there?

Thanks

PS The networking is working with the virtio driver at install. It took some tinkering on the older iso.


#8

Just wanted to confirm what beanpole135 wrote about the new mouse-settings tool in the SysAdm System Management category. The tool does work and mouse-settings persist across reboots.


#9

That’s nice but the mouse is so erratic its not usable. Is there a way to set it from cli?


#10

From the CLI you can adjust your moused service settings directly (that is all the SysAdm API does).

CLI Information: man moused
Settings file: /etc/conf.d/moused

Restarting the service to use the new settings: sudo service moused.<device_id> restart


#11

Thanks for the reply. I was able to get the mouse slowed down and not so erratic. Still not usable enough to try for any time.

Maybe someone experience could try TrueOS as a proxmox vm.


#12

I’m running a Test installation on smartOS/KVM; access via VNC works fine, mouse is configured as a touch device in the KVM settings for the VM, so it just follows the pointer of the connecting client. Haven’t tried with the latest updates (the new mouse settings are much better and more useful than before!), but I never had issues via VNC with the default settings either…

From my experiences during several years with 2 Proxmox 3.x hosts, VNC on Proxmox always was relatively buggy and unreliable; biggest issue on a leftover/legacy Proxmox 3.4 host since at least half a year is the completely broken keyboard over KVM, resulting in a completely garbled keyboard layout when trying to type anything over KVM within the VM.

If you dont’t have a special need or commitment for/to proxmox I’d strongly suggest you try smartOS for virtualization. It’s so much cleaner and beautifully simple to manage via config management (e.g. ansible). Network virtualization and -abstraction on illumos is absolutely superior to anything linux has to offer…


#13

Thanks for the reply. Glad it is working for you. Scraping proxmox to test TrueOS is not an option. Would be more inclined to look at jails under bsd. Proxmox has improve greatly since version 3. I think there may be many like myself who would like to try TrueOS as a vm.

Thanks for the hard work by the developers.