Having Trouble Updating?


#42

Ok, will check through the update log. Will try again before reporting, just in case there’s something I’m missing to do. I’ll head over to gitter.im as you suggest if I’m still in the same predicament. Thanks again. Appreciated. Frank.


#43

last ditch effort as well

sudo pc-updatemanager pkgupdate -f


#44

Ok, the following is a distillation of several trials and retrials. I’m now at a stage where I’m certain the old (*208 (??)) freebsd-examples has been deleted I re-created a new Boot Environment ( and assume TrueOS uses the most recent automatically) deleted Freebsd-examples (which terminal insists it does) run sudo pkg-static install -f freebsd-runtime which seems fine. Then I shutdown, boot-up and run update manager and pc-updatemanager.log.tmp reports:

- FreeBSD-examples-12.0.s20170205134406 [trueos-base] conflicts with FreeBSD-runtime-12.0.s20170205134406 [installed] on /usr/share/examples/etc/make.conf

and Update-Manager wants to re-run the same update as it did the last time around, same packages, same versions. So, FreeBSD-examples has been updated to *406 but isn’t compatible with runtime *406, which seems a bit crazy (?) I’m hoping that by reading from pc-updatemanager.log.tmp I’m doing the right thing.
As a P.S. to the above, and remembering that I’m ‘green’ with BSD I’m assuming that the old (January’s) freebsd-examples was deleted on command: pkg info freebsd-examples says:
pkg-static: No package(s) matching freebsd-examples, so I’m gathering that update-manager wants to install FreeBSD-examples-12.0.s20170205134406 but appears to report that it conflicts with FreeBSD-runtime-12.0.s20170205134406 [installed]. Should I attempt to remove that runtime package? Would that be a solution?


#45

the TrueOS way to update/upgrade

sudo pc-updatemanager pkgckeck
sudo pc-updatemanager pkgupgrade


#46

Well, sudo pc-updatemanager pkgcheck reveals:

Installed packages to be UPGRADED:
FreeBSD-examples: 12.0.s20170121141038 -> 12.0.s20170205134406 [trueos-base]

Which is confusing, as the earlier package was supposed to be deleted?


#47

looks like he was/is using pkg only, and not pc-updatemanager, which means things are getting out of sync


#48

Some of the trials involvng the update loop were via the inbuilt gui Update-Manager, so unless that uses pkg only then I’m stumped. It is possible that at sometime I may have run sudo pkg update/upgrade via terminal, would running the two commands you suggest fix a potential sync problem?


#49

it should. it should keep theTrueOS bits in sync with the FreeBSD bits

sudo pc-updatemnager syncconf
sudo pc-updatemnager pkgcheck
sudo pc-updatemnager pkgupdate

if this fails, you may need to roll back 1 BE to get an in sync system


#50

Looks like a reinstall might be the best option. On issuing the most recent commands you suggest, sudo pc-updatemanager pkgcheck gives:

Installed packages to be UPGRADED:
FreeBSD-examples: 12.0.s20170121141038 -> 12.0.s20170205134406 [trueos-base]

Seems that file never ever gets properly deleted for some reason. I don’t think rolling back a BE will help as every BE created has suffered with the same problem, from the very first,


#51

sudo cat /var/log/pc-updatemanager.log | less

scan through the update log and see you can find the issue


#52

The only issue appears to be: FreeBSD-examples: 12.0.s20170121141038 -> 12.0.s20170205134406 [trueos-base]


#53

known issue from January

check out this article Having Trouble Updating?


#54

Yes, however this just takes me back to the beginning of my quest : )) I have only two extra packages installed on top of standard TrueOS: nvidia-304.* and xmms (audio player). I required the nvidia-304 as the nvidia-375 auto-suppied by TrueOS and the nvidia-340 variants were not compatible with my HP laptop’s graphics and didn’t want to fall back on vesa. This was always a known problem for me in Linux - the nvidia-304* is a legacy option but has always worked in my HP G60. I only point this out as it’d be a game changer for me. I can’t see it being the cause of the problem anyway as the issue with freebsd-examples does appear to be at the root of my issue at least, and presumably for others who are attached to this thread. If this problem was solved, it obviously wasn’t for some. Really hoping a permanent solution can be found as I’m figuring it wouldn’t be worthwhile reinstalling TrueOS only to meet with the same issue. Maybe an update to the True-OS repository iso which includes February’s ‘fix’ might be the answer?


#55

After tinkering around for a few days, I think the freebsd-examples issue I’ve been experiencing is now finally put to bed. The crucial info: the difference between typing freebsd-examples and FreeBSD-examples despite the commands suggested earlier on this wiki-sticky. pkg info doesn’t find freebsd-examples as it doesn’t appear to exist. The following is long & messy (and moderators please feel free to tidy it up what isn’t relevant - which may be all of it : )) but it is a record of what I have done, which I know involved some unnecessary commands). Doing the following however, did result in a BE which now claims to be up-to-date via both terminal and SysAdmin gui Update-Manager (just in case there should have been any conflicts there, however unlikely. It has survived three reboots : )) All the following was completed via a terminal in Lumina Desktop. Hope this helps someone in the event of the same, or similar problems with updating TrueOS or at least provides some clues.

pkg info FreeBSD-examples
FreeBSD-examples-12.0.s20170121141038
Name : FreeBSD-examples
Version : 12.0.s20170121141038
Installed on : Thu Feb 9 14:00:09 2017 GMT
Origin : base
Architecture : freebsd:12:x86:64
Prefix : /
Categories : base
Licenses : BSD2CLAUSE
Maintainer : re@FreeBSD.org
WWW : https://www.FreeBSD.org
Comment : examples package
Annotations :
Flat size : 665KiB
Description :
examples package

sudo pkg remove FreeBSD-examples (not sudo pkg remove freebsd-examples)
I did not run sudo pkg-static install -f freebsd-runtime here (but this was run on previous attempts so I assume must have been installed in the current BE (?)
I then shutdown without doing anything else.
Then booted into Lumina opened terminal and:

pkg info FreeBSD-examples
pkg-static: No package(s) matching FreeBSD-examples

pkg search FreeBSD-examples
pkg-static: Repository trueos-base missing. ‘pkg update’ required
pkg-static: Repository trueos-base cannot be opened. ‘pkg update’ required
pkg-static: Repository trueos-major cannot be opened. ‘pkg update’ required

sudo pkg update
Password:
Updating trueos-base repository catalogue…
Fetching meta.txz: 100% 1 KiB 1.5kB/s 00:01
Fetching packagesite.txz: 100% 54 KiB 55.8kB/s 00:01
Processing entries: 100%
trueos-base repository update completed. 790 packages processed.
Updating trueos-major repository catalogue…
Fetching meta.txz: 100% 1 KiB 1.5kB/s 00:01
Fetching packagesite.txz: 100% 6 MiB 2.0MB/s 00:03
Processing entries: 100%
trueos-major repository update completed. 25962 packages processed.

pkg search FreeBSD-examples
FreeBSD-examples-12.0.s20170205134406 examples package

pkg info FreeBSD-examples
pkg-static: No package(s) matching FreeBSD-examples

sudo pc-updatemanager pkgckeck
Boot-strapping updater…OK
pc-updatemanager: Usage

branches - List available system branches
chbranch - Change to new system branch
check - Check for system updates
showeol - Show end of life (support) date for this release
install , - Install system updates
pkgcheck - Check for updates to packages
pkgupdate [-f] - Install packages updates (-f to force)
syncconf - Update PC-BSD pkg configuration
confcheck - Check PC-BSD pkg configuration
cron - Perform delayed check for system and pkg updates.

sudo pc-updatemanager check (not sudo pc-updatemanager pkgcheck)
Boot-strapping updater…OK
No updates available for 12.0-CURRENT!

sudo pc-updatemanager pkgcheck
Boot-strapping updater…OK
Updating trueos-base repository catalogue…
trueos-base repository is up-to-date.
Updating trueos-major repository catalogue…
trueos-major repository is up-to-date.
All repositories are up-to-date.
All packages are up to date!


#56

The freebsd-examples issue has been resolved in the latest STABLE, and no longer applies.


#57

On a fresh install of Latest TrueOS Unstable Desktop, my system was incredibly slow to update. I left it updating overnight, and it still was not finished in the morning. This was a problem because while in updating mode, app like Qupzilla immediately close after launching.

I fixed this issue by commenting out the line that enables ipv6 in rc.conf. After a reboot, updates only took a few minutes.

Now that my system is updated, TrueOS is working beautifully. Thank you!