Having Trouble Updating?


#21

Hi,
I did as adviced but it doesn’t work:
My last working environment is:

uname -a:
FreeBSD zb1.rm-i.net 12.0-CURRENT FreeBSD 12.0-CURRENT #14 1717ae3(drm-next-4.7): Fri Oct 28 13:49:49 UTC 2016 root@gauntlet:/usr/obj/usr/src/sys/GENERIC amd64

beadmin list:
12.0-CURRENT-up-20161101_231313 NR / 17.8G 2016-11-01 23:12 12.0-CURRENT-up-20161101_231313

  • creating and booting a new BE dows work
  • pkg remove freebsd-examples does work
  • pkg-static install -f freebsd-runtime dows work but leaves the system in an unworkable state (see below)
  • reboot boots not into graphics mode because of missing ‘basename’ symbol in libzfs and others
  • all zfs mounts are missing
    (workaround seems to be a pkg-static install FreeBSD-libc
  • than reboot works but not into graphics mode
  • all zfs mounts are still missing (It seems that the services incl. zfs are not executed)
  • pc-upgrademanager pkgupgrade seems to work.
  • During shutdown something is done (but it feels way too short for the amount of pkgs)
  • reboot boots only into singe user mode due to missing libs for openrc (libeinfo, libopenrc?, …)
  • all zfs mounts are still missing (It seems that the services incl. zfs are not executed, but a new openrc line shows up)

All in all its a real mess…

BTW: I don’t like the updates during shutdown:

  • You don’t see whats going on.
  • You can’t intervent in case something went wrong.
  • You can’t make necessary modifications to the loader.conf before the reboot

#22

Actually, you can see what’s going on, just press

Alt+F1

(I guess it’s F1, but it’s written right there at the screen that’s otherwise all you see if you don’t press those two keys.)

About the other two points I can’t comment, I never tried to intervene.

Other than that I’d assume that one day TrueOS is supposed to work like pcbsd, where the setting of the (original) BE are passed on to the new BE.


#23

ctrl-alt-f1
when you’re in X you need the “ctrl”.
Not in X, just ALT-FN


#24

Hi,
one can use Alt-F1 and Alt-F2 to see something
but its too fast to see something meaningfull
and it doesn’t stop before rebooting so you can’t
analyze anything.


#25

when i knew there was an error. i would use the cell phone and record the output.

not pretty, but it worked


#26

But as the update doesn’t destroy your previous BE and the update log should be analyzable after reboot into the new BE, I never thought of the “new way” of updating being a problem (for me, anyway).
If something goes wrong I have the previous BE as a backup and I can (hopefully) analyze the update log trying to find out what might have gone wrong (in my case it would just be looking for error messages as I’ still consider myself a *nix beginner or interested part time user).


#27

Yes, I still have the new BE’s
The one I manually created, the one pc-updatemanager (or the rc script) created.

Does anyone know where to look for?
…/var/log/pc-updatemanager.log contains:

pc-updatemanager: Thu Jan 26 12:21:13 CET 2017
Checking for updates to ports-mgmt/pkg…
Updating the package repo database…
Cleaning old pkg upgrade cache…
Verifying / fetching packages for ports-mgmt/pkg - pkg-1.9.4_1.txz
Verifying / fetching packages for misc/trueos-desktop - trueos-desktop-201701182017.txz

…/usr/local/log// contains only infos from pc-updatemanager before the shutdown script runs…

BTW:
Are the details of the update procedure esp. the shutdown runtime script described anywhere?

BTW2:
Could the update process (since its part of the shutdown) be influenced by the rshutdown_timeout parameter if it takes longer than 90s (default) to update?


#28

https://github.com/trueos/trueos-core/issues/303#issuecomment-275834787 observes a fix for my case but (sorry) not yet enough to tell the date or scope of its effectiveness for other users.


#29

@RodMyers @grahamperrin
I can confirm that deleting freebsd-examples solved my problem, I have a new boot environment now. :+1:

[russellh@Prescott] ~> beadm list
BE Active Mountpoint Space Created
initial - - 2.7G 2016-12-29 14:35
12.0-CURRENT-up-20170107_230951 - - 3.1G 2017-01-07 23:04
12.0-CURRENT-up-20170109_000429 - - 3.2G 2017-01-08 23:59
12.0-CURRENT-up-20170113_224154 - - 3.3G 2017-01-13 22:37
12.0-CURRENT-up-20170117_211917 - - 3.3G 2017-01-17 21:14
12.0-CURRENT-up-20170129_004835 NR / 23.0G 2017-01-29 00:42


#30

Hi,
I’m a complete novice to BSD being only slightly more familiar with Linux but I’d like to try and get to grips with BSD via TrueOS (I require a robust DE). I appear to have the updating problem described in this thread. I have tried the prep and workaround solutions and I believe I’ve followed those instructions to the letter. I think I still have the problem:

Checking for upgrades (419 candidates): … done
Processing candidates (419 candidates): . done
Checking integrity… done (2 conflicting)

  • FreeBSD-examples-12.0.s20170205134406 [trueos-base] conflicts with FreeBSD-runtime-12.0.s20170205134406 [installed] on /usr/share/examples/etc/make.conf
  • FreeBSD-examples-12.0.s20170205134406 [trueos-base] conflicts with FreeBSD-runtime-12.0.s20170205134406 [trueos-base] on /usr/share/examples/etc/make.conf

Every time I reboot and check for updates I appear to be getting the same information in ‘Recent Updates’ and an identical request in ‘Updates’ to update the same file as per at the last session.
Just wondering if this issue is still affecting users and whether there is another solution to this problem?
Many thanks in advance, and thank you for TrueOS!
Frank


#31

are you rebooting or shutting down?

To get the updates installed and new Boot Environment (BE) created, you need to shutdown

close ever application you have running, start a terminal, inside the terminal type;

sudo shutdown -r now

this should get the updates installed and new BE created


#32

Just run sudo pkg delete freebsd-examples to remove that one package (double-check the list of packages that will be removed before hitting “y” to continue with the removal), and then start the updates again.
That was an old bug which hit people quite a while back but was fixed in the later updates.


#33

my bad. I forgot all about that file/situation


#34

Hi

Thanks guys. I already tried the “workaround” suggested in first post, although that instructed: [quote=“RodMyers, post:2, topic:687”]
sudo pkg remove freebsd-examplessudo pkg-static install -f freebsd-runtime
[/quote]
and not: [quote=“beanpole135, post:32, topic:687”]
sudo pkg delete freebsd-examples
[/quote]
Previously, I created a fresh BE and activated it, shutdown without installing updates and restarted.

I take it then, following beanpole135’s reply, that creating a new BE is no longer needed and I can just do “sudo pkg delete freebsd-examples”? I will try that anyway and hopefully stop the update loop. I’ll check back and report. Thanks again.
Frank


#35

yes remove the file and run

sudo pc-updatemanager pkgcheck

just to make sure nothing else needs updating


#37

Ok, will do. Cheers!


#38

Ok, just tried that. Sadly, still stuck with the pkg update problem. Any other suggestions?


#39

did you get a /var/log/pc-updatemanager.log

entry this time?

edit:

if you head over to https://gitter.im/trueos/troubleshooting we can try and help real time


#40

Yes, but I’m looking at that through the SysAdm Update Manager…I guess that’s the same file as in /var/log ?


#41

that would be the log file, yes.

boring to scroll through, but you will either find the cause or a clue to what is happening