Having Trouble Updating?


#1

Please see the wiki post below:


Updates to TrueOS every day for four days (apparently repeated, looping, since Wednesday 2017-01-11 or earlier)
#2

Preparation

Optional, recommended:

  1. log in to Lumina (not any other desktop environment)
  2. use the Boot-Up Configuration page of SysAdm to create a boot environment
  3. activate the new environment
  4. restart TrueOS
  5. if Lumina invites you to install updates at shutdown/restart time, decline the invitation; simply restart.

Suggested workaround

  1. log in to Lumina and be prepared to enter your admin password
  2. in a terminal window, run these two commands
    sudo pkg remove freebsd-examples
    sudo pkg-static install -f freebsd-runtime
  3. restart TrueOS
  4. if Lumina invites you to install updates at shutdown/restart time, decline the invitation
  5. after the restart, you can proceed with updates in the normal way.

Thanks to:

Live help

If you need it:


#3

Didn’t work here. When I do sudo pkg remove freebsd-examples I get Package(s) not found!. If I search with pkg the package is in the repo, but a pkg info and it can’t find it. Tried a sudo pkg update -f but pkg still can’t info or remove it.


#4

okay.

2 options.

  1. roll back to a good Boot Environment (BE) and update again.

  2. in the bad BE, update. and when it says hit CTRL-F2, do it. This will be the boring part. Watch the process, and see what, if anything has issues.

That’s how the group this weekend found out about “freebsd-example”.

I’m going to assume some file is interfering with the upgrade process, and right now you will be the only one that will be able to see it


#5

… no freebsd-examples logged in this case. …

– I decided to close that issue without a fix.

@goal I’ll not know whether your case has the same root cause as mine, sorry.

I left some things of possible interest in the troubleshooting room at https://gitter.im/trueos

Good luck.


#6

I am still too much of a novice to say anything about anything.

I have TrueOS installed on a 120 GB SSD ( PNY brand )… But Lumina or TrueOS says I am running out of space.
( I think 107 GB is used in Pool 1, but I have installed lots of stuff from the repository, that
I do not need, but am only testing those software to see what the do and how they behave. )

I plan to purchase a bigger SSD this year once I locate a good deal.

( I have never ran anything on a old HDD except Windows XP, and Windows 7 ) All my
Linux experience and Windows 8.0 experience and TrueOS experience has been on inexpensive
SSD’s.

I have no idea yet how to use ZFS. I plan to learn in the near future. Below is a link to my screenshot of
Disk Manager. Click on that link and click on image to enlarge.

New photo by Elstan “Cornelius” McFrolicker

#7

I have two previous BEs: The original install, and one ~week old. What will be the consequence of rolling back to the one a week old? Will I lose packages installed between then and now?


#8

@goal Without pressing Y to confirm the updates what is the output of sudo pkg-static upgrade? Is it showing a small list of packages that will be installed, and a larger set that will be removed?


#9
Number of packages to be installed: 1
Number of packages to be upgraded: 69

The operation will free 7 MiB.
241 MiB to be downloaded.

#10

What usually happens when I do the sudo pc-upgrademanager pkgupgrade is that the process says that deltas cannot be applied, and it then proceeds to re-install everything – very time consuming.


#11

@goal What is the 1 package that will be installed?


#12
	openldap-sasl-client: 2.4.44 [trueos-major]

#13

what happens is you attempt to delete it?

sudo pkg delete openldap-sasl-client


#14
No packages matched for pattern 'openldap-sasl-client'

Checking integrity... done (0 conflicting)
Package(s) not found!

#15

@RodMyers I think @goal does not yet have openldap-sasl-client he simply has something installed on his system that has changed dependencies, and now wants to install it. I suspect that conflicts with trueos-desktop. I just removed:

Having those as depends would cause packages like openldap to uninstall trueos-desktop. I am getting ready to upgrade my desktop, and I will attempt to install openldap-sasl-client to verify.


#16

i remember it was one of the the things discussed this past weekend.

edit:
on my UNSTABLE and STABLE system(s), it just wants to install “openldap-sasl-client”


#17

So after upgrading one of my systems to the latest STABLE I attemped to install openldap-sasl-client. I see there is a conflict:

openldap-sasl-client-2.4.44 [trueos-major] conflicts with openldap-client-2.4.44 [installed] on /usr/local/bin/ldapadd


#18

@goal I can confirm openldap-client-2.4.44 is required by trueos-desktop in the latest STABLE packages.

Installed packages to be REMOVED:
        openldap-client-2.4.44
        libreoffice-5.2.4_3
        nss_ldap-1.265_12
        pam_ldap-1.8.6_3
        trueos-desktop-201701182017

I would suggest either waiting out the upgrade until the next UNSTABLE push, or removing other DE’s, and packages from the system that may pull in OpenLDAP. Things like FireFox, Thunderbird, LibreOffice, VLC, VirtualBox seem to be safe. I would really like to know which package is trying to pull in openldap-sasl-client.

I have checked our ports-make.conf, and I do not see any recent changes in TrueOS that would have triggered openldap-sasl-client.

Here are the list of ports I can find which are currently set to use openldap-sasl-client:

In addition to removing ldap* packages trueos-desktop for the next UNSTABLE I suspect this change recently made upstream by FreeBSD may also help in the next UNSTABLE:


#19

Okay. I fixed it (in my case, pretty sure it doesn’t apply directly to the other instances of this issue):

Looking up openldap-sasl-client in the AppCafe, I can see in the third tab that it is required by ldb which is installed. ldb seems to be a dependency of the Samba suites, of which I tried to install and later uninstalled. A pkg autoremove did not delete ldb, so I uninstalled it and ran sudo pc-updatemanager pkgupdate and the update ran its course installing the expected 68 packages. After login in I ran sudo pc-updatemanager pkgupdate again, and this time it was clean.

NB: Is it possible to do a ‘reverse dependency’ look-up like AppCafe does, but in pkg? If it is, I can’t find it.


#20

pkg info -r name will give you the packages that depend on “name”

This may be a little out of date, but should be close:
https://wiki.freebsd.org/PkgPrimer