Haswell GPU vs FreeBSD 12 / TrueOS & my OS switching update


I have now verified that USB(1) support under vbox is indeed borked under TrueOS, at least on my machine. I have had some success with using USB under under Windows XP SP3 under vbox but it doesn’t work reliably enough for me to successfully copy the trueos USB installer image from a fat32 formatted USB drive, it always dies with some ‘missing parameter’ error part way through. I have had no luck with USB at all under vbox Windows 10 - W10 makes the noise to acknowledge a USB device has been attached but then nothing happens - no drive appears.

Luckily, it seems my laptops ACPI has the DMAR support required for bhyve’s PCI passthrough to work but again, no luck so far. All my attempts at getting bhyve PCI passthrough to work have resulted in kernel panics so far but at least Windows 10 seems to run nicely under byhve otherwise.

I now have a few issues with trueos that I think are beyond the scope of its devs and which necessitate me switching to official FreeBSD 12 CURRENT in order to help get them fixed:

1 - Kernel panics when trying to PCI passthrough a USB3 controller to bhyve

2 - Long delays between actions when using gmtp to transfer files to/from my Android phone - gmtp dev thinks its a libusb or kernel prob

3 - True OS installer/bootloader’s lack of support for creating custom partition before install (to leave room for Linux) and the bootloaders lack of support for chainloading Linux/GRUB

I suppose that last one could be two points really but they’re very closely related so I’ve bundled them together as one.

The machine I have been testing TrueOS on has a Haswell GPU and I will require this to still work properly when I install FreeBSD 12. Does the xorg in FreeBSD 12 CURRENT support Haswell GPUs like TrueOS does or will I need to fetch xorg from elsewhere to get the same X hardware support as TrueOS? Are there any instructions for doing this anywhere, if required?



Well, based on your list of issues I don’t see what moving to “pure” FreeBSD 12-Current directly will do for you, aside from some time-differences in builds and such you will be getting the same kernel, the same libusb, the same bhyve, the same bootloader, and the same ports (gmtp).

That being said, FreeBSD 11.0+ is supposed to support Haswell systems as-is, but with all the newer Xorg stuff starting to get committed to the ports tree fairly recently there might be some manual steps you need to take to ensure that the newer Xorg stack is working properly, but nothing from outside the mainline repo should be needed anymore AFAIK.

EDIT: For context about the gmtp issue @danboid mentioned, you can view the ticket about it HERE.


Hi beanpole

I’m contemplating moving to FBSD 12 so that I can report these bugs upstream and hopefully get them fixed. As you know, I reported the gmtp problem on the trueos github issue tracker but the conclusion was that I should test it under regular FBSD 12 to see if the same problem is present there. AFAIK non of the TrueOS team are also bhyve devs and so I would inevitably get the same response if I reported my bhyve kernel panics on the trueos github tracker and if I tried reporting it on the Freebsd.org tracker they would undoubtably refuse to support me unless I was running official FreeBSD, right? Do you have any tips for getting PCI passthrough working with bhyve under TrueOS?

Nobody ever answered my questions about the bootloader on this forum ( Dual booting TrueOS and Linux on a BIOS machine ) so again I presumed I would be forced to test against with regular FBSD if I want upstream to respond to my issues.

You don’t sound very certain on my chances of getting X working OOTB under CURRENT. I’m certain my Haswell GPU isn’t supported under FBSD 11, at least it wasn’t accelerated last time I tried. I guess I’ll just have to try it and hope for the best.



ok, that makes sense then just so that upstream takes your issues a bit more seriously… :wink:

I don’t think the X11 setup for FreeBSD itself will be that hard - it just won’t be as “automatic” as on TrueOS.

My recommendations:

  1. sudo pkg install lumina
  2. sudo Xorg --configure
  3. Open up the “/etc/X11/xorg.conf” in an editor and change your “Driver” line near the bottom to the proper driver.
  4. echo "start-lumina-desktop" > ~/.xinitrc
  5. Simply run startx to start a new graphical/lumina session after you login to your user account.

Note: Steps 4/5 can be replaced by the use of some other graphical login manager like SLiM, GDM, KDM, etc…


Thanks beanpole

I know how to configure X, I was just wondering if any external repos or out-of-tree patches were responsible for the X we see in the latest TrueOS? From what you say, probably not.


Yesterday I installed FreeBSD 11, did all the freebsd updates and today I installed the ‘world’ and kernel from head / FBSD 12.

FreeBSD 11 claims to support the Haswell GPU but its not fully supported - the main issue I have is that I can’t set my 4K monitor to any higher res than 1080. True OS lets me set it to its full 4K res. Today I updated to the head (FreeBSD 12) kernel and world but my 4K display is still hobbled to 1080 as the max res.

I’ve not tried rebuilding X yet but I’m not so confident that would fix it. My suspicion is that TrueOS is using an unofficia/external (to FreeBSD)l repo to source its X build.

Could you check with Kris please Beanpole?



Is DRM-Next already integrated into CURRENT? That is one of the big differences between TrueOS and CURRENT for me: DRM-Next is already there and I don’t need to have to do something about it. I guess that is the reason you are stuck on 1080p since you have to use the vesa-driver instead of the DRM-Next-driver.
I think you have to look here: https://github.com/FreeBSDDesktop/freebsd-base-graphics/wiki to get decent graphics in CURRENT


That is what I was looking for nielsk!

I’m hoping to get everything running as I want under trueos but at least I know what the ‘hard way’ is now too.