Got The Weird Graphics Problem


#1

I downloaded Trident 18.12 Release last night and am trying to install it, but I seem to have the problem noted by Kris in the Downloading Notes, where moving my mouse causes the screen to go bonkers with what looks like sparkly confetti.

My system is a 10 y/o Gateway 64 bit AMD dual core with 6GB ram. I am using a 500 GB HDD, on which I have had True 18.03 previously. My plan is to put Trident on it as single boot drive. It uses traditional bios, not UEFI.

I noted the tip to run a command prompt and put in ‘gop set 1/2/3/4’ etc until finding resolution that works, but I can’t figure out how to do that. At first boot, I get stuck at the 6 different boot options, and can’t see how to go to a CP. So it ends up booting. Then I go to the terminal, but I don’t know how to log in.

Anyone else having this problem, and any advice on what to do?

Thanks,

Mike


#2

when boot menu show, hit space, then 3 (I think)

gop list

will show what options are available

gop set <insert # here>

then enter, then type boot


#3

Thanks Rod, but I could not get it to respond to those commands. I found however that I could proceed with install despite weird graphics. First time install failed, second time it succeeded. However, it wants me to log in before actually getting to a login screen (in other words while it still is just text). However when I put in name and password it says incorrect. Not sure what to do now.


#4

I tried logging in as root and put in the password, and it went through, so I think that means the password is correct. but it leaves me still not knowing what to do next. I still have no GUI. (In other words I can’t get out of command prompt env.).


#5

Maybe is keyboard layout problem?


#6

Hard to say, it was difficult to see the options during install, but I thought that going with the defaults would work. Anyway, I can get into Free BSD as root. I get the “Welcome to Free BSD,” and can access the manual etc. So I just need to figure out why login is getting rejected, and I have no GUI. Maybe I should just reinstall, and be more careful with user name and password?


#7

Do you try start-lumina-desktop?


#8

I’ll give that a try, thanks.


#9

It didn’t help. got a bunch of error messages. One of them was "no such screen.


#10
Please post the output of about
contents of /var/log/Xorg.0.log
John
groenveld@acm.org

#11

It would be a good idea to also post the manufacturer and model of your video card/GPU.


#12

Thanks for the help, but I think Trident may be more operating system than this aging old Gateway can handle. I decided to try Ghost BSD, which is now based on True. It is like True with Mate instead of Lumina. So far it’s working fine, and is half the size of Trident. My computer definitely likes it better.

I plan to revisit Trident somewhere down the road, but probably with a newer computer with better graphics.


#13

That’s interesting; from what I have seen Qt-based DEs can be less resource-hungry than GTk-based environments. I say can because KDE… but even that doesn’t need all those resources all the time. I’ve run KUbuntu 14.04 with a full Plasma4 desktop on a comparable HP laptop and that worked fine (it would probably still be in use if it hadn’t died).

I’m guessing something other is going on here than the DE used, but if you’re happy with your current solution, stick to it!