Google Maps not useable on Trident when system language is set to german (de_DE)


#1

The maps on google maps do not show up like before (once upon a time). For example on https://www.google.com/maps/dir/Flores,+Portugal/39.491402,-31.2839628/@39.3866198,-31.1888153,15z/data=!4m9!4m8!1m5!1m1!1s0xb3223bfc7735fe7:0x307045cfd78fa9d0!2m2!1d-31.193945!2d39.4474713!1m0!3e0
I get nothing but this:


Tried it with firefox and falkon - same useless result.
On the other hand the same map on spotwalla.com (I guess they use the same data) shows up like it should:
The satelite view on google maps is just a black screen while on https://spotwalla.com/tripViewer.php?id=1632559abf5ab39abc&hoursPast=0&showAll=yes the view is good.

In earlier times google maps has worked on TrueOS - but I don’t know when it stopped to do so. Wonder if this is a technical issue or whether Trident/TrueOS/BSD is sabotaged by google?


#2

clear you cache.

i just clicked on the link, and it shows


#3

Cleared my cache, didn’t help. What browser do you use?


#4

Sorry, I see Mozilla Firefox - hm


#5

that was firefox.

iridum shows map with road

falkon shows map with road

chromium shows map with road


#6

You are a lucky guy!
I logged out, changed the language setting to en_US, logged in -> google maps works now.
Would you like to try de_DE (German)?


#7

I have had a similar issue on Mac OS X ten years ago with rendering vector graphics in the browser. This with an application on a government site in France that only worked if the system language was set to French. In Mac OS X the bug has been fixed.

I’m almost sure it worked well with TrueOS (desktop), maybe even with early Trident versions - what has changed since then in terms of system language processing?


#8

nothing that I’m aware of. Still based on trueos, but FreeBSD 13.* instead of FreeBSD 12.*


#9

The issue does not occur with firefox-esr-60.5.1,1.

Does anybody else have issues with google maps when language is set to something other than en_US?


#10

With your link and localisation other than en-US:

TrueOS legacy 18.03:

  • Otter browser: map looks as it should (like your 2nd screenshot).
  • Falkon/Firefox (58.something): map looks as it should up until the page is finished loading, then the content of the map disappears completely, as in blank. But the command elements are still there, as is the left hand slider.

Trident U5:

  • Otter browser: map looks as it should.
  • Falkon (Firefox not installed (don’t like it)): map looks as it should up until the page is finished loading, then it looks like on your first screenshot.

#11

Thank you! It’s good to know not to be the only one.

Otter browser looks good and I would like to use it instead of firefox, but I’am used to work most of the time with the bookmarks-panel (in firefox) and I seam to be too dumb to do so with Otter.