Getting the Uzbl Browser Usable on TrueOS Stable


#1

Searching for Uzbl here on discourse.trueos today had no results, so I’d like to share my experience so far.
Installing the package via AppCafe was flawless but clicking on the new application icon opened an empty window only.
To get any kind of hint about the obstacle I entered the command uzbl-tabbed in a terminal:

[rudy@trueos-7819] ~% uzbl-tabbed
Traceback (most recent call last):
  File "/usr/local/bin/uzbl-event-manager", line 11, in <module>
    load_entry_point('uzbl==201100808', 'console_scripts', 'uzbl-event-manager')()
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 561, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2631, in load_entry_point
    return ep.load()
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2291, in load
    return self.resolve()
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2297, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/local/lib/python2.7/site-packages/uzbl/event_manager.py", line 48, in <module>
    from uzbl.daemon import UzblEventDaemon, PluginDirectory
  File "/usr/local/lib/python2.7/site-packages/uzbl/daemon.py", line 3, in <module>
    from uzbl.net import Listener, Protocol
  File "/usr/local/lib/python2.7/site-packages/uzbl/net.py", line 5, in <module>
    import six
ImportError: No module named six
Error: Could not start uzbl-event-manager

Trying to start the uzbl-event-manager manually produced the same ImportError. In line 5 the file .../uzbl/net.py is trying to import a module with the name ‘six’.
Good luck in AppCafe you can find it:
PyModule-six2017-11-07-17-48-45
After installing this package the Uzbl browser was successfully launched but produced this output:
uzblSSL2017-11-07-18-16-29
Within the /usr/home/{user name}/.config/uzbl/config file there is the setting:
set ssl_ca_file /etc/ssl/certs/ca-bundle.crt
There is no ‘certs’ directory on my system but in /etc/ssl is the file cert.pem.
So I removed the original setting and inserted:
set ssl_ca_file /etc/ssl/cert.pem.
Now the Uzbl browser opened the start page:

Yes, it looks like a working application now. Even it was possible to add my favourite search engine ‘Qwant’ to the default ones. I just added the line:
@cbind qw<Qwant:>_ = uri https://www.qwant.com/?q=\@-JSON.stringify(encodeURIComponent(%r))-\@
to the config file.

By the way this post was written in the Otter browser because it is kind of tedious to log yourself manually into this discourse time and again and in Uzbl the binding for passwords doesn’t seem to match with the login mechanism of discourse.