Fresh install, can't ssh in from ubuntu


#1

Hiya,

Did a fresh install for a friend at work and everything works fine, except for the fact that he’s one who has to ssh in from virtual machines on his mac. We’re trying to ssh in from an ubuntu virtual machine and keep getting this error on the TrueOS side:

Fssh_ssh_dispatch_run_fatal: connection from ww.xx.yy.zz port 40794: Broken pipe [preauth]

I can ssh into this box from numerous local machines, no problems.

Anyone recognize this?


#2

try ssh’ing from trueos first. may help

what are the ssh options they are using?


#3

Where is that message received?


#4

You may have to check your TCP wrappers options on the TrueOS machine (/etc/hosts.allow). There may be an option that it won’t allow machines to that don’t resolve to a reverse DNS to connect. This is probably an OK option, but when you are on a small local network without local DNS, this can cause some confusing ssh connections.

But I just looked at the current one and I can’t see anything obvious.


#5

That probably explains why I sometimes can’t ssh into my TrueOS box from other machines on my network, which is really annoying. By default, my TrueOS box is going through a VPN, so it doesn’t use the local DNS, and I usually have to add hosts to the /etc/hosts file for it to recognize them. Regardless, normally, the only boxes sshing into any of the boxes on my local network is other boxes on my local network, so caring about stuff like host names matching or that the keys on a machine changed (e.g. because the OS was reinstalled) is just plain annoying, even if it makes sense when you’re dealing with the internet at large.


#6

Normally SSH is disabled by default, at least this is my experience in running TrueOS as a server.